9 Replies Latest reply: Oct 2, 2010 11:29 AM by billearl
martinneep Level 1 (5 points)
I have a problem whereby I cannot get OS X to recognise British English words as correct.

System Preferences>Language&Text>Text>Spelling is set to British English.

However, when I type words like 'colour' and 'recognise' in mail, text editor etc... they are underlined in red as incorrect.

I have just spent over an hour with AppleCare, and they think that a complete re-install of OS X maybe the only solution. I really, really want to avoid this at all costs!!

Has anyone else come across this problem and if so, what was the solution?

Many thanks in advance,

Martin Neep

Message was edited by: martinneep

27" iMac, Mac OS X (10.6.4)
  • Antonio Rocco Level 6 (10,517 points)
    Hi

    Apple Mail > Edit Menu > Spelling & Grammar > Show Spelling & Grammar. Where it says "Automatic by Language" (it may say something else) click on it and you'll see a pop-up menu appear. Select British English.

    Tony
  • Tom Gewecke Level 9 (77,160 points)
    If Antonio's suggestion does not work, try installing the OED dictionary from this site and then make sure your dictionary is set to that -- it may be called English (Library) in the menu.

    http://wiki.services.openoffice.org/wiki/Dictionaries

    (You put the .dic and .aff files in Home/Library/Spelling)
  • martinneep Level 1 (5 points)
    Sorry, but this doesn't work. I went through absolutely everything you could think of with AppleCare
  • martinneep Level 1 (5 points)
    I don't really want to install a 3rd party dictionary as a 'work around' and don't really see why I should.

    What I don't understand is that the chap at support said that they were having the same problem on other machines built around a similar time as mine and he suspected a 'bad batch'? What does this mean? A bad batch of software??

    If they walk me through a re-installation from the same installation disk, surely I'm going to end up with the same problem, which would be a total waste of time!

    I know it hardy seems worth worrying about, but when you use your Mac for large amounts of text input, having the correct dictionary makes quite a difference.
  • Chris SHIR Level 1 (5 points)
    I have mine set to another local that supports British english: Au Nz and some of the Islands around there. Works fine for me in all programmes beit safari, word, pages, chrome ect...
    But yeah I had that issue as well
  • Tom Gewecke Level 9 (77,160 points)
    I know it hardy seems worth worrying about


    On the contrary, I think it is extremely important. On the other hand, being unwilling to possibly solve the problem by spending a few seconds downloading and installing another dictionary doesn't make a lot of sense to me.

    Here is the end of another recent thread on this:

    http://discussions.apple.com/message.jspa?messageID=12308362#12308362
  • martinneep Level 1 (5 points)
    Tom, I guess you're right. I've installed the OED from the link above and it has solved the problem. Maybe the issue will be fixed in a future update, who knows? Until then, I'll stick with this work-around; I really can't face a doing a re-install.

    Thanks again everyone!
  • Pondini Level 8 (38,740 points)
    martinneep wrote:
    . . .
    I really can't face a doing a re-install.


    You can easily re-install just OSX -- in fact, the old +Erase and Install+ option doesn't even exist in Snow Leopard. There's just Install. It loads a fresh version of OSX and deletes the old one, period. Your 3rd-party apps, users, data, settings, etc., are not touched (although it's strongly recommended to have good backups, just in case, but then you should always have good backups.)

    Then you'd need to download and install the 10.6.4 "combo" update. That's the cleverly-named combination of all the updates to Snow Leopard since it was first released, so installing it should fix anything that's gone wrong since then, such as with one of the normal "point" updates. Info and download available at: http://support.apple.com/kb/DL1048 Be sure to do a +Repair Permissions+ via Disk Utility (in your Applications/Utilities folder) afterwards.
  • billearl Level 2 (175 points)
    I had the same problem, but with 'Canadian English'. It was annoying having "colour" flagged as incorrect.

    In my case, the root of the problem was in using Monolingual to strip out languages other than 'English', specifically in the file /System/Library/Services/AppleSpell.service. I used the Mac OS X 10.6.4 Combo Updater to restore the unaltered AppleSpell.service file, whereupon the System Preferences>Language&Text>Text>Spelling setting actually worked properly.

    Setting Monolingual to exclude the /System/Library/Services/ folder prevents this problem from reoccurring.