Previous 1 5 6 7 8 9 Next 128 Replies Latest reply: Feb 13, 2014 11:48 AM by quinncom Go to original post
  • dmoser71 Level 1 Level 1

    All, I think I have a solution. I did a fair bit of troubleshooting and discovered what was going on in my case. I had three calendars that I shared with my wife when we were both on MobileMe. I upgraded to iCloud/Lion first. No problems - but we couldn't see each other's calendars as expected. A few weeks later, I upgraded my wife to iCloud/Lion. Her Calendar then started having those 403 errors everyone is talking about. I tried turning the iCloud Calendar feature on and off, and even signing in and out her iCloud account in System Preferences to no avail. I even deleted the shared calendars from her system and re-added them again. Still, was getting the 403 errors. I noticed that two of the three calendars were disabled when I created a test event to then try and switch the event onto the shared calendars. Aha, I thought. I now know only two calendars have a problem. So, when I deleted the calendars no more 403 errors. But, if I re-add them, I get the 403 errors again.


    The solution is this: I deleted the shared calendars from my wife's iCloud calendar list and then logged into my own iCloud account. I stopped sharing the two calendars in question and re-shared them again to my wife's iCloud e-mail address. Lo and behold, the new invitations took just fine and now, no more 403 errors. So, the source of the problem would appear to be a server-side permissions or backoffice kind of problem. The workaround is to delete the sharing properties (i.e. stop sharing) and then re-share the calendars again. I think maybe now with this information, Apple should be able to home in on a real fix but until then, try this workaround.

  • Larry Daniele Level 1 Level 1

    Thanks, dmoser71. Your solution worked for me.

  • Sidelines Level 1 Level 1

    I cannot get rid of this error.  And I notice if I login to icloud directly my calendar has all entries.  But on my mac when I display the calendar many entries are not showing up and the error occurs.


    Where are you deselecting sharing of calendars?  I tried deleting events that ran into the future that the error highlighted but they pop back up again.

  • dmoser71 Level 1 Level 1

    My solution is only valid when you are having problems accessing calendars shared from one iCloud account to another iCloud account. If you are having problems accessing your own iCloud account calendars, then my solution doesn't apply. Since I have not ever had the problem you are describing, I don't know how to offer a solution. Sorry I cannot help you out. Hopefully, you can go to an Apple store and show the genius what's going on and maybe he can open up a support ticket to get your account fixed. Just a suggestion.

  • coach_chad Level 1 Level 1

    I'm having the same "403" error, but it is specific to an icloud address.  There is no calendar sharing with this address.  It seems strange because this just cropped up recently.  There are other events that I have been successful in linking with this address.

  • Apiarnaud Level 1 Level 1



    maybe your DocumenRoot isn't configured, or is not in the ~User/Sites repertory ?


    Good luck !


    logiciel immobilier

  • Metagrapher Level 1 Level 1


    "Hello guys.

    Why don't you wanna follow my work around?"


    JoeMacII, your workaround involves purchasing other software, not making this software work, so it's not a real workaround.  Thank you for playing.

  • futiefutie Level 1 Level 1

    I haven't got a solution yet, but I think I know what my problem was with this error.


    I had two calendars in my iCloud account which I wanted to merge, so I exported one to an .ICS file, and imported into the other. Cue errors all over the place whilst it tried to sync with iCloud:


    The server responded with an error.

    Access to "APPOINTMENT" in "CALENDAR" in account "ACCOUNT" is not permitted.

    The server responded:


    to operation CalDAVWriteEntityQueueableOperation


    Ignore | Try Again | Revert to Server


    If I click 'try again' then the same error occurs, if I click 'Revert to Server' it seems to delete the offending appointment and move on to the next one! Not much use ..


    So I took a look at the console whilst iCal was syncing and I found a whole load of XML, but in there was the following:


    Found component XXX.ics with same UID in a different collection: YYY.ics


    Looking at the iCalendar specification it clearly says: "The UID itself MUST be a globally unique identifier". I also checked out the .ICS file which I created - it includes a UID for many (if not all) entries.


    In summary, I think this means:


    If you export a calendar from iCloud and attempt to re-import without first deleting your old calendar entries (even if they are in another calendar), iCloud will realise that it already has the appointments and stop you from recreating them. I'm guessing the solution is either to:


    (a) Delete your old calendar after you've created the .ICS file and before you import, or

    (b) Remove all the UID entries from the .ICS file before you import

  • quinncom Level 1 Level 1

    I had this same error in my console, "Found component /8547024/calendars/89FED87B-8E01-4E81-A699-AAC8605B3311/040000008200E00074C5B71 01A82E00800000000B04B502E0E24CF01000000000000000010000000AF32BD88D5049B4F9400A3C 71E8FBFC0.ics with same UID in a different collection." I couldn't find any events in my calendar that might be a duplicate of this one. I solved this by clicking the 'Revert to server' button, removing the just imported .ics file. Then I opened the .ics file in a text editor and change the "UID" value by one digit, e.g., from:








    And then opened/imported it again, successfully.

Previous 1 5 6 7 8 9 Next