Previous 1 2 3 4 5 Next 73 Replies Latest reply: Mar 5, 2015 9:21 PM by xe4 Go to original post
  • arikreiss Level 1 Level 1 (0 points)

    I have the same problem. Airport Extreme base station, airport express extender. Extreme network speed is 15-20Mbs, extended segment through express is 0.3Mbs. Previously had a TC with 3 expresses and still same problem


    I've been googling for months trying to find a solution and this is a widely reported problem. Extended network segments are very slow.


    Surely Apple should recognise this and propose a solution...?

  • SumDikNamedRich Level 1 Level 1 (20 points)

    Has anyone here tried playing around with channels in Airport Utility for the main base station? Wireless interference can almost always be a factor and if you have other devices like cordless phones, baby monitors, neighboring networks, etc..., if they are running on the same channel as the main base station, things can get a little wonky when it comes to dependable connectivity!

  • arikreiss Level 1 Level 1 (0 points)

    I played with channels last night. Some random variations in performance but really they are merely some noise around the figures I quoted earlier, nothing meaningful. The Auto setting still works best. There is also an interference reduction setting option which I have had on for some time, but that has also not shown a meaningful improvement.


    The speed difference between the core and extended network is almost 100 times.

  • Dr Jam Level 1 Level 1 (0 points)

    I am also having this same issue. I have a Time Capsule router which has extremely fast connection with Comcast as my provider, then I have Airport Express set to extend the network. My connection speed sadly drops to 1/10th the speed or even slower when my laptop is closer to the Airport Express. I pull it out of the wall and (sitting in same spot) immediately my speed multiplies when connecting to the original router.  I can download about 3MB/sec when I'm near the Time Capuse and then speed drops to about 100KB/sec or less, plus lots of lag time, when I'm by the Airport Express.


    And I don't think other potential network interference has anything to do with it.  I am in a new subdivision and the only house on the block; closest house to me otherwise is over 1/4 mile. I hope somebody finds an easy fix to extending a network without losing all the speed.

  • lunieri Level 2 Level 2 (270 points)

    I assume you've read this thread and have looked at the possibility of interference and also made sure that your Extreme and Express are both using the 'fastest' 802.11 mode N. on the 5Ghz band

    Here's some suggestions:

    1. In order to 'lock-in' the use of 802.11 N mode, hold down the option key when selecting the radio mode on the wireless tab of the airport configuration utility. Select the 802.11n only (GHZ) - 802.11b/g/n mode. This will set the 5Ghz channel to use only 802.11n while allowing older devices to use the 2.4Ghz b/g/n modes.

    2. set the multicast rate under the wireless network options menu, to High. but be careful here. This means that you will need a strong signal to connect to the device so you're effectively shortening your range. You're sacrificing range for speed.

    3. I suggest getting a utility like iStumbler and using it to see what network channels are busy in your environment and select one that are not crowded via the manual radio channel selection option on the wireless menu of the AirPort configuration utility.


    Before doing ANY of the above suggestions, I highly recommend that you use the airport utility to first SAVE a copy of your configuration file for each device in your network prior to tweaking any settings. And any settings should be changed via a computer that is connected to the device by an ethernet cable (wired connection) and not a wireless one.  If you run into any problems you can then import your working configuration and get things back to normal.


    The bottom line is that NO wireless connection will be as fast as a wired one. but if you take the time to tweak your network carefully you'll get the best performance possible.  Wireless network speed is based on having good signal strength at the receiver. but even with two wireless devices sitting side by side, you will not get speeds as good as a wired connection. The translation of your data into an RF signal and back out again takes time and is subject to lots of checking, encryption, and so on.

    When you extend a network wirelessly, you're doing all of those things twice. Once from the computer to the airport express and again from the express to the time capsule.

    If it's possible to extend your network by having a wired internet cable run between the express and the time capsule, I suggest you do that. You'll get better results.

    Good Luck

  • Roy 42 Level 1 Level 1 (0 points)

    Wonderfull, I also bought the Express and the network went from 4MB/s tot 400KB/s if I am lucky. Great buy, since it's quite an expensive setup with an Airport Extreme and an Express and no solution since more than 9 months.

  • lucfromvancouver Level 1 Level 1 (0 points)

    Still no solution to this?  I recently purchased an Airport Express to extend an Airport Extreme.  I extended wireless network and everything started to slow.  Even my wired connections slowed.  I started pings to the server and found half my packets dropped and some packets were coming back with latency in the thousands.  I called apple.  We reset both devices.  Set up the network again.  Found the same problem and he asked me to return my Extreme.  I tested without the express and it was fine.  Brought the express to my home and tested it on my own Extreme.  Cabled from 6 feet away and found the same results.  Went back to Future Shop and exchanged it.  Found exactly the same problem with the new one on both networks.  Does extending work?  Has anyone got it working satisfactory?

  • Jeremy Davenport Level 1 Level 1 (0 points)

    I've been having the same problem.  Until recently I was using two 802.11g Airport Expresses to create a wireless network, with no serious trouble.  Bought an Airport Extreme and an 802.11n Express to enlarge the network, with everything connected via ethernet and each unit creating its own network.  All of a sudden my connection started dropping out and streaming became impossible.  I had a full wireless signal on the menu bar, but the only way to connect was to plug my MacBook into the network via ethernet. I found this thread today, and have reset all the channels manually so each Airport is on a different channel and - bingo!  Everything (so far) seems to be working well!

  • Hazletone Level 1 Level 1 (5 points)

    Exact same problem.  Been battling this for months and it is driving me insane.  Airport Express is extending my Airport Extreme. Both N devices. Airport Extreme easily clocks in at 20+mbps whereas at the exact same time my Airport Express is .3 mbps.  And I live in the country, with no nearby neighbors of any kind and I've gotten rid of the cordless phone, sought out possible interference, nothing. I do notice when the microwave is on everything shuts down, but i'm not cooking TV dinners 24/7 so I can live with that.  And it would seem everything in my house wants to jump on the express so I've even had to go so far as to lock out the mac address of my iMac so I can have at least one device that doesn't slow down like a commodore 64.  I've tried changing channels to no avail.  I've read the responses above and none of them offer me any solution as far as I can tell, but there has to be something to this, right? 



  • Hazletone Level 1 Level 1 (5 points)

    I finally found a workaround to this issue. It cost me $108.24.  The Belkin AV500 Powerline adapter hooked to my Express with the following settings. 


    The correct settings on your Express would be:


    AirPort Utility - Manual Setup


    Click the Wireless tab below the icons. Settings should look like this:


    Wireless Mode = Create a wireless network  (NOT Extend a wireless network)

    Wireless Network Name = Same name as your main network

    Check mark next to Allow this network to be extended

    Radio Mode = 802.11n (802.11 b/g compatible) a good choice

    Channel = Automatic

    Wireless Security = Same setting as the main network

    Wireless Password = Same password as main network

    Confirm Password


    Click the Internet icon

    Click the Internet Connection tab. Settings like this:


    Connect Using = Ethernet

    Connection Sharing = Off (Bridge Mode)




    You must restart the entire network now


    After you do this your express should now run at a good clip assuming the AV adapter is receiving the internet signal over your power line from your router. 


    After spending countless hours trying to correct this problem, I believe the only solution is to throw money at it.  I'm now seeing speeds of 15-20mbps on all my N devices. I even got 3+mbps on my G Wii.  For once throwing money at the problem paid off.  No thanks to Apple of course but oh well, I finally have a wireless network that truly works at an extended range.



  • lunieri Level 2 Level 2 (270 points)


    you have created a roaming network, not an extended network. they are different.

    I think people on this thread may not understand the difference. They may be experiencing poor performance because they don't realize that their express devices will have to relay to the extreme. this means that they need to have a solid connection between them for it to work well. the extending device should be placed half way between the area you want to extend to, and the main/extreme device. The other thing to realize is that even the new express devices are NOT simultaneous dual band devices, they are single band devices, and if you have a slower 802.11a device connected to them, then they will use that protocol to connect to the main device.  when you want 802.11 g or n speeds, ALL of the devices on the extended network need to be the same protocol.

  • konstant10 Level 1 Level 1 (0 points)

    It looks as if the purpose of this threat is to collect as many users with the same problem as possible, without helping nobody. Well, plus one.. Same problem, but just within the local network. Internet works well. Checked on different OS.

  • Brain2000 Level 1 Level 1 (0 points)

    I'll join.  We have two Airport Extremes that are 50 feet apart looking at each other in two windows, running 802.11n.  The connection I get between them listed by clicking the "Clients" is between 1 and 20.  The computer can hook to either of them at speeds easily above 100.  They just refuse to talk to each other.


    Note, this is out in the woods.  There isn't anything to interfere.  Unless the stove is busy talking on channel 11.  These things are junk, I'm going back to my WNDR3700.  It has its own problems, but at least I can get bandwidth.

  • CarloBalla Level 1 Level 1 (15 points)

    Plus one...

  • CarloBalla Level 1 Level 1 (15 points)

    I played with settings (band, channel, etc.) and the transfer rate was much better. I tried to put the same settings of the beginnig and... now it is OK!!!

    Before it was VERY slow... maybe there is some bug...