Skip navigation

Airport Express - Very Slow Connection

79059 Views 69 Replies Latest reply: Apr 12, 2014 9:55 PM by biggie69 RSS
1 2 3 ... 5 Previous Next
Arash Zafarnia Calculating status...
Currently Being Moderated
Sep 26, 2010 4:05 PM
Hi,

I just purchased an Airport Express three days ago.

My ethernet connection works great and very fast.

My wireless connection through the Airport Express is full strength.

My wireless connection is incredibly slow. I don't think it has anything to do with the websites I visited - I have tried it with several, unrelated websites - they all load slowly. It typically takes 20-30 seconds for the complete page load. The etherent connection loads the same pages within two seconds.

I have tried loading the same pages in Safari, Firefox and Google Chrome, and they all load slowly.

Lastly, I have tried to load the same pages on my roommate's PC and they load incredibly fast.

Anyone know how I can fix this?

Thanks,
Arash
Macbook
  • Mountain High Mac Calculating status...
    Currently Being Moderated
    Sep 26, 2010 8:25 PM (in response to Arash Zafarnia)
    I have the same problem. I use the express to extend my network from my airport extreme and it is painfully slow whereas the extreme is very fast. It doesn't matter what computer I'm using.
    Macbook, Mac OS X (10.6.4)
  • Frank Dillon Calculating status...
    Currently Being Moderated
    Oct 10, 2010 1:02 PM (in response to Arash Zafarnia)
    I have exactly the same problem with AirportExpress. I think it may be a configuration issue but I would really appreciate any help.
    Macbook pro, Mac OS X (10.6.4)
  • debeenus Level 1 Level 1 (5 points)
    Currently Being Moderated
    Oct 14, 2010 10:18 AM (in response to Arash Zafarnia)
    I'd like to bump this question as I am experiencing the same problem.

    Just bought the Airport Express to boost up my wireless Time Machine network located downstairs. I plugged the Express in and configured it to support the current network. If I run a Speed Test through the network downstairs today, my speed is between 6 and 7 Mbs. If I use the same network and run the same Speed Test I am lucky to reach 1 Mbs

    On both floors I am seeing the max number of bars possible, so that shouldn't be the issue.

    One additional point, besides the 'Time Machine network' I am also able to select/use the modems/router network. If I do the same Speed Test upstairs through this network it scores just as high as downstairs....

    Anyone?

    Thanks,
    MacBook Pro, Mac OS X (10.5.7), Also a regular Macbook 13 inch
  • Redsox542 Calculating status...
    Currently Being Moderated
    Oct 14, 2010 10:42 AM (in response to Arash Zafarnia)
    I have the same problem. I am trying to extend the range of my Airport Extreme network using an Airport Express. I have full signal strength in the Airport icon at the top right corner of my screen, but a terribly slow connection (.5 mbps download speed). I have read all over these forums, and what I have read over and over again is an Apple representative stating to apply the appropriate settings and/or switch the channel/check for interference. I have done all of these things and have basically no interference.

    FYI: I am using an Airport Extreme N-Router as my base station, and an Airport Express b/g to extend it. Can it be that because I am using the old Express that I am having issues. Is it not compatible with the new Airport Extreme to extend the network? I also read somewhere that if both the N-version of the Airport Extreme and Express are used together, one as a base and the other to extend, that the wireless connection can be extended without using WDS, and the connection won't be "cut in half." Is this possible?

    I am thinking about exchanging my Extreme for a new one. All help is appreciated. Thank you.
    Macbook Pro (Intel Core 2 Duo), Mac OS X (10.6.4)
  • Bob Timmons Level 9 Level 9 (75,675 points)
    Currently Being Moderated
    Oct 14, 2010 10:55 AM (in response to Redsox542)
    I also read somewhere that if both the N-version of the Airport Extreme and Express are used together, one as a base and the other to extend, that the wireless connection can be extended without using WDS, and the connection won't be "cut in half." Is this possible?


    Sorry, but this information is not correct. If you have an older "b/g" Express, you'll need to configure both the AirPort Extreme and the Express to participate in a WDS setup. Unfortunately, WDS is a "g" technology, so if you choose to go with this setup, your AirPort Extreme "n" will become a "g" router. In addition, the bandwidth on the network will be cut by 50%, as you note.

    You can only use the "extend" setup if both of your devices are newer "n" routers.

    If your devices are not configured as a WDS setup now, then your network is not extending and it's also likely that the incorrect settings are affecting your connection speed. If you can, you need to move up to an "n" AirPort Express to allow your network to function at maximum performance.

    Message was edited by: Bob Timmons
    MacBook Pro, iMac, Mac OS X (10.6.4), Time Capsule, AirPort Extreme, AirPort Express, iPhone
  • GDMACK Calculating status...
    Currently Being Moderated
    Oct 17, 2010 10:42 PM (in response to Bob Timmons)
    I am having the same problems. Airport Extreme is very very fast in a wireless connection. I extended the range with an new Airport express (yes it is n)using the "Extend A Network" switch, and the download speed on my laptop at that end of the extended network is really slow, as in 1/4 of the speed of the Airport Extreme. How do I make the extended wireless network with the Airport Express as fast as the Airport Extreme? It works fine, it is just slow. If I move my MacBook Pro near the Airport Extreme the wireless speed of the download quadruples compared to the Airport Express, even though they are both running "n" in technology.
    iMac, Mac OS X (10.5.3), 3.33 ghz
  • idon\'tknowXYZ Calculating status...
    Currently Being Moderated
    Oct 18, 2010 2:37 AM (in response to GDMACK)
    I am having the same problems.
    I am totally fed up with the slow/non-happening airport connection with my MBP. Connection happens randomly after 20 minutes if I'm lucky.
    I am exploring the possibility of fixing this myself, with paper clips, woodglue and cellotape, because I'm sure there is some DIY fix for this. Obviously a more hi-tech solution is impossible, because after 2 months of this blasted problem I have given up all hope.
    What totally gets me is that it was working all fine before I did NOTHING and now it is totally useless $3K worth of junk.
    Mac can do better.
    (Ps did all the obvious: reset, repair permissions - what else is there?????? moan)
    MacBook Pro
  • idon\'tknowXYZ Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 5, 2010 5:37 PM (in response to idon\'tknowXYZ)
    -Bump-

    I'm having real problems connecting my MacBook Pro to my Airport network. Connection can only be achieved via ethernet cable to the ADSL modem, but doing so requires waiting for 5-10 minutes (occasionally up to an hour) and toggling between Airport On and Off in the taskbar. Eventually the four bars in the Airport icon to go from greyed out to full. Then it takes a couple more minutes for Safari and Mail to load. Once established, I can then continue the connection wirelessly.

    At all times, trying to connect via password fails due to timing out. Successful connection via ethernet just 'happens', after this wait.

    Connection drops out after the computer has been inactive for a while.

    I've tried the following: resetting PRAM (holding down Command, Option, P & R during startup), repairing permissions, resetting Airport and ADSL Modem, installing newer Airport firmware, physically siting my computer next to the Airport.

    There's no problem connecting to other wireless networks, eg. at cafes, university. Another Mac in the same room, my daughter's MacBook, connects fine - but it's not on Snow Leopard. I'm on OS 10.6.4 and praying there's going to be a software update fix.

    Please, is there someone who can help?
    MacBook Pro
  • Kell1 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 12, 2010 11:49 AM (in response to idon\'tknowXYZ)
    I have this exact same issue it's scary to see no one has any answers i feel i wasted my money.
  • idon\'tknowXYZ Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 15, 2010 4:10 PM (in response to Kell1)
    After installing 10.6.5, the problems temporarily subsided. My Airport network came up quickly in the taskbar, with the full four bars lighting up soon after waking/restarting. Safari and Mail loaded up a minute or two later. All this wirelessly.

    However, now it has reverted to the former state, of connection failing to initiate wirelessly, and only being possible via ethernet cable. Connection takes 10-20 minutes, as follows. In the taskbar, neighbours' networks appear before mine does. To get my network to appear, I need to toggle between Turn Airport On/Off during this 10-20 minute period. When it appears, I am then able to continue the connection wirelessly, until it drops out when my computer (MBP) is inactive. At all times, network search in the taskbar refuses my password and times out.

    I have reported the problem at http://developer.apple.com/bugreporter

    Could this be a router/modem-related issue? I was supplied an iConnect 622 modem by my ISP and am inquiring about firmware updates or a replacement model.

    If it helps, my Airport system profiler information is:
    Software Versions:
    Menu Extra: 6.2.1 (621.1)
    configd plug-in: 6.2.3 (623.1)
    System Profiler: 6.0 (600.9)
    Network Preference: 6.2.1 (621.1)
    AirPort Utility: 5.5.1 (551.19)
    IO80211 Family: 3.1.1 (311.1)
    Interfaces:
    en1: Card Type: AirPort Extreme (0x14E4, 0x8D)
    Firmware Version: Broadcom BCM43xx 1.0 (5.10.91.27)
    Locale: APAC
    Country Code: FR
    Supported PHY Modes: 802.11 a/b/g/n
    Supported Channels: 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11, 12, 13, 36, 40, 44, 48, 52, 56, 60, 64, 100, 104, 108, 112, 116, 120,
    124, 128, 132, 136, 140
    Wake On Wireless: Supported Status: Connected
    Current Network Information:
    PHY Mode: 802.11g
    BSSID: 0:1b:63:23:18:3b
    Channel: 13
    Network Type: Infrastructure
    Security: WPA2 Personal
    Signal / Noise: -54 dBm / -90 dBm
    Transmit Rate: 54

    Thanks if anyone can help.

    PS - is Apple listening??

    PSS - Utopia will be when computers, airport devices and routers/modems can actually talk to each other, to know where the problem is - like the head knowing if the leg is missing, or the foot etc
    MacBook Pro, Mac OS X (10.6.5)
  • Daniel Herkenhoff Level 1 Level 1 (20 points)
    Currently Being Moderated
    Nov 17, 2010 9:26 AM (in response to Arash Zafarnia)
    I have the same issue:

    AExpress extending an AExtreme network. The extreme is fast, but the express is too slow...
    iMac Intel Core 2 Duo, Mac OS X (10.6.5), iMac 17" 2GB RAM
  • idon\'tknowXYZ Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 25, 2010 1:57 PM (in response to Daniel Herkenhoff)
    I think what might be happening with these Airport connection problems, is that interference to reception can occur when someone nearby sets up another wireless network. You can monitor your own plus all nearby networks using iStumbler (http://www.istumbler.net/) - signal, noise, channels, frequency, MAC address, physical location etc.

    Someone near me started a network using the same frequency as me, 2412 on a D-link pte router, which might be the root of all the problems I've been experiencing. It would explain why my MacBook Pro connects fine elsewhere - 100% instant connection at uni, cafe wireless networks - but at home my own network shows poor strength (e.g. two bars) or often does not appear on the Airport menu bar at all, even when my MBP is sited right next to it.

    It would also explain the variable time it takes to connect to my network - sometimes a few minutes, more usually like an hour to achieve connection and full bar strength, depending on wireless activity nearby my apartment.

    Recent software updates including 10.6.5 address other bugs but not Airport connectivity. Notice that. Basically Apple has given up, because Airport Express is such a poorly designed, outdated piece of hardware that nothing will fix it - anyone who's tried knows it's impossible to reset.

    So guys, live with it, suffer it....
    MacBook Pro, Mac OS X (10.6.5), Airport Express
  • Mike Friedman Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 6, 2011 3:56 PM (in response to idon\'tknowXYZ)
    I've noticed this problem as well, and went back and checked and sure enough two other networks were on Channel 2 (both with reasonable signal strength).

    I tried switching to Automatic, but the airport chose channel 11 which also has two relatively strong networks. I manually set it to 5 and now it seems better.

    You should really use a stumbler application (I use a Widget from MacWireless.com) to find a free channel and manually set it. It can't hurt. You only need to change the channel on the MAIN base station, not on the remote (extending) one.
  • Warnich Calculating status...
    Currently Being Moderated
    Feb 16, 2011 12:09 AM (in response to Arash Zafarnia)
    Same problem here.

    Tried to exchange the Express with a new one - same difference.
    Will try to do a reset of the extreme (Time Capsule)
    MacBook, Xserves, Mac Minis, etc., Mac OS X (10.6.6)
1 2 3 ... 5 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (5)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.