1 Reply Latest reply: Sep 28, 2010 9:58 AM by snucker
snucker Level 1 Level 1 (0 points)
I've tried playing a few games in full screen under Windows 7, but for some reason they are all extremely laggy. Almost as if the iMac is running the full screen games in a 'virtual' environment. I uninstalled the generic iMac display driver and downloaded the official 10.8 driver for my 5850 Mobility. Has anyone else experienced this problem, and if so, was there any way to fix it? Thanks.

(games tested: Final Fantasy XIV, Warcraft III, Starcraft 2)

Message was edited by: snucker

iMac 27" - i7-870 - ATI RADEON 5850M, Windows 7, x64
  • 1. Re: Full Screen Lag - iMac 27", i7-870, ATI RADEON 5850M
    snucker Level 1 Level 1 (0 points)
    I think I might have found a solution. I set all the 3D options in the ATI Catalyst Control Center to 'Performance'. I was able to set Warcraft III to 1600x1200 resolution and everything on 'High' without any lag. Now time to test Starcraft II and Final Fantasy XIV.

    (I'm unsure if changing settings in-game will override the defaults set by the Control Center.)