13 Replies Latest reply: Oct 5, 2010 2:12 PM by TexasTom
julieeebear Level 1 Level 1 (0 points)
All of a sudden (about a week ago), when I went to watch a movie on Netflix, the website wouldn't work and came up with an error. I have never seen this before and I really don't know where to go from here. The error message reads:
HTTP Status 500
Type: Status report
Description: The server encountered an internal error () that prevented it from fulfilling this request.

Apache Tomcat/6.0.10


I have no idea what this means or how i can fix it. I already called Netflix and they assured me that it had nothing to do with them, but it was my computer/server/browser having the issues. I have also tried to access the Netflix website on Firefox and it doesn't work on there either. I haven't changed anything on my network settings recently either. Please help! I miss my Netflix :/

2009 15" Macbook Pro, Mac OS X (10.5.8)
  • Klaus1 Level 8 Level 8 (45,360 points)
    Netflix haven't updated to comply with Safari 5 yet, but in the meantime they offer the following solution:

    http://www.tech2crave.com/how-to-re-enable-netflix-in-safari-5/
  • julieeebear Level 1 Level 1 (0 points)
    I have actually tried that, but nothing changes. :/
  • Klaus1 Level 8 Level 8 (45,360 points)
  • andyBall_uk Level 7 Level 7 (20,495 points)
    Hi

    a 500 error is produced by the website server when it can't do something, & has no more specific message to give than 'internal error'. So yep, they usually are a problem at the site, not your end... although can be prompted by the way a computer identifies itself to a website.

    Of course, netflix may say they've no Apache Tomcat servers, in which case...?


    You get this message as soon as you try to reach netflix.com - or just starting a movie?
  • julieeebear Level 1 Level 1 (0 points)
    I get it just by trying to go to the netflix website. i can't even access anything.
  • andyBall_uk Level 7 Level 7 (20,495 points)
    ok, so let's try to see what the problem is

    Look in Applications/Utilities/ for an app named Network Utility & open it up.

    Choose the Traceroute tab & paste in netflix.com
    you will get a result like the following - paste yours here & maybe it'll show us where things get hung up.


    Traceroute has started…

    traceroute to netflix.com (208.75.76.17), 64 hops max, 52 byte packets
    1 192.168.1.254 (192.168.1.254) 94.569 ms 38.165 ms 101.685 ms
    2 lo0-plusnet.pte-ag1.plus.net (195.166.128.64) 58.363 ms 112.271 ms 76.528 ms
    3 ge0-0-0-403.pte-gw2.plus.net (84.92.4.2) 117.815 ms 103.226 ms 180.848 ms
    4 tge1-4.fr3.lon.llnw.net (195.66.224.133) 84.593 ms 54.973 ms 50.877 ms
    5 tge7-2.fr3.lga.llnw.net (69.28.171.125) 149.288 ms 126.720 ms 111.057 ms
    6 tge13-1.fr3.iad.llnw.net (69.28.189.30) 173.229 ms 132.891 ms 123.247 ms
    7 netflix.tge4-2.fr3.iad.llnw.net (69.28.157.14) 133.302 ms 124.706 ms 122.990 ms
    8 xe-1-1-0.jnrt-edge02.iad1.netflix.com (69.53.244.254) 141.544 ms 137.479 ms 148.532 ms
    9 xe-0-0-0-100.jnrt-edge02.sv1.netflix.com (69.53.230.217) 205.336 ms 196.395 ms 206.386 ms
    10 xe-2-2-0-955.jnrt-edge02.prod1.netflix.com (69.53.225.30) 198.953 ms 217.830 ms 225.265 ms
    11 te1-8.csrt-agg02.prod1.netflix.com (69.53.225.10) 190.333 ms 209.058 ms 207.096 ms
    12 www.dc1.netflix.com (208.75.76.17) 195.322 ms 183.465 ms 201.967 ms
  • julieeebear Level 1 Level 1 (0 points)
    traceroute to Netflix.com (208.75.79.17), 64 hops max, 40 byte packets
    1 192.168.2.1 (192.168.2.1) 3.350 ms 1.379 ms 1.319 ms
    2 192.168.0.1 (192.168.0.1) 4.623 ms 4.580 ms 1.804 ms
    3 bois-dsl-gw17-209.bois.qwest.net (67.41.38.209) 18.478 ms 18.155 ms 18.798 ms
    4 bois-agw1.inet.qwest.net (63.228.242.129) 20.594 ms 19.722 ms 18.887 ms
    5 boi-core-01.inet.qwest.net (205.171.155.65) 20.211 ms 18.154 ms 18.572 ms
    6 svl-edge-20.inet.qwest.net (67.14.12.125) 43.941 ms 54.231 ms 50.946 ms
    7 63.145.225.58 (63.145.225.58) 52.197 ms 48.035 ms 47.508 ms
    8 xe-2-3-0-954.jnrt-edge01.sv1.netflix.com (69.53.225.25) 45.014 ms 48.144 ms 45.618 ms
    9 te1-7.csrt-agg01.dc2.prod.netflix.com (69.53.230.230) 45.717 ms 52.505 ms 47.420 ms
    10 www.dc2.netflix.com (208.75.79.17) 46.110 ms 46.151 ms 45.562 ms
  • andyBall_uk Level 7 Level 7 (20,495 points)
    Hi julieeebear

    that all shows you reaching netflix servers w/o a problem, suggesting it's an issue their end; a little searching shows you wouldn't be the first to have that.

    You've tried two browsers, Safari & Firefox, which would normally rule out any settings on your mac - I do think it's likely netflix - either a general issue or their servers responding incorrectly to some specific of your connection/isp/location.

    You've no internet filtering/safety/firewall/anti virus software ? (sometimes such things can cause problems) - you tested briefly in a New User Account ?

    You've a macbook pro, can you test on a different network somewhere?
    reset your modem/router (sometimes this gets a new ip address, which sorts things out)
    other computers on your modem/router work ok at netflix?


    You can try another 'user agent' via Safari-Develop-User Agent. Use an IE one, say - and if you've no 'develop' menu showing, enable it via Safari-Preferences-Advanced-Show develop menu.


    Lots to try, sorry
  • Krag Level 2 Level 2 (240 points)
    You can try

    with Safari preferences, advanced, check Show Develop menu
    in the Develop drop down, select User Agent, select Internet Explorer

    Firefox also has User Agent, or try Camino.

    For me at comcast/fancast TV/movies website Safari hangs on authentication, so I use Camino.
  • glasshaunt Level 1 Level 1 (10 points)
    I have the same issue which started at the same time as yours. We actually have 7 computers in this house. Netflix works on all of them in all browsers except the computer which is running windows 7 in which case it does not work in Safari or Firefox on that computer. However I can get it to work in Google Chrome. Like you we changed nothing and all our updates are current.

    So although I have no definitive answer as to why we are suddenly getting an apache tomcat error message, maybe try Google Chrome and get your beloved Netflix back.

    I would go into complete withdrawal without my Netflix!
  • julieeebear Level 1 Level 1 (0 points)
    I figured out today (as glasshaunt stated) that Netflix, in fact, works in Google Chrome but still doesn't work in safari or firefox. Although this doesn't really fix the problem, it's a temporary solution and im happy i can get back to watching my netflix <3
  • Antoniuk Level 1 Level 1 (90 points)
    Clear your cache then either clear cookies or go into preferences and view cookies. Then delete all cookies for netflix. Close the preferences and go back to netflix.com. Relogin and you should be fine.

    I had the problem and this worked for me.
  • TexasTom Level 1 Level 1 (0 points)
    I can confirm that this procedure worked for me as well. Deleted all netflix cookies, cleared the cache and restarted my mbp. Success! Finally got it to work. Interestingly enough, it was not working on Firefox either and now it is working as well. I'm sure its just a coincidence but weird none the less.