Previous 1 2 3 4 5 Next 64 Replies Latest reply: Jul 2, 2011 10:39 PM by jennifer253 Go to original post
  • arcdetriomphe Level 1 Level 1 (0 points)
    (Sorry for the off topic post but just want to mention that I solved my Outlook notes syncing problem. See there : http://discussions.apple.com/message.jspa?messageID=11996568#11996568 )

    As for the iTunes Remote App, again : on Windows it doesn't seem that the problem has anything to do with the Wifi connection per se (I tried with/without router, with/without software firewall -- I use Comodo --, etc.).

    I have other apps (like iMonkey) I use to remotely manage music and other files from my iPod and it works perfectly. It's either iTunes or the Remote app's fault and both (as far as I can tell) don't really have any "tweakable" settings. Or maybe a conflict between different apps/components?

    Message was edited by: arcdetriomphe
  • TheSnackist Level 1 Level 1 (0 points)
    Nope, just double checked those, and I don't even have the firewall settings turned on. So it's not that.
  • evo85210 Level 1 Level 1 (0 points)
    For those who can't get itune to ask for the code, make sure ur bonjour service is on.
    for those who can't get the app to find ur library, idk, cuz i have the same problem
  • arcdetriomphe Level 1 Level 1 (0 points)
    For those who can't get itune to ask for the code, make sure ur bonjour service is on.


    Actually, my "bonjour" service (C:\Program Files\Bonjour\mDNSResponder.exe) is "on", and no code is asked for. I stopped it, restarted it, to no avail.

    I have this most basic problem, hence no "found library" either.
  • MikkyX Level 1 Level 1 (0 points)
    It was suggested I post in here with my own experience (you'll have seen this from another thread I started on the subject). As you see below I'm using a 3rd gen rather than 4th iPT but still the problem remains:

    --
    Here's everything you might need to know:
    24" iMac, 3 years old, running Snow Leopard w/all updates and iTunes 10.0.1
    Connected to our network via Ethernet
    Firewall not enabled, antivirus software not installed

    iPod Touch 3rd Gen, 32gb, connected to the same network wirelessly, iOS 4.1
    iPad WiFi + 3G 32gb, connected to the same network wirelessly, iOS 3.2.2
    Remote App v2

    Problem:
    The Remote app cannot connect to my iTunes library under any circumstance. With Home Sharing enabled, neither the iPod nor iPad can even see the library. If you go via the passcode method then each device shows up in iTunes, you tap in the passcode and get a message implying success. Then when you try to connect to the library nothing happens. This happens on my iTunes library and also to my girlfriend on the same computer so I don't think it's an issue specific to my account or computer login.

    Of note is the fact that other remote apps I have (XBMC Remote, AirVideo, MediaFire, LogMeIn, and Android VLC and BitTorrent remote apps) all connect and work without a problem. Somewhat ironic that an Apple app, on an Apple device, controlling a piece of Apple software, has trouble, I suppose

    I understand this is quite a common problem but hopefully if Apple see all the threads springing up as a result there is something that can be done. If there is something I can do to make it work in the meantime, tips are appreciated.
    --

    I've since tested on a Windows 7 64-bit machine via Home Sharing and had no problems.
  • GuestG4 Level 1 Level 1 (35 points)
    How is this for awesome?

    A late 2005 ppc iMac (with internal iSight), iTunes 9.2.1 (no more updates available), separate iTunes account (no home sharing), and same iPod Touch 4G with Remote App 2.0.

    1). IMac will not detect my PC iTunes 10 Library through normal AirTunes (obviously without home sharing), but again my PC can detect my iMac 9.2.1 Library and stream music back to my PC only (no airport express).
    2). IMac quickly discovers iPod Touch/Remote App 2.0 through passcode setup. Remote app then instantly shows iMac Library with full remote control functionality, and streams my changes to airport express/stereo.

    Crazy.
  • arcdetriomphe Level 1 Level 1 (0 points)
    Interesting.

    I wonder what the problem is.

    I spent a fair amount of time today trying to find out what's happening in my particular case. Seems to be that the "bonjour" service is having trouble doing its job (mDNSResponder.exe -- BTW, wonder why they didn't call it bonjour.exe... Maybe to make or PC even more intuitive).

    MediaMonkey's plugin MonkeyTunes, which uses the Bonjour service and the Remote app v.2 doesn't work either.

    I once again disabled firewall, etc., but it doesn't work. The router hasn't changed a but in the last year, so it's out of the equation.


    It could be something about mDNSResponder.exe and newer apple devices. OR just a bug with the remote app. What do you think ?

    1) Anybody could test 2 different iPod touch models (e.g. : 3g and 4g) with itunes 10 and the remote app v.2 ?

    2) Is it possible to somehow downgrade to a previous remote version ?


    P.S. :I might try un-installing /re-installing iTunes, QuickTime, etc., but this means a lot of tinkering, and I won't have the time to do that until next weekend. I'm also not that enthusiastic about that idea... I got most things to work and I'm not sure I'm willing to (re)break stuff that now works... Not that I couldn't repair it, but still...:)

    Message was edited by: arcdetriomphe
  • GuestG4 Level 1 Level 1 (35 points)
    ok, some success:

    I found that if I disable computer wifi, plug in an ethernet cable, and disable the firewall altogether, I was able to get Airplay to turn on when I open iTunes. After I turn on Remote App 2.0, I did quickly see my Library become available, and was able to navigate and control my library, and even stream it all to my airport express. Turning on Wifi and disconnecting the ethernet cable seems to still work okay. Turning my firewall back on seems to work "mostly".

    When I turn the firewall back on, I'm still able to navigate/control my library through the remote. I don't, however, see any "devices" section in iTunes with Home Sharing, a "speaker selection" box, or even the Airplay logo in the bottom right (but I do see a new "playlist" folder show up under Library and the standard white album list that updates/shows which album I'm navigating to on Remote App. So this is starting to seem a bit weird. iTunes 9 shows "devices" and the Remote App icon. MY iTunes 10 shows neither those, nor the airplay logo at the bottom right. The airplay logo only shows up occasionally, if I have my firewall disabled.

    If Remote App is closed, and I start iTunes 10, I do see a the genius logo and the sidebar logo in the bottom right. When I then turn on Remote App, I quickly see my Library on my iPod Touch. Nothing happens in iTunes until I press the song name on Remote App. Then both the genius and sidebar logos disappear, then I start to see the "playlist" folder and can control iTunes. The entire bottom right corner of iTunes is empty. no logos or buttons of any kind. I did learn that if I remote to a Movie or TV show, the genius button and sidebar buttons reappear, but if go back to playing a song, they disappear again. Something is funky!

    When my firewall is disabled, I can see which speakers are available on my remote App. When my firewall is enabled, I lose the ability to see which speakers are available on my remote app.

    Interestingly, I've also learned that I can only discover my airport express through airport utility on my PC when my firewall is disabled. The only thing that I remember changing was upgrading to iTunes 10. I already had previous iTunes 9 ports enabled in my firewall (which worked for airport utility/airport express before), so I'm wondering if the iTunes upgrade made new wifi port changes that I need to find and enable in my firewall. Again, disabling my firewall found my airport express VERY quickly, but enabling the firewall hides it again. This easily explains why my speaker selection disappears from remote app when I enable my firewall.

    Would someone happen to know what may have happened and how I might make changes in my firewall to work with this now? Was there a recent Airport Utility update that I'm just not remembering that may have made these changes. It's just weird.
    Do I have to uninstall/reinstall Airport Utility? I don't see how this would be necessary. I really just want to understand what happened and how to fix it.

    So, I guess, to summarize... Remote App 2.0 in iPod Touch works "mostly" well with iTunes 10 as long as your firewall isn't messing it up and/or is modified to work with any recent changes.

    Again, any additional info or suggestions are appreciated.

    thanks again to all those who have found interest in this topic and have helped me to better understand this.

    Please do continue to share your thoughts.
  • arcdetriomphe Level 1 Level 1 (0 points)
    Thanks for sharing.
    A I said before, disabling my firewall doesn't do anything here.
    I don't use Airplay, nor airport express.

    Using the iPhone/iPod Touch ZeroConf Browser, I only see :

    "iTunes Digital Audio Control Pro...
    _dacp"

    If I plug my iPod to my laptop (USB), I then also see :

    Touch_remote


    I wonder what others see with the ZeroConf Browser ("allows users to browse the network for available Bonjour/ZeroConf services, including RemObjects SDK servers or other applications providing network services that register with Bonjour") : http://itunes.apple.com/us/app/zeroconf-browser/id316741416?mt=8

    I still can't enter the remote app code in iTunes to do any kind of pairing....
  • GuestG4 Level 1 Level 1 (35 points)
    Did a full Uninstall/Reinstall of iTunes 10, Bonjour, and Airport Utility for Windows, and also deleted firewall rules before app startups to recreate them.

    So far, I think everything works correctly again.

    Airport Utility quickly finds Airport Express without problem.

    Remote App quickly finds Library over Home Sharing and Passcode.
    I guess the Remote icon only shows up with a "devices" section when you use the 4-digit passcode. Otherwise, I don't see a devices section. I still only see a "playlists" folder appear under the "Library" section immediately under the internet radio icon (bottom of the list). Both Home Sharing and Passcode connections work very well. I now always see the Speaker Selection options available on Remote App (even with the firewall enabled, and with both windows network detection and printer and file sharing disabled.)

    I never use "Genius" or "Ping" (both turned off). These icons (along with Airplay/Speaker icon)do appear when I'm not using the Remote App. When I do use the Remote App, the only icon I see is the Airplay/Speaker one. Specifically (as before), the Genius and Sidebar icons only appear when using remote app to navigate movies/tv shows/etc, or when not using the remote app at all. They do not appear when using the remote app to navigate music. The good news is that the Airplay/Speaker icon does now always appear, so I'm able to detect my airport express directly through iTunes again.

    I believe full-functionality has been restored.

    Being a new Remote App user with my first iOS device, I was hoping someone could confirm if the Home Sharing "Playlists" folder under the "Library" section is normal for iTunes 10 (vs a Remote icon under "devices" when the Passcode is used)? I just find that inconsistency a bit odd.

    Thanks again to everyone who participated in this discussion. Your input has been very appreciated.

    I will keep this thread available for a while in case some of you have any questions you would like addressed. Please let me know if you would like any help.
  • evo85210 Level 1 Level 1 (0 points)
    okay, so this makes no sense, i'm able to control my comp with teamviewer on the touch, but remote can't find my library? wdf? anyone knows how to fix it?
  • GuestG4 Level 1 Level 1 (35 points)
    evo,

    to be more specific, Remote App can't find iTunes because iTunes must first find your Remote App. The issue is iTunes 10's inability to discover wifi devices (which is due to its broken upgrade process). Your iPod Touch/Remote App should both be fine. The ability to use "Teamviewer" on your touch is not related, as it is simply a connection to the computer, not iTunes 10 directly.) I imagine your "Teamviewer" app uses different ports, which would also explain why it is still able to connect well.

    Have you double-checked to make sure you setup sharing by opening TCP 3689 and UDP 5353 on your 3rd party firewall safe networks. I also had to create a new Windows Firewall rule to enable iTunes to connect to the Remote App while NetworkDiscovery / PrinterFileSharing was turned OFF (I don't like allowing Windows to connect to anything/everything all the time.) Other than that, I believe the full uninstalls/reinstalls cleared up any issues that the iTunes 10 upgrade process broke.

    You may want to see if this works for you as well. I have a hunch it may.

    Good Luck!

    Oh, and thanks for mentioning Teamviewer. I want to give that a try now!

    Let us know what happens.
  • evo85210 Level 1 Level 1 (0 points)
    okay, so u said to open tcp and udp.
    i've done that to all my firewalls, windows firewall, kaspersky firewall and my telus routers firewall, but it still cant detect

    btw, teamviewer is quite battery consuming in a way, not obvious, but noticeable
  • TheSnackist Level 1 Level 1 (0 points)
    Glad to hear you have solved the problem on your end. Too bad it's only a Windows native solution... Has anybody come up with a workaround for the Mac side of this problem?

    -TheSnackist
  • arcdetriomphe Level 1 Level 1 (0 points)
    I'd like to add that I run Windows and I don't have any solution yet.

    Uninstalling and reinstalling a bunch of software doesn't appear like the easiest/ideal solution anyway.

    Note that after buying my iPod 4g, I had to uninstall and reinstall iTunes, Quick Time and whole bunch of stuff coming with it, anyway (Yup : iTunes 8 was acting up and nothing was functioning properly). So, as far as I'm concerned, that's done (i.e. : Uninstalling, reinstalling).

    Of course, I could do it again, but it seems a tad insane to try the same thing twice hoping it will produce different results. The only thing I didn't try is to completely uninstall my firewall. I guess I will, eventually even if it seems ridiculous -- I mean, this app is the *only one* not working on my computer. All the other ones don't have any problem to connect. That said, seems like nothing else could get in the way of the Remote App.

    _Problem summary_ : iTune doesn't see my iPod running the remote app (wirelessly). So I can't enter the pairing code. Note that I experience exactly the same problem with another app, mediamonkey (which can use the remote app too, through a plugin) : can't enter the pairing code.

    This seems to bring down the "variables" to 4 (as I said elsewhere) :

    1- firewall problem, which affects only the "bonjour" service (mDNSResponder.exe) necessary to establish communication between iTunes and the remote.
    2- compatibility problem between the bonjour service and the iPod 4g
    3- compatibility problem between the bonjour service and iTunes 10
    4- compatibility problem between the remote app 2.0 and the iPod 4g

    Message was edited by: arcdetriomphe