Previous 1 10 11 12 13 14 Next 204 Replies Latest reply: Mar 10, 2012 2:14 AM by Shawn M. Go to original post
  • Shirley 123 Level 1 Level 1 (0 points)
    I think I have success. My TV has a DVI port and so I connected the Apple TV via DVI to HDMI when it first came out. Unlike many of you, mine worked fine until this past weekend when my TV (which automatically selects resolution) wouldn't go to anything but 640 X 480 and I couldn't see anything on the TV except a flicker. So, I connected to my small TV in the kitchen using HDMI to HDMI and all worked. I have since ordered an HDMI to component video per a suggestion from someone on Twitter. Today I upgraded and then moved the unit back to my DVI input TV. At first it didn't work and then I recycled the unit and recycled the TV and it worked! Now the TV is showing 1280 X 720 and I have a perfect picture. I hope this is a result of the update but time will tell. Since mine worked originally and then stopped working, I'm a big apprehensive about its success!
  • nadeama Level 1 Level 1 (0 points)
    Well, I guess this is a half-baked fix, but at least it's a start.

    The "waves" have indeed disappeared, so my Apple TV is at least watchable now. Unfortunately, it sends a 480p signal instead of 720p. So, apparently no HD for owners of older tv sets, only standard definition.

    My television set doesn't display 720p (it displays 540p and 1080i), but it definitely supports 720p input (as stated in the tv's manual, and which I have tested with several upconverting DVD players in the past). It can accept 720p signal without problems and internally convert to 540p or 1080i.

    Every other piece of video hardware I have ever tested on this tv has worked fine at all possible resolutions (except 1080p, of course), so I don't know why it is so difficult for Apple's engineers to get this working with the Apple TV. Hopefully, a future update will provide a definitive fix to this.
  • clafournaise Level 1 Level 1 (5 points)
    The iOS fixed the wobbly screen on my Panasonic TH-37PD25 ... Very happy about that.
  • Euripides Level 1 Level 1 (25 points)
    Same here, the waves are gone (thank you!). However, like other posters my signal is not 720p (still not sure they don't default the signal to 720p if that is the "requirement"). Oh well, I'll take it!
  • Shirley 123 Level 1 Level 1 (0 points)
    Can those of you who have confirmed that the wavy lines are gone also confirm if you're using HDMI to DVI or HDMI to HDMI or other?
  • nadeama Level 1 Level 1 (0 points)
    I'm using a HDMI to DVI cable, and the wobbly picture is gone, although as I mentioned in my previous post, signal is 480p.
  • Shirley 123 Level 1 Level 1 (0 points)
    How can you tell what the signal is? Input lines on my TV says 720!
  • David M.F. Chapman Level 1 Level 1 (15 points)
    Look in Settings>General>About for the resolution the ATV2 is supplying. To answer your other question, I used to have wobbly video (and no sound) with my HDMI->DVI cable directly connected to the TV, but I fixed it (and got audio) with an HDMI switch box. That was before the upgrade. After the upgrade, I get steady 420p video (with no audio) connected directly and 720p video and audio through the HDMI switch, but there is a magenta color cast.
  • Shirley 123 Level 1 Level 1 (0 points)
    I'm getting 720p with DVI TO HDMI cable and audio from the optical port. Picture is fabulous! However, my ATV worked day one and then stopped. So, I'm not sure if this is another fluke or if this is fixed for good!
  • Mr Bigburn Level 1 Level 1 (0 points)
    My 'wobbly' resolution disappeared as well with the 4.2 update - however, my resolution is also only 480p; This is an HDMI --> DVI (HDCP-capable) setup with a separate optical to RCA for audio (using Gefen converter box);

    My TV is an older (5 years) SONY Wega - capable of 720p; Hopefully the software update is a step in the right direction;
  • ringonbob Level 1 Level 1 (0 points)
    same here

    I am having the same issues. Had waivey lines on going HDMI to DVI on original OS to my 7 year old Sony Wega. Bought the monorpice switcher, it fixed my wavey lines and I got a 720P signal (plus was able to switch between inputs). Updated to 4.1 (4.2)... and Get purple screen at 720p or bypass the switcher and get 480p (w/o purple). Very frustrating. I tried someones suggestions on the booting up order, I still got the purple screen... My other workaround suggestion is to go direct to tv (by pass switcher)... restart ATV2... set ATV2 to NEVER sleep, then switch the cables back through the switcher. Still only gives me 480, but lets me switch back and forth. I will try monoprice today and see what they have to say....

    If someone knows of a fix (even if jb'ing is required) please post.

    and where are my Apps?
  • JustReel Films Level 1 Level 1 (0 points)
    About that boot order, its all about timing.

    -Have both ATV and HDMI switcher switched off. Make sure the switcher source input is already set to ATV.

    -Get the ATV remote and the HDMI switcher remote in each hand.

    -Turn on ATV by pressing the center button, as soon as you lift up your finger on that button, _wait about half a second_ then turn on the HDMI switcher.

    You should see something on the screen in about 8 seconds.

    I had success trying this last night, and tried many combinations( turn on both units at exact same time, waiting 10 seconds then turn on, etc, etc.)
    then finally got 720p without the color problem.

    So basically:

    -AppleTV ON
    -wait 0.5 second
    -HDMI switcher ON
    -wait 8 seconds

    I'll see if I can post a video to show this.

    BTW I have a Sony Wega HDTV KF-42we610 which is about 7 year old.
  • David M.F. Chapman Level 1 Level 1 (15 points)
    JustReel Films: you are a frickin' GENIUS! I tried this, and IT WORKS, and I even get 720p HD resolution with proper colour! How did you ever find this?

    I use the shortest of delays: as soon as I see thew ATV2 light, I shoot the other remote.

    Now, how can Apple use this info?

    Thanks you so much! Dave
  • JustReel Films Level 1 Level 1 (0 points)
    Remote button mashing, bruteforce port switching, eventually I found one that worked out and tried to replicate my actions.

    Everytime you wake up ATV, it goes through a series of checklists such as initializing network, display etc. Before it displays anything on the screen, it challenges the HDMI port to give a response. It first asks the TV to spit out EDID data which is a list of compatible resolutions. The ATV had trouble getting that information so it defaulted to 480p along with incorrect clock phase. Hence the wavy lines. I think the firmware just adjusted the clock value but still couldn't detect the TV's EDID. Monoprice's HDMI switcher can detect the EDID of the older generation TVs (maybe it has extra chipsets that ATV does not have) so it can report it properly to ATV.

    As for the color problem, the data packets color encoding is shifted because it relies on the proper clock rate. I guess the HDMI switcher only reports it once, (when its turned on) and ATV has a time limit when to receive TV infomation. So turning on both units at the right order and time receives the data packets in time so the ATV can configure itself for display.

    You can read it more about it here:
  • Euripides Level 1 Level 1 (25 points)
    Using HDMI to DVI cable. I know it is not a 720p signal as I am able to cycle through the view modes (normal, zoom, wide, etc...) on my Sony RPTV. If it were a 720p signal, the picture mode would be fixed and would not allow me to change the view mode.