3 Replies Latest reply: Sep 29, 2010 6:35 PM by BDAqua
ukchris1968 Level 1 Level 1 (0 points)
I'm pretty new to the Mac so let me apologize in advance if I'm not that clear on things.

I have a Mac Mini G4 running OS X 10.4.11, I want to install iTunes 10 but it requires OS 10.5. I have 10.6 which I can't install ona G4 (apparently) but have no clue how I'd go about getting 10.5 such that I can then install iTunes.

I'm a little frustrated, I thought that the big claim was that it "just works" on a Max, I wasn't expecting this. My aim is to use the Mac Mini to stream content to an Apple TV all being well.

Thanks in advance for any help.

Chris.

Mac Mini G4, Mac OS X (10.4.11)
  • Klaus1 Level 8 Level 8 (45,360 points)
    I'm a little frustrated, I thought that the big claim was that it "just works" on a Max, I wasn't expecting this.

    It generally does, but often does not when you try to marry an old Mac like a G4 to the latest applications it can't run.

    You can run Leopard OS 10.5.x on a G4 if it meets the requirements, and you can get Leopard by calling Apple Telephone Sales.
  • ukchris1968 Level 1 Level 1 (0 points)
    Thanks Klaus, I appreciate the help!
  • BDAqua Level 10 Level 10 (119,045 points)
    Leopard requirements/10.5.x...

    * Mac computer with an Intel, PowerPC G5, or PowerPC G4 (867MHz or faster) processor

    minimum system requirements

    * 512MB of memory (I say 2GB at least)
    * DVD drive for installation
    * 9GB of available disk space (I say 30GB at least)

    You have to call Apple & likely ask for a Product Specialist to get it, if they still have it!