Previous 1 5 6 7 8 9 Next 132 Replies Latest reply: Dec 19, 2015 11:31 PM by jmooseman Go to original post
  • Montag451 Level 1 (5 points)

    Apple recently released an update that includes the following fix:


    - Fixes an issue that may cause external drives to be ejected after the computer goes to sleep


    I installed this update on both Macs at home affected by this issue, but both have continued to unmount drives at some point during sleep. I've wiped and repartitioning one of the affected drives to see if the original bug somehow "infected" the drive with some specific issue.

  • theRealSergio Level 1 (0 points)

    I'd like to confirm that the issue seems to be Time Capsule related, as by removing one of the involved drives from Time Capsule (which was off, but that wasn't enough, I had to disassocate the external hard drive from Time Capsule completely) I got a performing, stable 175 GB transfer without a sudden unmounting of drives.


    And yes, I had my "sleep drives when possible" option turned off, as makes sense, but apparantly its Time Capsules grabbing of drive connections that must not be "patient" enough to wait for drives to spin up or whatever.


    Hey, Time Capsule is nice, but if it compromises the ability to reliably use external hard drives, I'm wondering what other solutions people like.


    To set a context, I have a 2012 MBP Retina, and based on other threads, I had my USB hub on the left-side USB 3.0 port (having read about trepidation about the reliability of the right-side port), and I have a (stand-alone powered) Orico 4-bay dock with a couple of bare 1TB drives in it, and another WD My Passport 1TB plugged into another port of the USB hub.

  • DC Steve Level 1 (25 points)

    I just bought a new imac 27 i7.  I have the same problem.  I am using an OWC 4TB drive that unmounts unexpectedly (and immediately remounts) during time machine backups.  It does the same thing during Superduper backups.  I am running Mavericks.


    It does not do this while being read, i.e., while I was copying data stored on the drive to my new machine, it did not unmount.  Any ideas?

  • niccodeamus Level 1 (5 points)

    I also have a brand new iMac 27 i7.  I have 2 Freecom USB3 2TB drives linked to the machine.  They also spontaneously drop and instantly remount.  I havent yet linked it to TM, but I turned off TM (out of old habit) after it happened twice during attempted updating of iPhoto libraries (on the remote drives).  This caused a iPhoto hang (or at least an apparent hang and one crash). 

    I had hope that getting off the Firewire setup would solve this problem.  At least they instantly remount. 


    As an aside.  A lot of my TM related unmounting drive problems went away when I got hold of a TC and backed up over ethernet.

  • DC Steve Level 1 (25 points)

    I have spent too many hours on this.  I haven't definitely solved the problem, but it seems linked to pro App (FCP X and Aperture) files.  It might also be linked to multiple copying procedures being performed simultaneously.  I bought a Lacie Thunderbolt USB 3.0 drive and everything worked fine, so the problem might have been the drive, or how the drive interacts with mac/Mavericks.  I think I've solved it, but we'll see . . .

  • marrlin Level 2 (165 points)

    Have not found a fix as of yet.

    Currently testing if google drive is causing the problem.

    Have logged out of my google drive account and remounted my usb drive to my iMac.

    60 minutes and so far so good.

    Will update if continues to work.


    Console showed a reference to google drive problem right before unmounting my usb drive.

  • James Cook2 Level 1 (10 points)

    LaCie replaced my drive when I contacted them about some other concerns regarding unmounting. The problem with Time Machine and mounting/unmounting has vanished with the replacement and all is well. It was clearly something in the driver or the drive.

  • marrlin Level 2 (165 points)

    12 hours after uninstalling google drive, still no unexpected unmounting of any drives. [fingers still crossed]

  • Zepple Level 1 (10 points)

    I too have had many issues with intermittent improper disk ejection warnings with both AC powered and firewire powered drives.


    Spent the $1.99 on the app "Jettison" which fixed all my issues. This app should be part of Mavericks and not need to be purchased. The thing is Apple did not develop it.

  • DC Steve Level 1 (25 points)

    In my case, at least, the problem was files that the computer had difficulty sending to the external HDD.  In other words, the spontaneous ejections were the symptom of a different problem, and the computer's response was to eject the external HDD, rather than (I presume) dealing with what the computer thought was a corrupted file or risk corrupting the external HDD.  I ended up buying an external HDD from a different manufacturer and that solved the problem.  If my theory is correct, I suppose that this is a good safety feature. 



  • luisvela Level 1 (0 points)


    I am not an expert but would like to share some interesting detail with the Unmountin/mounting bug in OSX.

    I have just attached the last response I have given a technician of Lacie in relation to the three drives I have bought and two of them defective I thought and all three gone and back from LaCie.

    The problem still remained after the drives been send free of problems from LaCie.


    My last text to Lacie:

    During this days I have not been inactive and waiting for your reply; which I very much appreciate Thank you very much.


    In desperation and not resignation I kept reading forums trying to understand. Somewhere someone can't remember, mentioned a problem with Timemaschine. I thought it could be, not a hardware problem but a OSX problem.


    My procedure was such.

    1. I formatted the Drive serial....


    2. Re formated in a mac with Powermac G4 OS 10.5.8. Controlled access preferences in the drive and left it as "ignore ownership". Timemaschine deactivated.


    Unmounting/mounting problems disappeared. I left the drive writing/reading during several hours and with disk tool pro made several test. Everything went ok.


    3. Left it in standby a whole day and there where no Unmounting/mounting problems.


    4. Activated in the computer timemaschine and after a few minutes the problems with Unmounting/mounting reappeared on the drive.


    5. Did the whole process again - formatted drive and deactivated Timemaschine. The problem stopped.


    6. Went to another computer with OSX 10.8.5 Formatted drive once more. Control drive access preferences and left it as "ignore ownership". Deactivated Timemaschine. Installed little app called "Jettison".


    Has been working without hiccup. Unmounting/mounting problems disappeared.


    Now it is in its place (togehter with other 14 LaCie external drives) at the file server (mini 2009) running as fileserver with OSX 10.5.8. I reformatted once more in the server and checked the access preferences.

    Today it has been working until now without problem. The electricity in Zürich when of in the morning therefore had a bunch of alarms in servers drives.


    Let me wait until tomorrow and will update the situation.


    Now what I do not understand why are the new drives so sensitive and prone to problems?


    Hope this might help someone with ideas.


  • DC Steve Level 1 (25 points)

    I have had no further problems with spontaneous unmounting.  The new drive solved the problem.  I can only conclude at this point that the problem is how my original drive interacted with my computer.  Thus, this isn't really an Apple problem, so much as a compatibility issue.

  • luisvela Level 1 (0 points)

    By the way Timemaschine is activated and have had no problems until now.

  • luisvela Level 1 (0 points)

    Last update

    LaCie will replace the External drive anyway:


    Dear Luis,


    Thank you for contacting LaCie Technical Support!


    Yes, in some scenarios it can be an issue with Time Machine, but the Symptoms that you described made me believe that it is an issue with that drive.


    It is very common for Apple to randomly change programs, functions and the way things work in the background after each updated, we always try our best to make sure that all drives are always compatible but sometimes there will be issues that you may have heard and read about online.


    I feel confident that a factory new drive will solve your issues.


    If you have any further questions do not hesitate to contact us again.


    Best Regards,

  • soren bo Level 1 (0 points)

    I have a similar problem my iMac (latest 2013 model) constantly unmounts any external HDD i connect to the USB 3 ports, however the same external HDD works fine on my 2011 Macbook Pro (USB 2). The external HDD do not have a powersupply. I have tried with several cables and several external drives, all with the same problem.


    My iMac OS Mavericks is installed on an external SSD connected via Thunderbolt, this shows no problems only the USB3 connectivity has a fault. I expect that is may be hardware related, can anyoune tell how I can debug this?

Previous 1 5 6 7 8 9 Next