Previous 1 2 3 4 5 Next 132 Replies Latest reply: Dec 19, 2015 11:31 PM by jmooseman Go to original post
  • Level 6 Level 6
    I just discovered that the unwanted unmounting of my TM disk only happens when I lock the screen after a day's work. I have been in the habit of doing this quite often, but now I will manually dismount the drive before locking the screen.

    (These minor setbacks are sent to try us!).
  • Ryan Wuckert Level 1 Level 1
    I had the same problem.
    using a MBP non unibody.
    Daisy chaining two externals.
    one SpeedQ gtech raid5 6TB (new)
    and gtech mini 500gb (new with it's own power adapter to allow for FW800)

    When doing transfers from SxS card in the pci slot to these external drives
    one would intermittantly unmount causing the error.
    This happened with mutiple out of the box new mini drives.
    And when I reversed the connection order the same thing would happen.

    Swapped cables
    switched order of daisy chain etc.
    no dice.

    I think it is a max speed issue (in my case)
    the mini is 5400rpm
    the RAID is 7400rpm

    Solution was to: place another Gtech 2TB raid between also 7400rpm
    make my simultanious copies that way
    then drag n drop a copy to the mini after that.
    problem solved. kinda.
  • am-ellpa Level 1 Level 1

    This problem doesn't seem to get any real attention and we're nowhere from a real resolution ! (Just look at the dates of the many posts).

    I'm on a PBG4-1.67GHz-17" (that's a good old PPC) with MOSX10.5.8 with all the Software Updates installed from online to the current day. BTW this is a bad PPC OS release, and a sad place to strand faithfull users still using PPC on Apple's part !

    I've started to experience slowness of external drives WD MyBook 1Ti, 2Ti, 4Ti no RAID/RAID according to models. I use all of those in FW800 for obvious speed reasons. Now file copy between external drives and between Mac and external takes AGES even for chunks of 2Mi ! And now my WD started to self unmount for no visible reason too.

    A fresh reboot, then connect FW800 MyBook : it mounts (quite slowly too) and within 5 seconds of it's icon appearing in the Finder as mounted, it disappears because it gets ejected. Sometimes I get the OS message "Incorrect device removal" but not always !
    When I retry to mount the WD, it dos NOT appear to have suffered any abrupt unmount, I can't perceive that any fsck is being performed by OS.
    I can't seem to find anything useful in Console.

    I've the same problems regardless of the fact that I connect WD drives one at a time to my Mac or in daisy chain !
    I used to connect in daisy chain, of course, since FW is designed to work that way, and I had no problem before.

    I don't have TimeMachine set up on this machine and nothing else is connected to it.
    I've tried swapping cables between the WD drives and have tried 2 extras cables from Belkin.
    I also tried reinstalling a fresh OS and booting clean before attempting to use the drives.
    DiskUtility and WD RAID Manager are happy with the drives.
    The drives and Mac are not overheating since I get the problem regardless the uptime of the systems/devices.
    Other forums I've read about this problem report this happening with/without TM, iCal, iSync, USB2, Intel-based Macs : many reports but NO resolution.

    For what I can gather reading all the posts I found is this :
    I avoid USB so I can't discuss USB.
    Apple Mac PPC/Intel vs multiple brands of FW drives and multiple cables tested.
    I don't think it has to do with TimeMachine and there's very few chances it has to do with iCal or iSync or even EnergySaver or ScreenSaver settings either.

    If everybody reported about WD drives only, I'd say there may be a conflict between WD's RAID Manager "plugin" (different versions get auto-installed when various MyBook devices are connected, and they seem to run in parallel (when daisy chained devices are used) ... !?? under the same icon in the Finder Menu bar, but there could be an instance running per drive by design from WD ... )
    But people report also using other brands.

    This all points to OS/FW issues to me, regardless of drive brands and other software running (other than drivers/drive tools such as WD's RAID Manager I mean).

    I wish someone at Apple or one of the drive brands would communicate on this.

    Hoping for some answers,
  • travisroy Level 1 Level 1
    My similar problems started with FW and now have spread to USB using multiple drives in multiple self powered enclosures and cables. All seem to work fine on my older ibook via usb. The problem machine is a 2.53 GHz Duo Core Intel mini with 4G RAM. It's horribly annoying. Whenever I want to work on files on these drives the only way to reliably do it is to mount them to my ibook and open them through my network, which is not very speedy.
  • Ray Chang TW Level 1 Level 1

    I'd like to add that I've never had any problems with FW on my 10-week-old iMac.  I boot from a FW drive* and use the iMac's internal 1T drive for TM without any problems.  I have a 500gb USB drive I like to keep connected with certain files I only need "sometimes".  This was my TM drive during my Mac Mini days, and was always connected to my iMac until I did the last "Software Update" (apparently to 10.6.7) when this problem started.  I actually bought a powered USB hub thinking power was the problem.


    To circumvent this, I have plugged that 500gb drive into my AirPort Extreme.  It's much slower, but it has been connected for about 2 weeks now and never unmounted itself like it did on an average of about every 12 minutes when connected to my iMac after the 10.6.7 update.  I can even burn discs using the iMac's optical drive from files on the wireless-connected USB/AirPort drive.  I have rotated different cable sets and the unmounting problem always stays with 10.6.7.


    MAIN POINT (about FW and TM):

    Maybe my iMac doesn't drop my FW drive because that is the boot device.  Maybe 10.6.7 has lowered some kind of threshold for connected drives.  Maybe since my iMac's internal drive has nothing to do with FW or USB buses, that's an indication that TM is not the problem (for those who have been suspecting TM).  That's a lot of maybes, but at least I should let everyone know that booting from FW with 10.6.7 doesn't seem to be a problem and using TM on iMac's internal 1T drive is also fine.



    (When I bought iMac, I wanted to partition the 1T drive into 500gb/500gb for system and TM, respectively.  Disk Utility wouldn't let me do it, so I gave up.  I took the hard drive out of my MacMini, mirrored it onto a 500gb drive (from a smaller one), put it in a FW400 enclosure, bought an expensive FW400-800 adapter cable, and use it to boot the iMac.  This way I can always use my MacMini as a backup should my new iMac need to be fixed).

  • Ray Chang TW Level 1 Level 1



    Last night, I got "software updates are available for your computer" and I accepted it.  I left a USB drive connected during the night (daytime, in North America) and it never disconnected.  Also, I switched my 500gb drive from the AirPort Extreme to my iMac and it has been connected now for around 2 hours and has never disconnected.  So far, it seems the problem was in the OS.

  • octothorpe Level 1 Level 1

    I found this thread because a few days ago out of the blue an external drive I have been using for months started unmounting itself. This was happening whether it was connected via Firewire or USB.


    I finally put two and two together and remembered that the day before it started failing, I'd been using a piece of file synchronizing software called Synk, and had installed the little "helper" application it comes with to help it open automatically when certain disks are attached. Needless to say, I uninstalled it -- and since then my drive seems to be once more stable and mounted.


    I post this on the off chance any of you are using Synk.

  • beachaus Level 1 Level 1

    Same problem here with USB drives, CF cards, thumbdrives and firewire.


    Seems with this many people having the same problem, Apple might want to take note and tell us how to fix this.


    I am going to contact support -- if I find out anything, I will post it here.

  • taxin Level 1 Level 1

    any solutions for this yet, I have a WD My Passport which keeps unmounting on USB but my Seagate 1TB also unmounts, but only seems to be affecting one of my usb ports.. I'm happily copying from the other usb port from my Seagate to a Lacie on Firewire..



  • Gedfromchorley Level 1 Level 1

    Wahoo.... I get to join the club. Previously perfectly functioning Iomega ITb external drive is now unmounting. Tried to connect this morning only to get the 'dodgey diconnection' message. Rtried several times, the drive appeared then unmounted, usually with the bad disconnection message. Eventually got it up and running, ran for three and half hours copying APerture and iTunes files for back up then dismounted again. I have just started using Carbon Copy Cloner to move these files about.... any connection?? It seems to get nothing but praise. Come on Apple.... 8.5 thousand people have visited this thread, what's going on?


    PS also have a WD Elements 1Tb extHD connected with no issues so far.

  • rbeamon Level 1 Level 1

    Yet another me too!


    TM will unmount every few days for no reason. Resetting the power switch of the BlacX external dock will reboot the 500 GB WD drive fine, but it's a PITA. When booted TM is doing its job all ok.


    Using SL in a 3 month old iMac that works fine in all other respects. New with Mac so haven't mentioned my problem until now, but does Lion have this problem also?

  • Kenneth Cohen1 Level 1 Level 1

    This is an old problem, I've had it for years. I'm convinced it relates to sleep - either the computer in sleep or the drive putting itself to sleep to "save energy".


    The best I can suggest is, in the Energy Preference panel in System Preferences, uncheck "put the hard drive to sleep when possible".

  • rbeamon Level 1 Level 1

    Thanks, Ken. My iMac is in and out of sleep many times per day. I leave it on all my waking hours, shutting it down only at bedtime.


    I could run without using "sleep" for a week or so. If it doesn't dismount the TM external drive, that will prove a point.

  • Lamprey Level 1 Level 1

    Add me in.  Brand new G Tech 2TB drive keeps unmounting on my 7 month old iMac.  Running 10.6.8.  I have unchecked the put hd to sleep and will see if that works. 


    Hopefully Apple will address this...agree too many posts here about the same thing.

  • rbeamon Level 1 Level 1

    Hmm. I installed Lion a couple of week ago and the external drive doing the Time Machine duties hasn't dismounted yet. Seems as if they've fixed the problen in Lion.

Previous 1 2 3 4 5 Next