Previous 1 2 3 4 5 6 Next 132 Replies Latest reply: Dec 19, 2015 11:31 PM by jmooseman Go to original post
  • Kenneth Cohen1 Level 1 (70 points)

    Another guess: it might have something to do with the brand of hard drive. With Iomega external drives, it definitely is a problem, they will dismount themselves or may go into some semi-mounted state after not being used for some time - this results in apparent freezes of the computer when waking from sleep or starting up. If I disconnect the external drive from the computer, often the computer will then continue its startup or wakeup routines as though nothing had happened.


    I also have two Western Digital external drives - the problem does not seem to occur with them, or if it does, it's much less frequent.


    Also - in my experience, this problem will occur with both Firewire and USB 2.0, so I don't think the connection type has much to do with it. I think it's a problem of communication between Mac OS X and the external drive's firmware. In the case of Western Digital, they install their own software on the Mac's internal drive, so that may have something to do with alleviating the condition.

  • rbeamon Level 1 (0 points)

    In my case it IS a WD drive that was becoming unmounted frequently. It works through USB 2.0 and all I did was change to Lion. 

  • gmarinov Level 1 (30 points)

    me too


    4 hard drives: 2 x Samsung 500GB, 1 x Seagate 2TB, 1 x WD 750GB, connected via 2 x Icy Box, all ejecting on their own, regardless of scenario. the 2TB Seagate is the only one that doesn't eject itself. Timeouts in the console logs, like this:


    13/11/2011 00:18:42          kernel          USBF:          827384.749          AppleUSBEHCI[0xd69b800]::Found a transaction past the completion deadline on bus 0xfd, timing out! (Addr: 5, EP: 2)


    I am incredibly frustrated. The drives work perfectly fine in Read mode.

    Any help is appreciated..

  • gmarinov Level 1 (30 points)

    edit: check your USB *port* connection. the cable may be OK, just not in good contact with the computer. I had a box fail on me all day, and it's a box I've been happily using so far. The only difference was, I moved the cable from the USB hub it typically sat in, and plugged it straight into the laptop. I'm 8gb into a 550gb copy. May come back and report after it's finished... if it finishes.

  • gmarinov Level 1 (30 points)

    550gb copied over 8 hours, no glitches.

  • rbeamon Level 1 (0 points)

    Me and my big mouth. My external drive became unmounted twice since my post of a few days ago. I went about 5 weeks with Lion and thought it was fine, but here we go again!

  • Kenneth Cohen1 Level 1 (70 points)

    This may help, I haven't tried it yet but there's not much to lose at $2.  St. Clair Software is also the maker of Default Folder, which I've been using for many years.


  • rbeamon Level 1 (0 points)

    Many thanks, Ken. I'm new enough to Apple to not know many of the Apps yet. Will check this one.

  • Kenneth Cohen1 Level 1 (70 points)

    "Jettison" appears to be new. I wish it had come out years ago, anyone who uses external drives with a computer needs the drives to dismount before the computer goes to sleep, or you could have the problems we've been talking about when the computer wakes up. While you're at it, if you have any use for a good file/folder navigation utility, look at Default Folder on the St. Clair software website, it's very popular for good reason, really enhances the rate at which you can get work done by making it much easier to hop from place to place on the computer.

  • rbeamon Level 1 (0 points)

    Yes, I will likely try "Jettison". Looks as though it's a hands off deal with no side effects. My use of the computer is pedestrian enough that I wouldn't need Default Folder X, as they now call it, but may still try it as I really miss the PC file hierarchy. Default Folder X looks like a more logical layout.

  • carsten205 Level 1 (0 points)

    Hi guys,


    I have been struggeling with this problem for years, then yesterday, I came to find, that the powersupply to a laptop can only support so much before some of the more demanding/powerconsuming items seems to unmounth. My firewire connected hard drive beeing dismounthed, it is powerdependent 2.5", seemingly takes up a lot of power, but is somehow prioritized higer than feks. my western digital 2 tb. drive, that keeps unmounthing. When dismounthed this firewire hd, I no longer have the problem with WD 2 tb. unmounthing.


    Hope somebody may try to eject or dismounth other items connected to espc. laptops, and then try again to see, if this very simple maneouvre may be able to help.

    "Simplicity is the last step of art and the first step of nature." (Quote: Bruce Lee)

  • Robby Berman Level 1 (130 points)

    Add me in here, too. I've also been struggling with this for years on both my iMac 24" and MBP USB ports. The MBP dismonuts are much less frequent, though.

    It's not the cable or specific port. It's also not the drive. I've had multiple replacement drives from OWC that exhibited this problem, as well as a Wiebitech drive.

    This is very frustrating and worrying; eventually these drives develop bad blocks.

    I'm something of a troubleshooting idiot savant, but I've have spent years on this to no avail. Frankly, I'm relieved to see I'm not alone.

  • Stuart Meyer Level 1 (0 points)

    Here's another Me Too for you.  I use a 2 TB Buffalo external drive to clone the HD with Carbon Copy Cloner (CCC).  Lately, CCC has been unable to write certain sectors to the Buffalo drive and I have had to erase and zero it out in Disk Utility for CCC to work correctly.  I think it is going bad.  At the same time this started happening, my Time Machine external drive started unmounting mysteriously and not mounting when I would turn the iMac 27" on.  I can turn it off and on to mount it and Time Machine kicks in to backup at that point.  But, sometimes I'll walk away and it will be disconnected without any warnings or error messages, so I can't tell if it even completed the backup.  Then, at the same time all of this started, when I would be in Photoshop and go to open a file it would take about 20 or 30 seconds to render thumbnails.  The window would appear blank for that entire time as though there wasn't anything in the folder.  Same thing would happen when I would manually go into Finder.  It seems to take an inordinately long time to render the thumbnails in a folder.  None of those two external drives are powered by USB and have their own power source and they stay powered on even if the iMac is off.   Any thoughts on whether something is going on with my HD drive too?  It seem that everything is going bad.

  • Jim Plante Level 1 (0 points)

    Okay, guys, I found this on MacOS Hints:


    Uses a couple of scripts to unmount drives on sleep and remount them on wake. Worth a try.


    I've got the same problem as the rest of you. When this Core i7 goes to sleep, the backup drive unmounts. Then CarbonCopyCloner can't find it on wake. This s*ucks (d*amned censor), and isn't very Mac-like. What happened to "It just works!"? I'll try these scripts and see if they solve the problem.

  • Jim Plante Level 1 (0 points)

    Well, those scripts worked! Try them.


    You need to work with the Terminal a little, but you can copy and paste into TextEdit to make the scripts. Then copy and paste the Terminal commands line by line if you're shy about using the terminal.

Previous 1 2 3 4 5 6 Next