Skip navigation

External Drive UNMOUNTING On Its Own...

70051 Views 125 Replies Latest reply: Mar 7, 2014 11:11 AM by marrlin RSS
  • niccodeamus Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 24, 2012 3:06 PM (in response to carsten205)

    mine also would lock into sleep.  sometimes it would just take ages to wake, holding down space button for ages, clicking mouse, turning mouse power off, all that type of thing would eventually wake it.  I am sure something is using clock cycles in a loop.

     

    i have had problems with spotlight indexing getting stuck, and now the screen saver and possibly itunes all affecting the FW800 chain.

     

    with the screen saver on a stock apple pattern and itunes off, CCC has just completed a 4 hour clone without dropping the chain.

     

    TimeMachine refused to work during the backup though, for whatever reason

  • Marcus Muench1 Level 1 Level 1 (5 points)
    Currently Being Moderated
    Nov 2, 2012 7:05 AM (in response to howwow)

    Unfortunately you cann add me to "me too"! I have a Mac Mini that is two months old, and a WD 1,5TB USB harddrive for Time Machine backup (I use encrypted filesystem).

     

    I have deactivated sleep for computer and harddrives, and the computer was up and running over night. The last backup was created at 06:22 this morning, and the attempt at 07:20 failed with exactly this error. I tested all three USB ports on the Mac Mini, it's all the same.

     

    After reboot I deactivated TimeMachine and copied a 3,5GB DVD image into the root folder of the external drive. Copying started slowly, but then worked fine. At about 960MB the copy process stopped, I saw the error messages

     

    Nov  2 14:48:09 macminimm kernel[0]: USBF:455.470AppleUSBEHCI[0xffffff803d844000]::Found a transaction past the completion deadline on bus 0xfa, timing out! (Addr: 10, EP: 2)

     

    at a regular basis, and after about five minutes the copy in the finder stopped with error -36 and a notification that the volume has not been unmounted correctly (and been unmounted then).

     

    I hope this is not an issue with the logic board, all other USB devices (mouse, DVD drive, Logitech wireless headset) work with no issues.

  • Jim Mcdonald Level 1 Level 1 (10 points)
    Currently Being Moderated
    Dec 7, 2012 7:02 AM (in response to Marcus Muench1)

    Last month I decided to buy a LaCie 3T for data storage (I've another drive for TM) with FW 800 capability. The drive would un-mount when the MBP was left unattended, accompanied by a Finder freeze. I'd have to do a hard re-start on both the MBP and the 3T to get things functioning again. I assumed that it was a faulty 3T, just made an exchange with LaCie to get another drive, and I'm finding that the new drive also un-mounts during sleep, even if I change the Energy Saver prefs to NOT put drives to sleep when possible. Right now I had to downgrade to USB 2.0 and so far, during one length of time when the MBP was asleep, the 3T remained mounted. Tonight I'll do an Apple Hardware Test to determine if the FW 800 port is functioning properly. I'm also lucky in that my 3 year warranty isn't expired yet. I'll be calling Apple up regardless, and may request a new logic board. I'll write a follow-up.

  • carsten205 Calculating status...
    Currently Being Moderated
    Dec 7, 2012 8:28 AM (in response to Jim Mcdonald)

    I had a new motherboard installed as my mac froze and it kept happening after that, so I doubt logic/motherboard will do diffrence much, if logic is same as motherboard?!

    But as it still now happens, I can inform you, that sometimes it happens, and after a while, nomatter how many times you close down and start up, it may incidentially, as in my case, just suddenly dissapear or come and go.

     

    I cannot find any reasonable explanation, but I have another issue allso, that may give some hints for someone who knows stuff, my startup sound is sometimes high, sometimes low and sometimes medium, this again has nothing to do with what soundlevel it was closed down at or any kind of settings beeing so set, as it has not manually been adjusted in between the diff. experiences.

     

    My mac is 8 yrs. old and it happens more or less as it did back in the day...

  • Dill Calculating status...
    Currently Being Moderated
    Dec 12, 2012 10:58 AM (in response to howwow)

    I'm posting here to try and get support on a 'work around' for this situation...  My External USB Drive appears to be going to sleep requiring me to reboot or unplug and plug the device back in before I can write to it. 

       My first idea was to have an applescript or automator task access the usb drive every 5 min or so to prevent it from being idle long enough for it to sleep.  (sounds good, but probably bad for the External Drive)

       My second idea was to have an applescript of automator task that can 'zap' my usb ports and have them re-check for connected devices. (sounds great, but can't find any info on this possibility)

       Lastly, I've remembered on older OS's that you could choose to quit the Finder and it would relaunch the Finder... so I wonder if quitting the Finder would make the OS review connected USB devices and mount any available???  (best option if it will work IMO... problem I have is quitting Finder in Mountain Lion since that option appears to be missing)

     

    do any of these options sound like sufficient work arounds?  I'd like to try any of them, any support would be appreciated.

     

    Thanks,

  • Kenneth Cohen1 Level 1 Level 1 (60 points)
    Currently Being Moderated
    Dec 12, 2012 11:56 AM (in response to Dill)

    Dill - I've had similar problems for years. When my iMac goes to sleep, so do the external drives, which I wouuld expect; but when the computer wakes up, only its internal drive wakes, and the external drives simply aren't there. In fact I believe they have been unmounted but not ejected. This in turn causes the real problem for me - the computer itself may "hang" because it is looking for the drives and can't find them. Or some running applications (MS Word) may hang for the same reason after awakening, they can't find the external drives.

     

    Best solution I've found is to make sure that the drives dismount automatically when the computer goes to sleep. I use a small app from St. Clair software (the Default Folder developer) called "Jettison" to do this. This eliminates the hanging problems. The external drives are automatically ejected upon sleep, and generally need to be restarted after the computer wakes up (I press the power buttons on them to do this, since they've been ejected and so there is no way to automatically remount them that I know of). As long as nothing hangs, I'm satisfied with it.

  • Dill Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 12, 2012 3:13 PM (in response to Kenneth Cohen1)

    I've read quite a bit about various unmounting/ejecting symptoms of USB drives on Mac OS, and couldn't really find much on my particular situation or a fix for it.  I'll look into Jettison, but I'm not sure it'll help as I have reason to believe that it's my external drive that is going to sleep while I'm active on my computer but not the drive.  When it puts itself to sleep or whatever it does, it requires me to restart my computer or unplug the device before I can get it to mount and can write to it again.  Interestingly enough, I can still listen to music from the external drive even when it has stopped allowing 'write' access.  A restart of my computer has always been the solution for me, but I'd love a better work around this issue.  I'd like to avoid purchasing another external drive only to have the problem persist. 

     

    Thanks for your suggestion, I'll do some research on Jettison and see if it can help me...

  • carsten205 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 13, 2012 2:19 AM (in response to howwow)

    Ok, so now we may have some good news!

     

    Speaking on the phone today with a person from Promac, an apple repairfacility in my country, Denmark, said, that as WD My book Studio II (for mac) is dealing with this problem, using their HD's should solve the problem, just in case anyone is going to get a new HD, we all like to hear if this works. Actually I could see myself looking into getting one soon.

     

    There may exist another newer Thunderbolt connected version too, but my gear is way too old for that, so if anyone gets into that, I guess we all like to hear reg. this too.

  • Kenneth Cohen1 Level 1 Level 1 (60 points)
    Currently Being Moderated
    Dec 13, 2012 6:22 AM (in response to Dill)

    I was about to say something similar to what carsten205 says. I have two Western Digital drives which don't fall asleep "during the day" if the computer doesn't sleep, and are OK while the internal drive doesn't sleep. They come with their own driver software which probably handles things like this. You have to keep the drivers updated, there is no warning or reminder about this. Otherwise they have also been reliable.

     

    My external drives that do have this problem are both Iomegas that I bought about three and four years ago. They're reliable in most ways, but this little glitch - going to sleep even when the computer is not - seems to happen if the drive has not been accessed for a couple hours.

     

    One thing you could try, to fix your problem, is to write an Applescript that automatically accesses the external drive every so often, that might help, just a guess though.

  • John Fitzpatrick Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 13, 2012 7:33 PM (in response to howwow)

    I am going to join in.  I have a 2012 mac mini server that does not sleep.  I have attached to it via USB a 2tb buffalo drive that is used only for itunes media storage.  Twice, the computer shut down due to a problem.  Each time after restarting it, the 2tb drive was nowhere to be found.  Restarting again, it still did not show up.  Unplugging the usb cord and reinserting did not bring it back.  The only way to get it back was to unplug both power and usb.  Then it showed up again.  I have also had just the drive disappear without the computer shutting down due to a problem.  This happened numerous times over the past several days.  I see no rhyme or reason as to why this is happening.  I have replaced the usb cable and tried alternate ports but it continues...stinks to have problems like this on a brand new computer....

  • Jim Mcdonald Level 1 Level 1 (10 points)
    Currently Being Moderated
    Dec 18, 2012 10:37 PM (in response to Jim Mcdonald)

    I moved the 3T LaCie to the iMac upstairs and found that the drive behaved as before. I also found that it affected the behavior of another LaCie external drive daisy-chained to the 3T. So the easy deduction is that the LaCie drive is defective-- this is the REPLACEMENT drive that was defective. And now I've found that the drive acts up when I have it connected via USB 2.0. It's the enclosure wiring and/or design that's the problem, IMO.

     

    I suppose that the better news is that the problem appears to NOT be the MBP.

     

    So I'm awaiting a second replacement drive via Fed-Ex. I told the LaCie folks to test the damned thing before sending it to me. We'll see.

  • OzziesMAC Level 2 Level 2 (150 points)
    Currently Being Moderated
    Dec 22, 2012 9:56 PM (in response to howwow)

    No solutions within the mac for daisy chain drives unmounting?

     

    I have 2 g-drives daisy chained via fire wire 800 and over night the are dismounting improperly.

  • James Cook2 Level 1 Level 1 (10 points)
    Currently Being Moderated
    Dec 26, 2012 9:10 AM (in response to OzziesMAC)

    I'm convinced it's a Time Machine bug and has nothing to do with the drives.

     

    I bought a new LaCie external drive and it kept dismounting after Time Machine backups. The drive still showed on the Desktop, but trying to view its contents would show an empty drive and crash the Finder - perpetual spinning ball. Other apps remain accessible and operational, just no Desktop response. Restarting always results in a blank screen unless I forced the restart.

     

    Energy Saver has been set to sleep just the monitor.

     

    As long as I leave Time Machine off, the drive works perfectly for days. I just turned TM back on this morning, it did a backup and when I came back to the computer an hour later the drive was once again in limbo.

     

    After restarts Time Machine can do a backup. If it's allowed to sit until another backup is scheduled the drive will once again be inaccessible.

     

    Time Machine is creating the problem.

  • OzziesMAC Level 2 Level 2 (150 points)
    Currently Being Moderated
    Jan 12, 2013 1:46 PM (in response to James Cook2)

    I also do not think it's the external drives, we have to many different brands having the same exact issue of the Mac unmounting the external drive on its own.  I run iTunes 24/7 with two external G-Technology drives daisy chained via firewire 800.  It is always unmounting the second drive when after the Mac has been sleeping for a bit.

     

    The work around that I have been using is letting the Mac display go to sleep but keeping the Mac awake at all times.  Since I have done this the external drives do not unmount.  Has anybody found a fix or a better work around yet?

  • Jim Mcdonald Level 1 Level 1 (10 points)
    Currently Being Moderated
    Jan 13, 2013 9:57 PM (in response to OzziesMAC)

    In my case, it WAS the LaCie 3T that was the problem. It was, I suspect, something in the enclosure interface or firmware or software that was the problem.

     

    I received two replacement, which meant that I used and tested 3 drives altogether. On the third try, I immediately reformated the drive to a Mac extended journaled, and in doing so, erased all of the LaCie software. I then cloned the data from the older 3T to the newest one, and have kept the newest drive on FW800. It gets daily use, gets mounted and unmounted a couple of times a day, with no problems.

     

    Since that time, I've had no problems with the newest drive, and returned the older one via FedEx.

1 ... 4 5 6 7 8 9 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (5)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.