Previous 1 3 4 5 6 7 Next 793 Replies Latest reply: Sep 14, 2013 9:32 AM by larrylintz Go to original post
  • patdpoo Level 1 (0 points)
    Dave, is this your replacement one? So you've exchanged your ATV2 device and still not luck? If so, this is so sucky. Apple needs to fix this quick. I have not gotten mine problem resolved and hoping the Apple specialist has referred to the engineers. He mentioned calling me Thurs, tomorrow. Hope he does or I'm back on the phone with Apple support. I'd hate to return it as this is exactly what I've wanted in a home entertainment center for my tv, but if it's crappy manufacturing and poor planning, then I will do that in a heartbeat.
  • davepaisley Level 1 (0 points)
    Yes, this is the replacement. The odds on it being hardware are now pretty small at this point, so the problem must be something to do with the network setup. As I mentioned, it works fine when wired, and streams internal stuff just fine wirelessly even.

    Some other threads here say the ATV2 tries to use certain ports on the router that may be a problem. Another thing I am wondering about is whether the "send information to Apple" option has something to do with it (but if that were the case, why does it work OK when wired into ethernet directly?)

    Given that my other 14 wireless devices work just fine, what is the deal with this?
  • kman-5 Level 1 (0 points)
    Same problem; start a movie, wait for it to load, plays for a few seconds, kicks me out back to the start movie screen. I'd bet it is having a problem with the connection speed and not the authentication, otherwise you would never get past the initial screen to select a movie. I finally gave up and watched the movie using the Netflix app on my TV, no problems. If they don't fix some of these issues it may be going back.
  • a brody Level 9 (65,410 points)
    Given that my other 14 wireless devices work just fine, what is the deal with this?

    Can one say overload? Yes, in theory you can take many devices. But practice is never what theory suggests. For each device your bandwidth is spliced. Get enough devices sharing a line, you eventually will have no bandwidth for the device that decides it wants all the bandwidth. Then it just conks out. There is an old methodology that dates back to prior computing days, the k.i.s.s. principle. So please simplify and isolate it on its own with the router. If it doesn't work with the router alone, then you have argument to take it back. Otherwise you don't know who is eating the bandwidth from whom.
  • Tim Campbell1 Level 3 (575 points)
    If it's able to stream shows from your Mac very quickly then it doesn't sound like it has any networking issues. There's the known issue of OpenDNS (I know several ISPs use OpenDNS) but there's the Google public DNS server work-around (manually using as the DNS server address) which seems to fix the problem. Also you report the issue with any remote streaming (e.g. even from Apple) and DNS work-around is normally only need for people who are just having the problem with Netflix (and nothing else.)

    I'm wondering what kind of network performance your ISP is giving you when your Apple TV is having problems streaming shows from the Internet.

    You might get on your computer and go to and let it check your speeds. Streaming a movie takes a good bit of bandwidth and if the ISP can't keep up it'll be a problem... but that should be a problem for anything that can stream Netflix, not just Apple TV. Some ISPs really suffer during "prime time" (when everyone is home using the Internet) but don't have issues at other times of the day (when people are at work or school.) It is important to test your ISP connection at the same time of day when your Apple TV is having problems.
  • patdpoo Level 1 (0 points)
    Tim, my speed test show 5m. Netflix also tested my speed from the ATV2 and got zero coming from it. They checked other screen shots and info from previously viewed streaming from other devices in our home and it showed 5 as well. So speeds not the issue for me.
  • davepaisley Level 1 (0 points)
    Hey, thanks for the condescending tone. It seems to be a forte of yours.

    Did you read the bit where I wrote that I turned off all the other devices, rebooted the router and the ATV2 and the issue is till the same?

    Besides, I can have half a dozen devices running at a time and they all work fine.

    We're talking less than 1,000th of normal bandwidth here, not even down to a tenth. More than three orders of magnitude.

    When you have something meaningful and useful to say I'll be glad to see it. Until then...
  • davepaisley Level 1 (0 points)
    I have comcast cable, and it routinely tests at the upper end of performance.

    As I've said several times here and to Apple, the ATV2 works fine when plugged into the router and all my other devices work fine at the same time the ATV2 is struggling.

    It's an issue of it getting only kilobits a second via wireless outside my home network instead of megabits.

    It has to be some setting somewhere... There's another thread about the ATV2 trying to ping some external port that most routers may block. I'll check that out when I get home tonight.
  • Tim Campbell1 Level 3 (575 points)

    Just making sure I didn't misunderstand any details...

    If you plug the ATV2 in via "wired" network, everything works, and everything is fast.
    If you unplug the ATV2 and make it use "wireless", then only "local" content (e.g. streamed from iTunes on a nearby computer) is fast, but everything that has to come from the Internet (movies from Netflix or Apple) is slow and bounces you out.

    Is that correct?

    I have an original ATV1 (wired) as well as a new ATV2 (wireless) and am not having any problems BUT, unfortunately my ATV2 is in a room where it needs to be wireless. I have a 2nd ATV2 on the way and should be able to test this theory as it'll be installed in a location where it could use either wired or wireless (so what I'm about to suggest is untested), but here goes...

    When a device has more than one type of network interface (e.g. "wired" and "wireless") they are usually treated as completely independent -- meaning that when they are configured via DHCP (from your router usually) they will not get the same IP address. Also any manual configurations you do (e.g. if you configure the DNS server to force it to the address) while it's on "wired", this would probably not be remembered when you switch to wireless (you'd have to re-enter the information.)

    Have you reviewed the network settings issued to the ATV2 after it was switched to wireless, and if so, is it different (e.g. DNS settings) than when you use wired?
  • davepaisley Level 1 (0 points)
    First part is correct.

    I manually changed the DNS to while it was wireless - also tried at one point. I haven't looked at the settings it automatically set up when wired, but that would be a good thing to do.

    Next step is to take it to a friend's house to see how it behaves there...

    (also check router settings for blocked ports, firmware updates, etc., turn off send to Apple and turn off the 1 hour timeout to see if having it stay awak for a few hours will help.)
  • Sullipilot Level 1 (0 points)
    I called Netflix and they said that it said my ATV was getting 0 Bandwith. Not too sure what that means. But they shot me over to Apple and they were just as confused and had me do a bunch of tests for engineers to look at. Hope it works. Its a great little thing but I'd like to get it to work 100%
  • patdpoo Level 1 (0 points)
    Exact same thing I went through calling Netflix. Apple support hadn't heard until the guy checked out the forums. You have to believe that support by now has heard of everyone's issues. I'm waiting to hear back after consulting the engineers too. Let's hope we hear soon!
  • Vageli Level 1 (0 points)
    If a may be able to throw my two cents in the troubleshooting pile, given the fact that your ATV2 works wired but not in wireless, would point out an issue with the wireless link between your router and ATV2.

    Let me try to quantify this a bit, so that it makes sense:

    You see, even though we are conditioned to see connection speeds reported as 54MBits, or 130, or even 300 with N equipment, all this is more of a theoretical value than a realistic one. And though all of us know this to be the case, in reality, that translates to a series of ill-fated possibilities.

    From other posters earlier in the thread, it appears that the quality of the expected stream from ATV2 is higher than say the Roku, xbox, PS3 or TiVo implementation. Unknowing if this is possibly changed in future firmware releases or not, your current description points to perhaps a wireless connection that does not maintain a consistent bandwidth between the source (Netflix) and the ATV2 Box.

    Though the connection may be still up, most likely it is fluctuating; and by that it may drop to any of the in between rates, from 1.5, 2, 5, 11, 24, 48 MBps that are possible within the g-standard. Adding any WEP/WPA encryption, and possible neighboring interference in the mix, compounds the issue even further. And if your wireless connection drops even for a second to anything below 11MBps, that will not be enough to maintain a healthy Netflix stream, on top of all the encryption, networking stack chatter and packets that encapsulate it.

    So you may have to patiently experiment with different channels, transmission modes and encryption types for testing, and that will give you a better idea as to why this is happening.

    Keep us posted; I am sure you will be able to find the light in the end of this tunnel
  • Tim Campbell1 Level 3 (575 points)
    Vageli wrote:
    You see, even though we are conditioned to see connection speeds reported as 54MBits, or 130, or even 300 with N equipment, all this is more of a theoretical value than a realistic one. And though all of us know this to be the case, in reality, that translates to a series of ill-fated possibilities.

    That's a valid point. 54Mbps is the theoretical max speed of 802.11g technology. But very rarely does anyone actually get 54Mbps. I think Broadcom (who makes most of the chips) states that the average connection is closer to 24 -- and that's with reasonably good signal. Any weaker and the connection would drop to 11 or worse -- at which point you are precariously close to the point where it is no longer possible to 'stream' a movie. You'd have to pre-download the entire thing.

    The advantage of 'n' technology is twofold. In part, it's that the speed is faster. But the other half (and possibly more significant) is that the range is much greater. 802.11n allows clients to be about 3x farther away AND still have an even better signal as compared to 'g'. I think Broadcom states that the average 'n' user is getting around 160Mbps -- which is a HUGE difference. Often times a house that requires 2 or more 'g' base stations can have the entire space adequately covered with just 1 'n' base station.

    But what doesn't make sense in Dave's case is that when he's on wireless he can STILL stream quite nicely as long as the machine he's streaming from is in the house. If the root issue in his case were wireless signal quality, it should be equally poor when try to stream from a local computer running iTunes.

    If you have an 802.11n router, set it to use the 2.4GHz bandwidth as this will have better penetration through objects than 5GHz (lower wavelengths penetrate better.) There are utilities you can get which will show you which channels are being used (normally not displayed in your list of wifi networks). If there are many other wifi networks in your area, you'd like to know which channels they're using so you can avoid using the same channel (thus reducing interference). There's also signal bleed to adjacent channels (technically it can bleed just slightly into a frequency 2 channels away).
  • davepaisley Level 1 (0 points)
    Again, all of that is very interesting, but all of my other devices (desktops, laptops, Wii, iPhones, iPods, iPad, printer, WAP) work flawlessly without this endless ******* around trying to find some mysterious network problem.

    The ATV2 is supposed to be the ultimate out-of-the-box experience - take it out, plug it in, watch stuff (well, after all that tarting around with the virtual keyboard).

    C'mon, grannies should be able to set this thing up without resorting to black belt kung-fu networking.
Previous 1 3 4 5 6 7 Next