Skip navigation

Netflix Problems

436272 Views 793 Replies Latest reply: Sep 14, 2013 9:32 AM by larrylintz RSS
  • JRoDDz Calculating status...
    Currently Being Moderated
    Oct 13, 2010 5:33 PM (in response to Vageli)
    Vageli, I agree. If the ATV works fine on the LAN connection then it's got to be something with your WiFi. Sometimes you have to look at the simplest explanation.
  • Matt Gahs Calculating status...
    Currently Being Moderated
    Oct 14, 2010 7:57 AM (in response to JRoDDz)
    Maybe I can help clear up some confusion (while also saying i'm having the same "bounce back to menu" problem).

    • I have never had the "Cannot play this movie" error.
    • There are certain titles for me that, when I try to play them, it takes three to four times longer to load them (black screen with white pinwheel) than other shows. Normal shows take about ~15 seconds, these troublesome shows take ~45 seconds or more.
    • Troublesome episodes for me include: "Weeds", Season 5, Episode 1. Another is "Cake Boss", Season 1, Episode 1.
    • When they begin playing, I get 4 to 5 seconds of video, then it acts as though I pressed the menu button and takes me back to the episode detail screen with the "Play" button.
    • My DNS is set to 8.8.8.8, which made no difference.
    • I have played several videos without issue before coming upon a troublesome episode, and when I move on to some other episode or series, they work perfectly, too. Whenever I go back to a troublesome episode, I get the same experience.
    • I am on 2Mbps DSL, hard ethernet from the modem to an AirPort Extreme, from there hard ethernet to the Apple TV. No wireless devices are enabled when this issue occurs.

    As I mentioned before, I can use the Apple TV flawlessly on Netflix BEFORE I encounter a troublesome episode, as well as immediately after. It does not appear to be a "bandwidth" issue.

    Can anyone else list their troublesome episodes, or verify that the ones I listed DO or DO NOT work with their Apple TV?

    -Thanks!
    Matt
    MacBook (White), Mac OS X (10.6.3)
  • patdpoo Calculating status...
    Currently Being Moderated
    Oct 14, 2010 11:38 AM (in response to Matt Gahs)
    I have already listed my problems via earlier posts. Many of your issues are mine and others.
    iMac, Mac OS X (10.5.8), ATV2
  • davepaisley Calculating status...
    Currently Being Moderated
    Oct 14, 2010 1:26 PM (in response to CalebG)
    To recap quickly - my ATV2 works fine when wired, works fine on the home network when wireless, but is abominably slow when connecting to outside sources while wireless. All other wireless devices work flawlessly, and have done for years.

    Today I took the ATV2 to a friend's house to try it on his wireless network. He has an identical router (Linksys WRT160N ver 1) with no fancy settings.

    Hooked everything up, put in the network SSID and password (WPA2 Personal) and everything worked flawlessly. Looked at the network settings - couldn't really see any differences. It came up as 192.168.1.101 (first available IP address for devices), FWIW. On my network it has been .102, .106, .116 at various times. Default Comcast DNS server. Router address 192.168.1.1.

    He had another refurbed WRT160N handy that he is going to install in his in-laws house. It had never been set up before. We swapped it in, set the SSID and network password. ATV2 worked with it flawlessly too.

    Next step is a hard reset on my own router and then reset the SSID and WPA2 and see what happens. He also loaned me the spare router to try also, so I'll give that a shot.
    Mac Mini, ATV2, Mac OS X (10.6.4)
  • dazexone Calculating status...
    Currently Being Moderated
    Oct 14, 2010 1:35 PM (in response to davepaisley)
    I wonder. Some of these media devices use upnp to get out. I have had stale upnp cache that affected other devices before. Logging into the router and simply clearing all upnp cache from the router fixed my problem. I wonder if that may be the issue with some of the ATV2 problems. Worth a shot.
    Macbook Pro, Mac OS X (10.5.5)
  • Tim Campbell1 Level 3 Level 3 (570 points)
    Currently Being Moderated
    Oct 14, 2010 3:00 PM (in response to Matt Gahs)
    Matt Gahs wrote:
    Maybe I can help clear up some confusion (while also saying i'm having the same "bounce back to menu" problem).

    • I have never had the "Cannot play this movie" error.
    • There are certain titles for me that, when I try to play them, it takes three to four times longer to load them (black screen with white pinwheel) than other shows. Normal shows take about ~15 seconds, these troublesome shows take ~45 seconds or more.


    (snipped list of shows)

    • I am on 2Mbps DSL, hard ethernet from the modem to an AirPort Extreme, from there hard ethernet to the Apple TV. No wireless devices are enabled when this issue occurs.


    A 2Mbps connection is very slow. The issue you're experiencing makes sense.

    There are two different issues at play here.

    First, the producer of the video content gets to determine what quality level they want to use for video compression. While a lot of people get hung up on how "hi def" something is, they're typically thinking along the lines of whether the video is in 480p, 720p/i, or 1080p/i. Unfortunately it's not that simple. A movie recorded a 720p but with very low compression (e.g. high bitrate), can look better than a movie recorded at 1080p but with very high compression (e.g. low bitrate). The 1080p video will only look better if it's bitrate is better than the 720p video.

    Second, there is no uniform speed for playing movies. Movies have variable bitrates.

    If you were to use a digital camera to take two pictures of different subjects, but didn't change any camera settings (same resolution and compression level) and the camera records the pictures as "JPEG" images, you'd find that every picture has a different file size when saved to disk... even though the resolution of the camera didn't change. The file size depends on the complexity of the image and how well it could compress.

    Movies aren't still pictures, so they employ a few other tricks to reduce bandwidth and take advantage of the fact that two frames of video, when compared side by side, are often nearly identical. So rather than transmitting a full frame of video, it's only necessary to transmit the differences between frames. You could overlay a grid of squres on the frame (like a checkerboard). If the contents of the first square in the grid (say the upper-left corner) is identical to the same square in the 2nd frame of video, then you don't really need to transmit that frame. In reality it's a bit more complex than this, but you get the idea.

    If the scene is still (camera isn't panning, zooming, changing focus, etc. but is mostly just still and very little in the scene is moving.) then the differences from frame to frame will be very small. That segment of video will compress extremely well. But if the opposite is true and just about everything is changing all across the scene, then in comparison, that scene wont compress nearly as well and will require a higher bitrate & thus higher bandwidth from your network.

    Basically the "bitrate" of a movie will vary during playback. I suspect what you're encountering is that many (most?) of your movies & TV shows are compressing well enough that the Apple TV doesn't have to buffer very long before it's able to start playing. But just occasionally you hit upon some content that's either recorded at a substantially higher quality OR it's just demanding higher bandwidth because of the way it was filmed.

    The fact that it takes 45 seconds or longer for some content, but only 15 seconds for other content, is not necessarily any cause for concern.
    iMac 2.8 GHz Core i7 8GB / 17"MacBook Pro i7 2.66 GHz 8GB, Mac OS X (10.6.4)
  • dddewitt Calculating status...
    Currently Being Moderated
    Oct 14, 2010 3:12 PM (in response to CalebG)
    I'm having generally the same problems laid out here before: ATV2 works fine with internal network stuff (streaming photos, music, etc) and with internet content like youtube, flickr, etc. But Netflix will play about five seconds of something and then return to the menu.

    What I've noticed though is that it only seems to do this with television shows. I've tried two different movies (Bolt, Phoebe in Wonderland) and both seem to work on par with my previous Netflix experience. But every TV show I play (I've tried Veronica Mars, Bones, and Psych) has this problem.

    If anybody has any clue as to why THAT would make a difference I'd love to know. Unfortunately I mostly use Netflix for tv shows.
    MacBook, Mac OS X (10.6.4)
  • davepaisley Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 15, 2010 3:27 PM (in response to davepaisley)
    Ok, the latest.

    Swap in friend's router (identical model to mine Linksys WRT160N), with his SSID and password untouched, that worked perfectly on his home network - worked perfectly.

    Changed the SSID and password to my own preferences. Back to the same old problem.

    Change the SSID and password back to his - no change in the problem.

    Back to my hardware:
    Hard reset on my router, leave it untouched (so SSID=linksys, no encryption) - no change.

    Tried turning off all devices, reset cable modem, router and ATV2 in order - no change.

    I'm pretty much out of ideas now.
    Mac Mini, ATV2, Dell XPS, Dell E1405, Asus EeePC, Mac OS X (10.6.4), iPhone 3GS, iPod Touch, iPad
  • Gaugevox Calculating status...
    Currently Being Moderated
    Oct 15, 2010 3:51 PM (in response to dddewitt)
    Most of my problems are with TV shows, also. I tried out Bolt, and it played with no problems. Wonder if it has to do with differences in video encoding? The Starz Play titles (like Bolt) seemed to be compressed a bit more than other titles.
    MacBook Pro, Mac OS X (10.6.4)
  • Sullipilot Calculating status...
    Currently Being Moderated
    Oct 16, 2010 8:23 AM (in response to davepaisley)
    Was the modem the same? Also how are your iTunes downloads? I only ask because if its simply just changing a modem/router I am gonna run out and get a new one.
    Thanks,
    Sully
    Mac Mini, Mac OS X (10.5.5)
  • patdpoo Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 16, 2010 8:49 AM (in response to patdpoo)
    Here's the latest for me. I completely unplugged everything: the Apple Airport Extreme, cable modem, Sony tv and ATV2. I hadn't realized that we didn't completely unplug everything at the same time. My husband had unplugged TV and ATV, but never the rest. So after starting again, I completely reset my Airport and put it back to my defaults. All this seemed to help a bunch. Still not able to stream TV shows like The Office as it is still bumping out to the start after about 4 seconds. But successfully was able to watch Heros and a complete movie on Netflix. That is progress from previous attempts.

    I have a support contact with Apple whom I will attempt to contact today or tomorrow who wants me to try some things the engineers told him to do.

    Will update how that goes.
    iMac, Mac OS X (10.5.8), ATV2
  • J Simpson Calculating status...
    Currently Being Moderated
    Oct 16, 2010 9:19 AM (in response to CalebG)
    I have the same problem it sounds like many people have with Netflix. Netflix worked beautifully for the first couple weeks, but just within the last two days, I can't stream ANY movies. I can access Netflix, browse titles, add/remove movies to my queue, but I can't watch anything.

    The error message is this: "Sorry we could not reach the Netflix service. Please try again later. If the problem persists please visit the Netflix website. (112)."

    I went to Netflix, and they, of course, just point you back to Apple customer support.
    ATV2, Mac OS X (10.6.4)
  • jasonawright Calculating status...
    Currently Being Moderated
    Oct 16, 2010 10:09 AM (in response to CalebG)
    I had the same problem where Netflix selections would take a long time to download and then drop after 2-3 seconds. I have Verizon FIOS and worked with tech support to update my Actiontec M1424WR router to select a difference channel for frequency and increase the number of channels to use. This improved download speed and, at least in a couple of trials so far, did not drop Netflix selections. Try it out yourself. Could be that you just need to change some router settings to improve your access. It's worked for me so far.
    Asus N71J Laptop, Windows 7
  • Dh4ck3r Calculating status...
    Currently Being Moderated
    Oct 16, 2010 5:52 PM (in response to CalebG)
    Having a problem with my netflix "genre" listings. I am able to login to netflix and view all the movie genre's, but I cannot enter the children and family movie listings. Netflix times out and errors with the "temporarily unavailable. Try again later" message. I can enter all other genre listings and view and play movies without issues. Just can't see the childrens and family listings. This has been going on for two days. I can access those listings on my iPad without issue and netflix customer support says they have never heard of this. Apple was less than helpful as well. Any thoughts?
    Apple TV 2 G
  • gepark Calculating status...
    Currently Being Moderated
    Oct 17, 2010 5:48 AM (in response to Dh4ck3r)
    I'm having exactly the same problem with my Netflix connection. If I log into my account using my Macbook, I can see all the genres listed and watch from anything. Through the Apple TV I can't browse the "Children and Family" area. Same error - "temporarily unavailable".
    Apple TV (2nd generation)
1 ... 4 5 6 7 8 ... 53 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (10)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.