Previous 1 2 3 4 5 6 Next 79 Replies Latest reply: May 18, 2013 12:28 AM by Owen_B Go to original post
  • CA_Ridgerunner Level 1 (15 points)

    Actually, it appears that there's something associated with the IPv6 settings itself.   I was experiencing the same problem, but already had IPv6 set to "Off"


    SImply turning it "On" corrected the problem.  There was no need to turn it back "Off" as per the above instructions.   


    Odd, but easy to fix.

  • CA_Ridgerunner Level 1 (15 points)

    Bennie -- same for me... flipping the IPv6 setting seem to be the trigger.   Haven't experienced any network problems yet, and doubtful any will pop up.    

  • lisbonbhoy Level 1 (0 points)

    Adding the incoming port rule in "Windows Firewall" on my Windows 7 32 bit laptop  -- and doing similar via my Kaspersky Firewall on my Windows 7 32 bit desktop worked for me  - I'm currently using iTunes version 10.5.1 and ATV2 . Thank you very much!!

  • rocklebee Level 1 (10 points)

    Anybody try this on Lion yet, where the IPv6 options are "Automatically, Manually and Local Link Only?"

  • CA_Ridgerunner Level 1 (15 points)



    Yes - I experienced the problem, and had the solution work fine for me on two different systems running Lion (i7 iMac, and a 13" MacBook Air).   As I'd mentioned in my previous posting, all that was necessary for me to do was toggle the IPv6 setting -- as mine was already set to "Off". 


    Turning it on (and using the "Automatically" choice in Lion) cleared up the problem.  


    Just for testing purposes, I went back approx 24hrs later and set the IPv6 option back to "Off", and the problem still remains resolved.   So again, from my experience and on my systems, it apparently looks like the simple act of toggling the IPv6 settings clears up whatever the bug is.

  • HondaChuck Level 1 (5 points)

    I do not have an "off" option, only "automatically, manually, and local link only"  I have tried all three (although manually wont let me proceed with entering stuff) and I still can not get my itunes to connect to airplay on apple TV.  It works on my MacBookPro but not my imac.  The setting appear to be the same with the only difference being the imac is ethernet wired to internet and macbook is wifi.

  • HondaChuck Level 1 (5 points)

    unplugging the ethernet cord and using wifi on the imac solved the problem.  Is there anyway for this to work while imac is wired instead of wireless?

  • Gustavo8405 Level 1 (0 points)

    Thanks! Worked perfect

  • lee192 Level 1 (0 points)

    I'm having no luck with any of the solutions suggested here. I have unplugged ATV2, then reset ATV2, and attempted to turn off IPV6 (although it doesn't seem to be an option with Lion OS 10.7.2). I used to be able to connect to Apple TV from iTunes and then one day it simply stopped (although it sill shows up in the Airplay box). I'm able to connect to all my Airport Expresses, and my other devices (iPhone, iPad and Macbook) can connect to ATV2.


    But my iMac won't. I want to connect through iMac so that I can run my music to differnt parts of the house (ATV2 + my expresses).


    Apple wants to charge me $30 to answer this question even though I've only had the device since June, and it worked perfectly for the first three or four months I had it. Also, I believe the problem is with my iMac -- not with the ATV2 -- since ATV2 works on the other devices. I do have Applecare on my iMac, but Apple still won't help.


    I'm a little disappointed with Apple about this, and frustrated about what to do to fix ATV2. Any suggestions would be appreciated.

  • mattfromwaimauku Level 1 (0 points)

    OK, here is what you do on Lion, since the option to turn off IPv6 is unavailable in the normal interface.


    - Start Terminal (this is a program found in the Utilities folder in your Applications folder, you can also get there by clicking on the desktop, select "Utilities" in the "Go" menu, then double click on "Terminal".)


    Type exactly these commands into terminal:


    networksetup -setv6off ethernet


    (then hit enter)


    networksetup -setv6off wi-fi


    (then hit enter)


    Then close Terminal, and restart your mac.


    There should now be an option for "off" for IPv6. You can check this by opening the "system preferences" in the apple menu, then click the "network" icon, then select "wi-fi" on the left, then click on the "advanced" button, then select the "TCP/IP" tab. Then "configure IPv6" should be set to "off".


    Try playing itunes through your airport express (or I assume apple TV) and see if it works.

  • JoshJGC Level 1 (0 points)

    Thank you mattfromwaimauku for the "Terminal" command recommendation. Turning the IPv6 off fixed my iTunes AirPlay problem... fyi, I have Airport Extreme TC, Airport Extreme, 3 Expresses and 2 ATV2 for streaming music and iTunes.  Having an unknown error was unbelievable frustrating.

  • Alex Johnson2 Level 1 (115 points)

    Perfect, mattfromwaimaku.

  • ManiAugustine Level 1 (0 points)

    Jason202, you are a genius! Thank you. I was spending a lot of frustrated time on this.

  • Trust Divine Level 1 (0 points)

    Man, I would love it if someone could tell me why my Terminal's response to


    networksetup -setv6off ethernet




    ethernet is not a recognized network service.

    ** Error: The parameters were not valid.



    Thoughts?  Yea, obviously, I'm having the same AirPlay issue others are.

    Thanks mattfromwaimauku, looks like a huge help to many of us though!


    MB Air, 10.7.2

    ATV 2

    Airport Express

  • mattfromwaimauku Level 1 (0 points)

    Ok, that's pretty weird. My only guess is that perhaps you spelled it wrong?


    Thanks to others for the thanks to my post too makes me feel good to know I helped someone