Previous 1 2 3 4 5 6 Next 79 Replies Latest reply: May 18, 2013 12:28 AM by Owen_B Go to original post
  • Alex Johnson2 Level 1 (115 points)

    Yes, because you have a MacBook Air, and you're using ethernet through the USB interface. I don't know what the phrase is: I know it is not "USB Ethernet" because I tried that - but that's why. Someone with better knowledge may be able to help with the correct command. Your AirPort should be OK if you followed the instructions though.

  • skottmckay Level 1 (0 points)

    Ummm - because you have a MB Air, which like doesn't have an ethernet port...


    networksetup -h for help, which lists as the second option '-listallnetworkservices'. From that you will see what services you have.


    Given your hardware, 'networksetup -setv6off Wi-Fi' is probably what you want.

  • mattfromwaimauku Level 1 (0 points)

    ha, that was obvious. I should have realised that!



  • Trust Divine Level 1 (0 points)

    Hey! Its working on my MB Air now!


    Thanks everyone!


    So I ran:


    networksetup -setv6off Wi-Fi


    and I got a new response in iTunes:


    Got a processing wheel for about 20 seconds, then


    "An unknown error (-15006) occurred while connecting to the AirPlay device “Apple TV”


    And then Apple TV was no longer an option for connecting to via AirPlay at the bottom righthand of the iTunes window. Though, homesharing was still "on".


    I turned homesharing off.


    I turned homesharing on.


    Apple TV became an AirPlay option.


    I tried to connect AirPlay via Apple TV.


    Same symptom as before I ran

         networksetup -setv6off Wi-Fi


    AirPay connecting window came up, but nothing.


    I tried again.


    It works!



  • bwrl Level 1 (0 points)



    Everyone who knows their macs knows that the stock solution to any networking related problem is "turn off IPV6".


    I thought Apple were supposed to be user friendly, but hey, it typically worked.


    I have struggled for countless hours getting iTunes on my macmini to connect to my ATV2.  I can stream from it from the ATV2, but streaming to the ATV2 from the macmini stubbornly refused to work.   It used to work but recently, it stopped working.  Not working probably coincided with my upgrade to Lion, but I am unable to say for sure.  My home network is entirely on ethernet but thought I'd try it on Wifi - still no joy.


    My Windows PCs all connect to ATV2 perfectly.  Everything except my macmini worked.  This is a problem because the macmini is my iTunes server.


    So presumably in full knowledge of the fact that most people need to turn off IPV6 for anything to work (!!!) what does Apple do?  Hehe in Lion it removes the option to turn off IPV6, Lol !!!


    Well, mattfromwaimauku I'm no terminal monkey so I'd have had no idea how to turn off IPV6 on my macmini, but thanks to your post, my macmini now connects to ATV6 without issue.

  • jsnowman Level 1 (0 points)

    The Terminal commands helped me and everything works now.



    I must say though:   userfriendliness is far from making stuff in the Terminal...

  • Kaale Level 1 (0 points)

    Thanks to all here! The IPv6 setting fixed my connection problem, too.

  • Alex Yates Level 1 (0 points)

    Thank you Shane Scott, I used your method to help me find a solution. I have a MacBook Air 2nd Gen Running

    Mac OS X Lion 10.7.3 and i did the following:


    1. Open System Preferences

    2. Open Network pane

    3. Select Advanced at the bottom right

    4. Go to the TCP/IP tab

    5. Make sure Configure IPv4 is set to Using DHCP

    6. Make sure Configure IPv6 is set to Link-local only

    7. Click "OK"

    8. Click "Apply"

    9. Quit Itunes

    10. Restart your Mac

    11. Let iTunes connect to you're Airtunes speakers


    These setting have not effected anything else from working but make sure you remember what your original settings are before altering incase you have problems.


    Hope this works!

  • julianelmago Level 1 (0 points)

    So im connected  now to the ATV with my mac book pro with OS X lion 10.7.3, and when playing a movie from my iTunes Library, (arround 10 mins), it kicks me out the movie and says I need to turn on again the Home Sharing option in Itunes on my computer using my Apple Id. The funny part its that in my mac I still have the Home Sharing "on" and logged in but my ATV wont recognize this.

  • Master82 Level 1 (0 points)

    If your using AVG, turned off your AVG firwall and try to play the AirPlay

  • Zatchillac Level 1 (5 points)

    My iTunes keeps closing whenever I would try to access music from my new Apple TV (hard wired) and I would also have to disable and then enable Homesharing again. So far the only thing I've done to fix it (no problems yet) was to unplug the Ethernet cable from the Apple TV. Personally, I think that's kind of rediculous being that I have a Mac mini, Airport Extreme and 2 Apple TVs (started having more issues like this with the newest update).

  • philip290 Level 1 (0 points)

    Itunes will not connect to Apple TV 2 or 3. Homesharing will not connect to Apple TV 2 or 3. Airplay will connect to Apple TV 2 or 3.


    Here is the solution that worked for me if you have the following confiquration:

    iMac connected by ethernet to router.

    Apple Tv 2 or 3 by ethernet to router.

    Apple TV connects to internet but will not see itunes or homesharing.


    "Unplug" do not turn off, actually unplug airport. Plug back in.

    Unplug router. Plug back in. Turn of airport or wi-fi on iMac if you have it on as well as ethernet. It seems Apple TV/Itunes/homesharing and airplay does not like both being on.


    After doing this it should work. If not, repeat but also turn off homesharing on iMac and turn back on.

  • Argomez Level 1 (0 points)

    It worked for me, thanks! you're the man!

  • coreybx Level 1 (0 points)

    Worked with removing IPv6

    Mountain lion users follow above link

  • chompy13 Level 1 (0 points)

    Hi Matt, how are you?

    i hope you can help me.  i have ATV and itunes in my Dell notebook. it used to work pefectlly managing my itunes through my ipad listening to my itunes music. but know in my itunes on the dell appears air play error (-15000).

    do you know how to fix it in my dell pc configurations?

    Thank you in advance,