10 Replies Latest reply: Jan 11, 2011 4:27 PM by tokyogabe
rastagrl Level 1 Level 1 (0 points)
Hi,
I am trying to connect my Kindle wifi to my airport express and it will not connect. Kindle keeps asking me for a password I enter it and it still will not connect. I can see my network on the Kindle but cannot connect. I have changed the radio mode on AE to 802.11g and it still does not work. On another site someone suggested a network key. I do not know what that is. Any help w/b greatly appreciated.
Cheers

MacBook Pro, Mac OS X (10.5.8), Kindle latest generation
  • Bob Timmons Level 10 Level 10 (87,700 points)
    Just a hunch here.

    Open AirPort Utility - click Manual Setup
    Click the Wireless tab below the icons
    Check the setting for Security

    Try WPA2 Personal if your Express is not already on that setting

    Update settings and give it a try
  • rastagrl Level 1 Level 1 (0 points)
    Hi Bob,
    It is already on WPA2 Personal
    Thx
  • Bob Timmons Level 10 Level 10 (87,700 points)
    Thanks. Sorry, I don't have a Kindle here to test with.

    If you don't mind trying a few things...

    Set the Radio Mode on the Express to 802.11b/g and try it with WPA2 Security.

    If no luck...

    Leave the Radio Mode at 802.11b/g but change security to WPA/WPA2 Personal on the AirPort Express. Then check if there is an option on the Kindle to connect using a setting like WPA-PSK (TKIP)

    If still no luck...

    Curious if it will connect if you temporarily set the AirPort Express to no security.
  • Bob Timmons Level 10 Level 10 (87,700 points)
    There are different ways to say the same thing using security.

    Apple setting of WPA/WPA2 Personal = WPA-PSK (TKIP) on other devices

    Apple setting of WPA2 Personal = WPA2-PSK (AES) on other devices
  • rigormortis Level 2 Level 2 (225 points)
    "on another website" i wonder if that was me!

    haha

    anyways i have recently suggested on another forum that you try the alternative network key.

    run airport utility
    select your airport from the left panel
    click manual setup
    on the top menu bar, click base station
    on the pull down menu click on equivalent network password
    try typing the WPA Pre-Shared Key into the kindle 3.
    if you are running separate names for 2.4 and 5 ghz it will give you two separate pre shared keys

    you can try wpa tkip personal or wpa 2 aes-ccmp personal and it should work
    as long as you select the correct ssid (the correct station) and correct password on the kindle.

    i was reading on amazon kindle forum that someone was claiming that amazon said that the airport extreme was incompatible with the kindle 3.

    i have the extra long super paranoid 63 character passphrase, and i found out that instead of typing a completely random string of characters like
    O0h8o(2lD*z~"UZLe,Up(sz3zpPui4ao1ma0~s1{BS8Flpo+>od@-$zBusOluO$ on a kindle or an iphone for that matter, that it is easier to go to airport utility and type in the "equivalent network password".

    the equivalent network password worked for my kindle 3. it was not connecting to my airport extreme. i assumed it was a typo. and no matter how hard you set your 504-bit wireless passphrase, airport utility will always give you an alternative passphrase in hexidecimal, which is numbers 0-9 and uppercase letters of A-F that makes typing passwords much easier in kindle 3s and iphones and ipads.

    on my other wireless devices i just use a usb key to copy the key from (or autorun.inf for "windows connect now") so i never have to type the password on those computers.
  • kaushikn Level 1 Level 1 (0 points)
    even mine would not connect for a long time. ( I even returned my wifi only kindle and got the 3G one). But today, I reset my airport express back to the factory settings and then retraced the steps for setting up a wifi connection and then my kindle could connect. Maybe you should give that a try.
  • rastagrl Level 1 Level 1 (0 points)
    Yes that was your post that I saw (LOL) and just said wow for your network passphrase made my head spin and I decided to leave it alone. I am not that tech savvy and do not want to mess up what I have in place for my network which is very simple. The 3G works just fine but just wanted to see the wifi so I guess I can always go to Starbucks, but I may give it a shot anyway.
    Thanks so much!!
  • kfingering Level 1 Level 1 (0 points)
    Resetting the AirPort worked right away. Wish I had tried your solution first. I still don't understand why I needed to do this just for the Kindle. We have three laptops which were connecting with no problems. Even occasional guests have no problems logging on to our Airport. Thanks for your help. The Kindle was a Christmas gift from me to my wife.
  • kristy_s Level 1 Level 1 (0 points)
    Resetting the base station to default settings worked for me. I tried all of the other steps listed online, and Amazon even sent me a new Kindle, thinking the first one was just broken. Nothing else worked. I even have a Kindle 2 that was already connected to the same network...whatever
    After restoring the base station to default, I set it up exactly as before, same passwords and all. Kindle 3 connected, no problem.
  • tokyogabe Level 1 Level 1 (0 points)
    i just solved this on my time capsule. i had it set to 802.11n 5ghz only and it would not see my network or connect.

    after going through the different settings it seems that it will not connect to a 5ghz network...i was finally successful with the setting 802.11n b/g compatible 2.5ghz. i also changed it to wpa/wpa2 personal security (don't know if that did anything though).

    i also used the setup manually function.

    oh and the firmware is now 7.5.2 currently (the newest one)

    good luck!