9 Replies Latest reply: Oct 18, 2010 7:22 PM by jmvtwin
Richard Miller4 Level 1 Level 1 (0 points)
Lately I have not been able to connect to my wifi on my 3GS. It used to work fine and I can connect to another nearby insecure network just fine. I have tried resetting network settings on the phone and resetting the router and neither worked. It asks for the password and says unable to join the network. My laptop connects just fine. Am I missing something to check ?

iOS 4
  • 1. Re: unable to connect to Wifi
    Allan Sampson Level 10 Level 10 (123,340 points)
    Have you checked the manufacturer's website for your wireless router to see if there is a firmware update available for your wireless router model that you haven't installed yet?

    If the firmware for your wireless router is up to date, what type of security are you using with your wireless network - WEP or WPA2?

    If you are using WEP and your wireless router supports WPA2, try switching to WPA2 which is much more secure than WEP which is important if you have a Windows PC connected to your wireless network and this may resolve the problem.
  • 2. Re: unable to connect to Wifi
    Richard Miller4 Level 1 Level 1 (0 points)
    There are no firmware updates. I checked that already. I was using WPA and WPA2 and it wouldn't work using either.
  • 3. Re: unable to connect to Wifi
    kjeffrey Level 1 Level 1 (0 points)
    Did you try no WPA or WPA2. Mine iphone 4 works without security on, but not with it. I am running 4.1 and did a factory restore and it worked for while but as of today we're back to no wifi. you could restore phone and that may help but I don't know for how long.
  • 4. Re: unable to connect to Wifi
    poupoi Level 1 Level 1 (0 points)
    I think there is a problem with the iPhone software. My iPhone connection to wifi is in grey. I have followed all the Apple instructions and doesn`t work.
    The answer of try not to use WEB encription in the WIFI is really poor: We have allways connected by WEP and nowadays it not work.
    Apple, please, review the software in terms of WIFI. Thanks.
  • 5. Re: unable to connect to Wifi
    shane0613 Level 1 Level 1 (0 points)
    Did you recently update your iPhone operating system to IOS4? I updated my 3G and my wifi worked for a few days, then started acting strange. Then it would not connect to any, even getting to the point that it would not see any wifi networks. If I tried to join a password protected access point, regardless of what type of encryption is used, it constantly says unable to join network "X" or whatever. I have contacted 2 of the best rated iPhone repair service business in the nation. Both stated that the problem is software related and not a hardware issue. They also say that it has to be fixed by an apple update. I talked to the 10th best rated service and he said he could fix it, but stated he would have to downgrade the phone to os 3.1.3. I sort of think he may have a way to fix it by jailbreaking it and downgrading the modem/wifi firmware to pre 5.13.04. I don't want my phone jailbroken. I am waiting to see if Apple will help out its valuable customers by fixing this problem. I used the wifi function the most, b/c I don't have a data plan. The iPhone is much easier to lie in bed with to get online, than a laptop. Please help us Apple, Jobs, Wozniak. HELP!! LOL
  • 6. Re: unable to connect to Wifi
    donmig Level 1 Level 1 (0 points)
    Exactly the same thing happened to me (3G 4.1). Does not see any wifi. Apple's only answer is to restore it but it does not work.

    Help.

    Message was edited by: donmig
  • 7. Re: unable to connect to Wifi
    Gustavo Carrer Level 1 Level 1 (0 points)
    I have de same problem with my i-Phone 3G. I upddate the firmware (4.1) and I stil cannot connect to wifi networks. I used the same conections from 2008 without problems, until last week.

    I need solutions
  • 8. Re: unable to connect to Wifi
    Allan Sampson Level 10 Level 10 (123,340 points)
    If no change after resetting network settings on your iPhone, which erases all wi-fi network settings from your iPhone and will require re-joining every wi-fi network you have access to when returning within range of the network, try restoring your iPhone with iTunes as a new iPhone or not from your iPhone's backup. If no change after restoring your iPhone with iTunes as a new iPhone or not from your iPhone's backup, your iPhone has a hardware problem - likely with the wireless card.
  • 9. Re: unable to connect to Wifi
    jmvtwin Level 1 Level 1 (0 points)
    I have an iPhone 3G. I got the lastest 4.1 update and reset my network settings but my WiFi option is still grey! Please HELP!