Previous 1 2 Next 23 Replies Latest reply: Nov 28, 2010 8:12 AM by Traci Bunkers
skinner456 Level 1 Level 1 (0 points)
I just purchased a new Macbook Pro (13") - my first ever Mac - and am trying to get it to print with my Epson Artisan 810. Like many others I am having problems but none of the posted solutions work for me.

I installed it fresh initially with the drivers from the Epson website, I selected the Bonjour option, I was even able to download whatever update was out there through the Software Update feature, but still the same issue. The printer scans w/o a problem, it can tell me the ink levels and access the maintenance page w/o problems, but cannot print.

Whenever I print SOME message must make it to the printer because as soon as I hit print the printer starts making noise as if it is going to load paper and print, but then almost immediately it cancels the print. The printer log ALWAYS give the same error no matter what document or program I try to print from:

Error: /Library/Printers/EPSON/InkjetPrinter2/Filter/rastertoescpll.app/Contents/MacOS /rastertoescpll failed

I have tried uninstalling and reinstalling the printer over and over and I keep getting this same error and immediate print job cancellation. What the heck is the problem here?

Macbook Pro 13 ", Mac OS X (10.6.4), Epson Artisan 810 printer problems
  • DaddyPaycheck Level 6 Level 6 (16,035 points)
    Un-install all Epson printers from your system. Reboot your computer. Install the printer again but let your Mac find the drivers.
  • skinner456 Level 1 Level 1 (0 points)
    I gave that a try and had the exact same result. Literally the instant it sends the document to the printer the printer queue on the computer pops up that error and the printer itself almost immediately says it is canceling the print. The printer is quite clearly receiving information because it acts as if it is about to start printing something (makes the whole getting ready to print noises, acts as if it is about to load some paper) before the cancellation occurs. I am printing fine from a laptop running Windows 7 (wireless connection to the router) and a desktop running Windows XP (wired connection to the router).
  • John Blanchard1 Level 5 Level 5 (5,030 points)
    This error has appeared before:

    http://discussions.apple.com/search.jspa?search=Go&q=rastertoescpll

    You may have luck reverting to the previous Epson drivers, or you may be able to get it to work by resetting the print system and re-adding the printer.

    Hope these links help.
  • skinner456 Level 1 Level 1 (0 points)
    Unfortunately I have seen other peoples posts and none of the things they try seem to be working.

    I truly don't understand what else I can try to do; I can scan documents, I can check the ink level, when I try to print a test page it actually prints something - a group of different colored parallelograms with lines in the middle and underneath it says "LWO298 QP110A29". I don't know if that is what the test page is supposed to say or not but something at least is being printed.

    I've tried uninstalling using the original installer and then reinstalling and it doesn't make a difference.
  • John Blanchard1 Level 5 Level 5 (5,030 points)
    One more thing then to try, if you don't mind. Try deleting the printer, the <hard drive>/Library/Printers/EPSON folder and the /Library/Caches/Epson folder, and then reinstalling the drivers using Software Update. Then add the printer again.

    Remove the original installer from the equation since the software has been updated since that was released.
  • Epson Mac Tech Level 2 Level 2 (200 points)
    My name is Syd and I work for Epson America, Inc.

    It sounds like something got corrupted in your OSX installation of the driver. First try to reset the printing system and clear out the installed printer. Please do the following:

    Unplug the Artisan 810 from the computer
    Control-click or right-click a print queue in the "Printers" pane.
    Choose "Reset printing system..." from the contextual menu.
    Click "OK" in the "Are you sure..." confirmation sheet.
    Replug in the Artisan 810 and use Apple Software Update to install the latest driver.

    Here's an article on how to troubleshoot 10.6 printing issues: http://support.apple.com/kb/TS3140

    Also, this article has good information on the 10.6 printing system: http://support.apple.com/kb/HT3771

    Here to help,
    Syd
  • skinner456 Level 1 Level 1 (0 points)
    John, I deleted the printer and deleted those folders and reinstalled the printer using the printer menu. When I tried the apple software update it said my software was up to date and didn't offer an option to get updated print drivers. I tried printing again and the same thing happened.

    Syd,

    I am trying to print from the Macbook to the Artisan entirely over a wireless network. The Macbook has not been plugged directly into the printer or to the router at any point in this. I did try what you suggested, resetting the printing system, and as earlier it did not offer any software updates when I looked for one. I tried printing again and the same result.

    I dug around some more directories and found some more files with the epson name in there and deleted those and then attempted to reinstall using the printer setup page, and then again tried a software update and again it didn't find any new drivers, and of course the same printing error occurred again.

    It sure appears that the MacOS is holding onto drivers somewhere that I cannot discover because when I reinstall the printer it takes it all of 3-4 seconds to install, and when I try to do the software update it is not finding any new drivers anywhere.

    Syd, I agree that there seems to be something specifically corrupted about the printer driver itself, however, but is there another way to remove drivers?

    Should I try uninstalling everything and attempting a USB installation to see if prints that way?
  • John Blanchard1 Level 5 Level 5 (5,030 points)
    skinner456 wrote:
    John, I deleted the printer and deleted those folders and reinstalled the printer using the printer menu. When I tried the apple software update it said my software was up to date and didn't offer an option to get updated print drivers. I tried printing again and the same thing happened.


    Are you sure you're deleting the correct files? Deleting these files should delete the installed Epson drivers. If the printer is on and connected, Software Update should offer to download the latest driver. You could also download the driver from Epson.
  • gumgum2 Level 1 Level 1 (0 points)
    I am having the same problem on a new printer I bought last week, errors occurred even on a new replacement and have been pulling my hair for the past 2 days (there's not much left...)

    pls...help
  • skinner456 Level 1 Level 1 (0 points)
    I have deleted every Epson file I can find and reinstalled using the control panel and the epson website drivers and it still is happening.
  • gumgum2 Level 1 Level 1 (0 points)
    are you fr UK?
  • Epson Mac Tech Level 2 Level 2 (200 points)
    Hello skinner456,

    Normally disconnecting the printer (if connected USB), deleting the files and restarting the computer resolves the issue. At this point we recommend contacting Epson technical phone support, as there are many variable's to explore. Hopefully they can better determine the issue and get you up and running. The direct toll free number for your model would be in the manual or email sent to you when registering the product.

    Here to help,
    Syd
  • revmfn Level 1 Level 1 (0 points)
    I had same problem. I removed the Artisan as my printer (had been using bonjour). Unplugged printer and turned off, used USB connection, then went to preferences and clicked on +. I was given 3 options:
    USB, IP, and Bonjour. I choose both USB and Bonjour and both work.

    Somehow the printer preference had shifted to an IP setting-and that's what made the error message appear since I do not have that kind of network.

    Hope this works for you!
  • skinner456 Level 1 Level 1 (0 points)
    I'll give this a try next, but I spent an hour on the phone with Epson yesterday and they couldn't figure it out. I am on the phone w/Apple tech support and they are going to elevate me to a new tech support level because the first guy cannot figure it out.

    I have tried installing wirelessly only using the Bonjour and IP options and both keep giving me the same error. I have reset the printing system, deleted files and directories off the HD, re-downloaded the newest drivers, run the apple update to get any downloads, and no matter what I do I still get the same error when I print.

    I can scan fine, I can see the ink levels, but I just can't PRINT w/o this message appearing. I have two Windows computers that print fine, one of which is a wireless laptop, so I feel there must be something specific in the MacOS for me that is causing this repeated error that is unrelated to the driver installation itself, because everyone else seems to be able to solve this problem by doing these trouble shooting steps.
Previous 1 2 Next