9 Replies Latest reply: Dec 29, 2010 4:26 AM by Trygleren
ShawnEgo Level 1 Level 1 (0 points)
iPhone 4 will not down load apps, just freezes. I can still use phone, but get "waiting" logo on app downloads.
  • quark29 Level 1 Level 1 (0 points)
    Reboot your phone.
  • imakers Level 1 Level 1 (10 points)
    Hi - I've got the exact same problem

    Discovered it seems to be something to do with Wifi.

    If I turn Wifi off, the 3G connection kicks in and the downloads start.

    It's really strange, I can browse the web, view the app store, view itunes, trigger a "purchase" via Wifi, but can't actually download anything from the App Store via wifi. Also found that I can't access the "View My Account" option under Settings | App Store if I'm connected by Wifi, but can if via 3G.

    Anyone any thoughts?!
  • Safari Buggs Level 1 Level 1 (0 points)
    Hi,
    I had the same problem, the Apps "tab" / section in Itunes was "greyed out" until I turned WIFI off and disabled restrictions, then suddenly I could select the apps and download them...
  • 3l0y Level 1 Level 1 (0 points)
    I have the 3gs and this problem started when i upgraded to 4.1. I don't think restarting the phone is an acceptable solution.
  • @leon Level 1 Level 1 (0 points)
    I cant update my APPS in my iPhone 4...
    when i click update it will write not connected to iTunes...
    I tried this almost more than a week...
    But it can download apps.. Any help?
  • imakers Level 1 Level 1 (10 points)
    So I think I've found the problem AND have a solution...

    Well... at least it's fixed my issue!

    Having used my phone on another Wifi network I discovered that all worked well... so therefore the issue had to be either with my Wireless Router or my ISP. A quick call to my ISP ruled them out.

    So to the Router... I was preparing myself to have to go and buy a new one - but thought I'd try a couple of tests

    Firstly I tried to enable port forwarding for port 443 (as app store requires a secure connection/port) - but the router was already configured to enable this.

    Secondly, I thought I'd update the router firmware - but it was already up to date.

    Finally I restored the router to it's default settings... and strangely the iPhone started working and downloading apps via wifi!

    So now the question is - why did it all of a sudden start working? After a bit of looking through the settings, I came across the option "Connection Type" - prior to resetting the router, I was using a PPPoA setting. After the reset, the setting was defaulted to PPPoE.

    So with PPPoE all works well. With PPPoA downloading Apps/using secure connections fails!

    A quick test to set the router back to PPPoA confirmed this.

    So I'm running the router with Connection Type PPPoE and am now very happy!

    For reference, I've got a Belkin N1 ADSL Modem Router.

    I hope this helps others!?
  • Snowy2 Level 1 Level 1 (0 points)
    How ?
  • imakers Level 1 Level 1 (10 points)
    I guess it depends on your Router/ADSL Modem - but for my Belkin, you connect to the Router admin page, then select "Connnection Type" from the left hand menu, and select PPPoE then complete the appropriate settings.
  • Trygleren Level 1 Level 1 (0 points)
    I had the same problem. Even my laptop would not allow access to iTunes.

    The solution for me, was to change the DNS-settings of both the laptop and the iPhone.
    I now use OpenDNS as my main dns-server. Everything worked after that.
    To change your dns, open the network settings and change the dns server adress to that of a 3rd party dns (for example OpenDNS). You can find such and ip adress by searching the net.