5 Replies Latest reply: Jan 9, 2011 12:28 PM by bjornio
Macey1 Level 1 Level 1 (0 points)
I just upgraded from Leopard to Snow Leopard on my Macbook and it's created lots of problems with my LCD external display:

- The display won't work at its native resolution (1680x1050) - it will flash up an image for 1/10 of second and then go black. I can only get it to work at a lower resolution, which looks AWFUL.

- If I try to start up my Macbook with the lid closed and the display connected, the display won't work at all (it jams on the start up screen). It only works if I keep both of them running

I never had these problems when using Leopard. I've searched lots of forums and found that many people are having similar problems with external displays. Apple still haven't fixed the bug after repeated efforts from people to get if fixed.

Here are some threads (now closed) on this if you're looking for solutions:
http://discussions.apple.com/thread.jspa?threadID=2132912&tstart=0
http://discussions.apple.com/thread.jspa?threadID=2136455&tstart=1
http://discussions.apple.com/thread.jspa?threadID=2132837&tstart=0
http://discussions.apple.com/thread.jspa?messageID=10084332

Common suggested fixes are:
- Force OS X to use LCD font smoothing (does not work for me)
- Clear the PRAM on start-up (does not work for me)
- Delete /Library/Preferences/com.apple.windowserver.plist (does not work)
- Change energy management setting to high performance (only works on graphics cards in Macbook 15" and 17").

From reading these forums it appears that this is a well-know bug. Has anyone else got any suggestions to fix this? And why hasn't Apple fixed this yet after so many people bringing it to their attention? It's clearly a bug that wasn't in Leopard.

MacBook 5.1, Mac OS X (10.6.4)
  • Roosterthebooster Level 1 Level 1 (5 points)
    Macey1 is absolutely spot on. I have a 2008 MacBook Air and a 2008 Unibody MacBook Pro. Neither can hold a second display output satisfactorily. The Pro just cuts out at will, the Air has a snowy output. This problem persists on both a Panasonic Plasma and a Samsung LCD. I have followed every fix on every forum and nothing works. Apple, you must sort this out with an update. Both laptops are fine in bootcamp XP, so its has to be down to apple drivers. Come on Steve/Apple, this simply isnt good enough. Please please please offer a software update.
  • simonjoliver Level 1 Level 1 (5 points)
    I also have this problem; I have a 17" Early 2009 Unibody MBP, which I connect to an external Princeton VL2018W 1680x1050 monitor. For me, the problem is that the external monitor will flash up the image briefly, and then go black (but usually flickering dark grey) almost immediately. This actually freaks out the monitor hardware and I can't power the monitor off, I have to pull the power cord out of the back.

    About 1 time in a dozen, I can get the monitor to work correctly when I plug it in.

    It seems to be a display timing issue; when the monitor is working it reports (on its OSD) a horizontal sync rate of 65.3Khz. When it is failing, it reports being fed 65.4kHz.

    Also interestingly, this is not solely a software issue; the same computer worked fine with the same external monitor until I poured a glass of water over it, and had to have the motherboard replaced last month. Now, with the new motherboard, it hardly ever works, even though I am running the same OS install as before.

    I sometimes use the laptop with a Dell 30" monitor, and although its early days, that seems to always work fine, even after the motherboard swap.
  • djamalt Level 1 Level 1 (0 points)
    I'M FED UP WITH APPLE! They've always been a little shady, but the last half of 2010 took the cake!

    First it was the iPhone 3g "upgrade" to IOS4 which was garbage and killed my ability to use the 3g until I figured out how to crack the software, wipe the thing clear then reinstall the original software. Next up was purchasing the iphone 4 as a Christmas gift for someone running tiger on their mac, only to find out that the iphone 4 doesn't work on tiger when they tried to sync their contacts - and then having to rush out and purchase snow leopard so that they could enjoy my gift. Then I install Snow Leopard (note - I purchased the family pack) onto my own leopard-running(10.5.+) powerbook only to have the external LCD display I've been using for years suddenly stop working.

    Oh, okay, to be fair, it works IF I RESIGN MYSELF TO SET it to "mirror image" (which defeats the purpose of having multiple displays) and drop the resolution down to a pathetic, unsharp, nearly distored setting that is almost painful to look at knowing that this monitor was just A COUPLE OF DAYS AGO showing me crystal clear images.

    Then I exhaust myself trying to find a fix only to discover that APPLE in their infinite brilliance (AKA - their torture of loyal customers) knows of the issue - worked it out - then created an update that created the issue all over again. I'm so done! No more macs. I'm going back to the evil land of PCs. At least there, you know you're getting crap, it doesn't sneak up on you after getting you to trust it time and time again.
  • machecnik Level 1 Level 1 (0 points)
    Same for me... I'm angry, ****** and I have no idea what to do... good old MacBook worked perfectly, new one has troubles with DVDs, external display isn't neither found etc. and no answers from Apple! Customers orientation at zero level :-/
  • bjornio Level 1 Level 1 (0 points)
    Same here. My MBP 15" early 2009 model worked fine when I used Leopard and had 2 different external LCD displays. A Hyundai L70N and a Samsung Syncmaster. When I upgraded to Snow Leopard, the external displays were viewable for about 2 days and now they maybe come on for 5 minutes, or maybe not at all and it just sits in non-responsive mode. Sometimes it just sits on the blue screen on both of them and doesn't do anything until I unplug my DVI adaptor, which I bought from a Mac store. This is bugging me to pieces.

    I too have searched forums and all things everywhere and have same problems as others and have come up with no solution. I had my external display working this morning cutting in and not, not lasting more than a minute before it blacks out. I checked the console and everytime the display cuts out, the console message says

    "9/01/11 1:39:15 PM com.apple.BezelUIServer[5314] Sun Jan 9 13:39:15 bbmp BezelUIServer[5314] <Error>: kCGErrorIllegalArgument: CGSGetDisplayBounds (display 5fbfe8a0)"

    It displays this message EVERYTIME the display shuts itself off...but only when it decides it want's to work!!!! Annoying!!

    Come on Apple, please find a solution. I've been patiently waiting for 14 months. The anticipation is killing me.