10 Replies Latest reply: Feb 3, 2013 6:26 PM by Kevin_Juggles
rhythmproject Level 2 Level 2
Hello All - I recently got a new iMac and a new iPhone 4 so it's been difficult for me to troubleshoot this problem. I got my iphone 4 to show up in iPhoto yesterday but I don't know how, it just popped up after awhile. [I opened iPhoto with phone plugged in, opened iphoto with phone unplugged, unplugged phone with iphoto in, etc. - I tried all options].

Anyone else having this problem?? All my specs are included in my profile. Any help would be much appreciated!!!

iMac 27" 2.93 GHz Quad-Core i7 12GB RAM, Mac OS X (10.6.4), LP9.1, iPhone 4 (v4.1), Ableton Live 8
  • rhythmproject Level 2 Level 2
    One detail I didn't include is that I have iPhoto v 8.1.2 Thanks!
  • Terence Devlin Level 10 Level 10
    This comes up on the forum from time to time. Some folks have fixed it just by restarting the phone. Others had to do a reset.


  • MadisonP Level 5 Level 5

    This behavior and a fairly exhaustive list of resolutions is detailed here: http://support.apple.com/kb/TS3195

    If that does not take care of it for you, you might want to hit up the iPhone forum as this is usually an issue with the data on the iPhone and not with iPhoto.

    Hope that helps.
  • Gregory Lynn Level 1 Level 1
    From my experience I think its a bug related to the number of photos on the phone. The more photos I have loaded on my phone, now well over 1300 and 111 movies, the slower it is to appear in the iphoto device list. iPhoto is auto launched when I plug the phone in so it is detected properly on the usb bus and the app launch is triggered. I am working to isolate now but it could be the compare between photos on phone and the iphoto library, parsing out the duplicates, which means a db scan which would get slower as it grows. This should not delay the device showing in the device list if the code is architected properly, but perhaps its not, and it waits for the compare to happen erroneously first.
  • Gregory Lynn Level 1 Level 1
    Follow-up on my post, yes, after deleting my photos and re-accessing iPhoto, my iPhone4 appeared quite quickly in the device list in iPhoto, which proves a good chunk of my theory about the number of photos and related compare operations interfering with the device load into the list.

    **Note iPhoto sees ghost placeholders for all the photos that were deleted and import is activated for same, a 2nd bug in iPhoto.

    Apple, howz about hiring me to help out the team again?
  • Dave8 Level 1 Level 1

    We also saw something like this - I had awesome note installed and two notes had pictures in them.  After removing the pictures from the notes, my phone showed up in photo and imported correctly.  You might check other apps that can embed images.  Hope this helps someone out there.

  • Will H. Level 1 Level 1

    I had a similar problem on my 2009 MacBook Pro running 10.7.2, iPhone 4S and iPhone '11 (both of which had the most recent updates as at the time of this post): my iPhone was appearing and working correctly in iTunes, but was not appearing in iPhoto or Image Capture. I had >1000 photos on the camera roll, including some saved from Safari and emails etc.


    The following fix worked for me: unplugged external monitor. Voila. That's it. So, in troubleshooting this problem, I recommend that others try unplugging _all_ other peripherals before connecting their iPhone.


    Message was edited by: Will H.

  • ElenaG Level 1 Level 1

    Thank you anselhall, the whole process didn't make much sense to me, but it WORKED!!!

    Thank you!

  • Kevin_Juggles Level 1 Level 1

    It didnt work for me, I couldnt see anything in PTPCamera on the activity monitor and my Iphoto has never recognized my iphone as a device! I can still sync it to Itunes and Iphoto will sync albums to the phone but I cant import photos from my phone to iphoto any help would be much apreaciated!