4 Replies Latest reply: Oct 2, 2010 7:36 AM by OlsonBW
OlsonBW Level 2 Level 2
expertise.macosx
Mac OS X
I accidentally blocked a javascript from a website and have no clue how to unblock it.

"Permission for applet refused
Please accept the permissions dialog to allow
the applet to continue the loading process"

I can't figure out at all what I'm supposed to do.

Mac OS X 10.6.4
Safari 5.0.2

Oct 2009 Intel Core 2 Duo 2.53 GHz Mac Mini with 4 gb of RAM, Mac OS X (10.6.4)
Solved by andyBall_uk on Oct 2, 2010 7:18 AM Solved
Hi Olson

that's a Java game, only very loosely related to Javascript.

I tried & denied at your link, and just had to quit Safari for the 'do you want to trust' dialogue to be shown next time. Have you done that yet?
  • Carolyn Samit Level 10 Level 10
    expertise.safari
    Safari
    Hi,

    From your Safari menu bar click Safari / Preferences then select the Security tab.

    You can enable Java Script there.






    Carolyn
  • OlsonBW Level 2 Level 2
    expertise.macosx
    Mac OS X
    Hi,

    It is showing that Javascript is turned on that screen (Preferences -> Security). It only appears to be turned off, or denied, for a specific website. To be exact, ONLY the single player on-line for MineCraft at http://www.minecraft.net/play.jsp. All other javascripts on all other pages for that website and everywhere else runs. Just not on that page. I accidentally told it to deny on that page. I can't figure out how to undo it.

    Message was edited by: OlsonBW
  • andyBall_uk Level 7 Level 7
    Hi Olson

    that's a Java game, only very loosely related to Javascript.

    I tried & denied at your link, and just had to quit Safari for the 'do you want to trust' dialogue to be shown next time. Have you done that yet?
  • OlsonBW Level 2 Level 2
    expertise.macosx
    Mac OS X
    Restarting Safari didn't work. Well, I didn't get a message that it was blocked, just a black rectangle where it was supposed to be. I guess their site was busy because I tried it again awhile later and now it is working. Thanks.