Previous 1 4 5 6 7 8 Next 105 Replies Latest reply: Oct 9, 2011 10:55 PM by davidfevre Go to original post
  • Robert Farthing Level 1 Level 1 (65 points)
    So, even though I consider my ATV2 to be "fixed", I've noticed that if I manually put it to sleep, it won't recognise my library when it wakes (unplugging then replugging ATV2 will kick mine back into life). If I allow it to sleep on it's own, I haven't had any problems with it.
    The issue of pressing "done" in home sharing is a mute point (IMHO), because when you escape the function, or do anything in iTunes, it effectively hits the "done" button anyway. I'm thinking that anyone that thinks this has cured their problem will find that it was coincidence, and will have issues at a later date (but I may be proved wrong).
    I don't have an Airport Extreme. Mine's a Thompson TG587n v2 using Software release 8.4.2.R.
    Quitting and restarting iTunes has never cured my problems, even in the early stages of ownership (when it only worked 10% of the time).
    Hope this helps.
  • Chris Chapin Level 1 Level 1 (0 points)

    Regarding changing your suggestion to change the Verizon FiOS Network Connection Wireless settings from "Network (Home/Office)" to "Broadband". I followed your directions and it fixed my issues with ATV and Airplay. I am not sure what this change in setting actually does. Does this setting open up any network security issues?

    Thanks for the help.
  • chris2good Level 1 Level 1 (0 points)
    Hi all,

    I am having the same problem, after recieving the ATV2 for Christmas, it all seemed to work well until the 2nd/3rd/4th time i.e. after the Mac/AppleTV has been Asleep!

    I have read through all of the replies and tried most suggestions but to no avail... The only solution I have so far is to unplug the ATV by the wall and also turn Airport off/on for it to work again!

    Also I tried changing the network settings as someone suggested, but I have a BT Homehub and i logged into the admin panel but couldn't find how to change from Home/Office to Broadband - if that even exists for BT!!!

    Is there any solutions yet?

    Much appreciated
  • bobcat38 Level 1 Level 1 (0 points)
    I got my ATV2 for Christmas and I'm also having the same problem. Seems like the only way to make ATV to stay logged into I-Tunes is to leave I-Tunes running in the back ground. If there is another fix I would like to know it.
  • Bryan Brindeiro Level 1 Level 1 (15 points)
    Bobcat38, for you to be able to view/stream media from your mac to appletv, iTunes MUST ALWAYS be open and running in the background for this to work, as iTunes acts as a media server to your appletv if you wish to stream from your mac, so naturally it won't work if you quit itunes on the mac. I keep itunes running at all times and just minimize or hide the application on the mac and it is always available to my appletv. Hope this helps explain how it all works and maybe why you have difficulties.
  • chris2good Level 1 Level 1 (0 points)
    Bryan, I appreciate that we need itunes open in order to stream media to ATV, however I do not want to leave itunes running every single day for the rest of my life...

    For example, yesterday I turned off my mac, turned it on again today and went to use ATV but it could not find my Mac - even though it was turned on and home sharing was on... The only way I could get it to find ATV again was to reboot the ATV and also turn off/on Airport (which another user suggested).

    Surely I should not have to do this every time I want to use ATV? Apple cannot expect me never to turn off my iMac can they???
  • bobcat38 Level 1 Level 1 (0 points)
    Next time open I Tunes log out of home sharing and then log back in and ATV should find your IMac. That works for me when I shut down my IMac.
  • Jaunty Level 1 Level 1 (5 points)
    New ATV2 user, ATV2 lost my iMac but still saw my Macbook. Weird thing was Remote could still see and control the iMac but ATV2 (and Remote accessing ATV2) could not. Anyway, logged out of iTunes on the iMac and back in and ATV2 saw it again.
  • BigCplus Level 1 Level 1 (0 points)
    Just thought I'd share what worked for me. I'm running iTunes on my Windows 7 machine and had the same issue with my Apple TV V2. It was running fine when I first hooked it up for about 3 weeks and then one day it just stopped see the iTunes computer.

    I came across another thread that suggested I change the type of network in Windows 7. If you go to the Network and Sharing Center, you will see that you can assign network types (Home, Public, Work) to each network. Well, for some reason, I had changed it from "Home" to "Public". In public network mode, I guess Windows 7 locks down more sharing options.

    I changed it back to Home and restarted iTunes. A dialog box came up that said I didn't have a service called "Bonjour" started. I went to the control panel to start that service up and it started working. It has been working ever since. Don't know what the equivalent Mac fix would be, but the problem might lie somewhere in there as well.

    To recap:
    - Go to Control Panel -> Network and Sharing Center (Make sure that network type is set to home)
    - Go to Control Panel -> Adminstrative Tools -> Services (Make sure that the service called "Bonjour" is started)
    - Restart iTunes (always seems like a good step just in case)

    Hope this works for you ....
  • mcdj Level 1 Level 1 (35 points)
    Not sure if this will help anyone, but I seem to have solved the issue of the ATV not waking my 2010 aluminum Mac Mini.

    I had the Mini connected to my Airport Extreme via ethernet. The Mini is right next to the router, so I never saw the need to enable wifi on the Mini.

    Like many people have found, the ATV seems to have difficulty waking the Mini up. Today I decided to enable wifi on the Mini. In network settings I changed the order of connections to give ethernet priority, so I assume that I am still using ethernet to connect to the web. But now my Mini is also part of the wireless network via wifi directly from the Mini, instead of just through the Airport Extreme.

    Oddly, my Macbook never had an issue waking up the Mini before; only the ATV was wake challenged.

    Now I'm happy to report that the Mini is being woken by the ATV. I assume this is due to enabling wifi on the Mini.

    So...if you've been having issues waking your Mac with the ATV, and your Mac is connected to your Airport solely via ethernet, try enabling wifi on your Mac. You can still maintain your ethernet connection for the fastest possible pipe to the internet.

    Message was edited by: mcdj
  • etkal Level 1 Level 1 (20 points)
    Hey mcdj, thanks for the tip.

    I recently got a Mac Mini to use as my iTunes server, and after researching the wakeup capabilities in conjunction with Airport Extreme, I enabled sleep mode (as a habit on "servers" I always disable this).

    However, then I noticed that the iPhone remote app would wake up the Mini, as would other network access like screen sharing, but my AppleTV2 would not show the Mini in its list of computers if the Mini was asleep.

    Switching it back to wifi and not using the ethernet (I don't want it to have two addresses on the same subnet) definitely seems to have fixed the problem.

    My guess is that it is most likely a bug in the Airport firmware, but it could also be in OS X in that when going to sleep it does not properly register its services to the Airport over ethernet...
  • DogNamedDave Level 1 Level 1 (0 points)
    Bryan, many thanks has worked for me.
  • arthurrunsnyc Level 1 Level 1 (0 points)

    Good advice, this did the trick!

  • OzziesMAC Level 2 Level 2 (150 points)

    Leaving itto stay awake the entire time my solve the issue for now but no need to leave it on when not needed.

    I have found that turning sharing off then back on via the Apple TV menu seems to be a good work around as well and that way you don't have to leave your mac mini awake the entire time.

  • bugcounter Level 1 Level 1 (0 points)



    This fixed my problem.  Which, by the way had not been a problem before.  I'd been using my AppleTV for months with no issues.  Tonight after a power failure, I started having problems... but your solution fixed it.


    Interestingly, switching back to "Network (Home/Office)" did not re-create the problem, which makes me think the solution has more to do with rebooting the router than anything else.


    Anyway, Thanks!


    - Don


    Message was edited by: bugcounter, fixed typos

Previous 1 4 5 6 7 8 Next