Skip navigation
This discussion is archived

TrackPad Stuck

4966 Views 8 Replies Latest reply: Nov 29, 2010 10:44 AM by grey412 RSS
vzlaimprov Calculating status...
Currently Being Moderated
Oct 3, 2010 12:44 PM
My late-2009 MacBook Pro's trackpad likes to remain stuck as if I had double-clicked the screen. No matter what I do, what I press, how many times I open and close my laptop, the problem will not disappear. It happens quite frequently (almost every other day) and I am starting to wonder whether or not it is a software bug or a product defect.

Please help! Is there a way to solve my problem?
MacBook Pro, Mac OS X (10.6.4), Late 2009
  • Mac Medic (be@MacOSG.com) Level 6 Level 6 (17,290 points)
    Currently Being Moderated
    Oct 3, 2010 11:07 PM (in response to vzlaimprov)
    If that unit has a removable battery, pull it out, run from AC and test. If it's OK, swelling of the battery may be the cause.




    Check out the new remodeled MacOSG website! 24-hour Apple-related news & support.
     MacOSG: An Apple User Group  iTunes: MacOSG Podcast  Follow us on Twitter: MacOSG

    2.53Ghz 2008 MacBook Pro • 500GB HD • 4GB RAM, Mac OS X (10.6.3), 1.6Ghz MacBook Air • 3 iPods • iPhone 4 • 3G iPad * AppleCare
  • Jack deWees Calculating status...
    Currently Being Moderated
    Oct 5, 2010 12:17 PM (in response to Mac Medic (be@MacOSG.com))
    I am having the same problem. It renders my computer nearly useless. Mine doesn't appear to have a removable battery. Anyone have any other suggestions. This would be an awfully expensive paper weight to have lying around.
    MacBook Pro 13", Mac OS X (10.6.4)
  • riccardotm Calculating status...
    Currently Being Moderated
    Oct 5, 2010 5:33 PM (in response to vzlaimprov)
    I'm having the same problem with my trackpad and find the only way to solve it is to restart my macbook pro. This makes me think it is a software issue as it hasn't always done this as well. If anyone has any answer's they'd be much appreciated, restarting every other day can get rather annoying, especially in the middle of something important.
    Macbook Pro, Mac OS X (10.6.4)
  • maglover12 Calculating status...
    Currently Being Moderated
    Oct 9, 2010 9:26 PM (in response to vzlaimprov)
    I'm currently having this issue. The trackpad on my MacBook Pro has been stuck on highlight and unable to perform any other function for a few days. However, the trackpad functions correctly when the battery is removed and I'm running on AC. I ordered a new battery and hoped that that would solve the problem (my current battery looks like it is starting to bulge), but unfortunately the problem has continued with the new battery too. I made an appointment with Apple Care for tomorrow...crossing my fingers that there is some solution that doesn't involve replacing the entire top case. I'll let you know if I find out anything useful!
  • Tom Magee Calculating status...
    Currently Being Moderated
    Oct 10, 2010 11:39 PM (in response to maglover12)
    I'm currently having about the same issue. This started happening right after software update and the apple store says it is unrelated. Upon startup, machine works fine until you touch the touchpad. then it thinks you've selected something and you have to restart to get out of it. With a external mouse everything works fine until you touch the pad and then have to restart. Temp workaround was to disable the trackpad. Anyone else having same problem
    MacBook Pro, Mac OS X (10.6.4)
  • paulbutcher Calculating status...
    Currently Being Moderated
    Oct 11, 2010 6:39 AM (in response to Tom Magee)
    Same issue here - about once a day, the trackpad behaves as though it's "stuck" down. I can sometimes clear it by randomly clicking around, other times the only thing that clears it is a powercycle.
    MacBook Pro, Mac OS X (10.4.9)
  • Klatox Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 27, 2010 9:19 AM (in response to vzlaimprov)
    I have this issue as well, mid 2010 mbp 13". What I do is tap the trackpad a few times with 2 fingers (i.e. right-click), and hit a escape a few times and that always clears it up for me.
    Mac OS X (10.6.5)
  • grey412 Calculating status...
    Currently Being Moderated
    Nov 29, 2010 10:44 AM (in response to vzlaimprov)
    had this same problem happen yesterday on my MBP i5 2010
    a fresh OS install fixed it.

    so must be software related
    MBP i5 2010, Mac OS X (10.6.3)

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.