12 Replies Latest reply: Apr 11, 2015 5:45 PM by andrew_in_au
Hervé S. Level 1 Level 1
I just bought an USB wifi interface with a chipset from Ralink, and got issues on OSX 10.6 (and just that version) when trying to use non-open networks (the Ralink "Wireless Utility" just quits instead of showing the password pane).
I use Raling drivers 3.0 instead of the older (and similarly buggy) ones from the hardware provider, Alfa networks.
The 3.0 drivers do work for any OSX <= 10.5, on windows, and even on Mandiva without installing anytning...

Very curiously, the only way I found to indeed register onto a password-protected or encrypted wifi network is to open a Guest Account session on 10.6, then run the Ralink Wireless Utility from there, and IN THIS CASE everything works fine.

I initially supposed that was coming from my account, some incompatibility with a specific thing. After more (and vain) analysis, the same buggy behavior can be repeated with another completely different mac and non-guest user (same 10.6)

If anyone has any suggestion...

FWIW, similar issues here are described at http://discussions.apple.com/thread.jspa?threadID=2319950&start=15&tstart=0 but the discussion is closed there.

macbook pro, Mac OS X (10.6.4)
  • Niels B Level 1 Level 1
    I have no experience with Ralink drivers on OS X 10.6 Snow Leopard, so I don't know if this helps for you, but maybe you can also use an older version of the USBWirelessUtility to control your driver.

    This was the solution for my situation (iBook with a PPC G3, OS X 10.4 Tiger). Ralink didn't compile the WirelessUtility any more for a G3 processor, but the installer worked fine and also the driver could still be used with a G3. I'm now using the Tiger version of USBWirelessUtility with the Tiger version of driver USBWirelessUtility is pre Snow Leopard, but maybe it's worth a try.

    See my to long howto: http://discussions.apple.com/message.jspa?messageID=12591377#12591377
  • BDAqua Level 10 Level 10
    A few different Ralink based USB Wifi devices work fine here in 10.3.x to 10.6.5, have you tried these?

    Here's all the Ralink drivers for OSX...

  • Niels B Level 1 Level 1
    I now have experience with OS X 10.6 and my Sitecom WL-329 with a Ralink RT2870 chip. I can't reproduce your problem however, so perhaps the problem is solved in the new driver. I used version of the Ralink driver, which was released 10/29/2010, this in combination with OS X 10.6.5. The driver is for RT2870 /RT2770 /RT307X /RT2070 /RT3572 chips according to the Ralink website.

    Since both driver and OS are more recently released than your post, I'd suggest to uninstall your previous driver and download and install the newest version. And update to OS X 10.6.5 if you haven't yet.

    I could successfully setup a network connection to a hidden WEP protected network with version of Ralink Wireless Utility without having to use a Guest account. (I could even do this with the USB Wireless Utility version I mentioned in my previous post. Version doesn't have the WPS tab of its sibling, but I don't use WPS for connecting to my network).

    Version of the driver didn't install properly on my system.

    In "System Preferences -> Network" I have a new "802.11 n WLAN" interface after inserting the USB stick, you'll have to add it to your services (and don't forget to press "Apply" after adding the interface). After inserting the USB stick, the Ralink Wireless Utility opened automatically. It took a few seconds after I connected to the network profile from the Ralink Wireless Utility for the "802.11 n WLAN" service/interface became connected. The service went in the Network prefpane from "no connection" to "no IP address", back to "no connection", again to "no IP address" and finally became "connected".
  • Michaelstx Level 1 Level 1
    I've been going in circles on this same issue for about a year. I have an Alfa AWUS036NH USB card with the Ralink 3070 chipset. Trying to use it to connect a MBP4,1 running OSX 10.5.8. I've tried installing several versions of the ralink USBWirelesUtility software/driver with various results, but never a connection to the internet. Some older versions simply opened the wireless utility, failed to connect, then quit. The newer ones, like the latest 10.29.10 build (utility ver.; NIC driver ver. mentioned above, appears to work correctly. The utility opens when I plug in the device. It finds my network, I can enter password for WPA encrypted network, and get a connection.

    However, in Network preferences, I get an option for 'USB Ethernet (en2)' not '802.11 n WLAN'. And no matter how I've tried to configure it, I still get no connection to internet. If I set it for manual DHCP and pick an IP address within my routers range, Network preferences will show that I have a connection, just like the WirelessUtility app shows I have a connection. But they're lying to me, I still can't actually connect any apps to the internet.

    I'm at my wits end. What am I doing wrong?
  • Scionara32 Level 1 Level 1
    i don't know why snow leopard does not recognize the wireless adapter that I installed on my mac. despite installing the ralink drivers.
  • Darryl Rehr Level 1 Level 1
    When I run the RAlink software on my MacBook (10.6.6), the device's utility opens, I see a long list of networks (all of my neighbors, I guess), and I am connected to one of them... but not MY home network. When I choose my own network and click the "Connect" button, the utility crashes.

    I've e-mailed the RAlink people, but anticipate translation problems (English vs Chinese) ... that is if I get any response at all. I will try to be optimistic and hope to be pleasantly surprised.

    Idease from this forum more than welcome!~
  • Scionara32 Level 1 Level 1
    the only way to solve this problem is to boot snow leopard on 32 bit mode which means adding this line on your boot.plist arch=i386
  • alexpp Level 1 Level 1
    Hey Darryl,
    any news regarding your issue? Any reply from Ralink?
    I have the exact same problem, except my network appears in the list of available networks. Otherwise the utility crashes the same way whenever I'm trying to connect to any network, with this exception: Exception Type: EXCBADACCESS (SIGBUS).
    I've tried booting with a 32-bits kernel as suggested by Macbookpro32, but it makes no difference.
  • Darryl Rehr Level 1 Level 1
    The unit I had was an "Alpha Network" device. I returned it and got the Afterthemac device.

    The difference is basically the great support you get with it. "BJ" from Afterthemac spent a good hour on the phone with me diagnosing the difficulties. First, I had an errant setting in my Time Capsule setup (I switched to simple WAP2/Personal from the other option that I had selected (don't remember it exactly). Second, BJ sent me a fresh copy of the 10.6 driver, in case the copy on the included DVD was a "bum copy." After that, the thing worked... although the performance was not as good as should be expected. BJ is sending me a new unit, in case the original has something wrong with its antenna - allegedly "rare" but not out of the question.
  • DanConnie Level 1 Level 1

    I had troubles UNTIL I installed the USB into a good USB port power.. A powered hub.

    Perhaps for some this may be a solution.


    Good Luch

  • Andrew Jung1 Level 1 Level 1

    Hello, you need to manually create a profile for the network first.

    Don't use the site survey tab to connect or add a profile to your network. If you do, the program will just crash.


    1. Under Site survey take note of the SSID, Authentication, and Encyprtion fields for the network you want to connect to.
    2. Go to the Profile tab and "Add" a new profile.
    3. Title your profile
    4. Select the SSID from the drop down list
    5. Click Authentication and security
    6. Select Authentication Type
    7. Select Encryption Type
    8. Put your network password into WPA Pre-Shared Key (you can right-click in the field to Paste in your password)
    9. Click OK
    10. Select you new network under Profile
    11. Click Activate


    You should then get a yellow checkbox with a red background; followed by a green background once connected.


    This works for a MacBook Pro running 10.6.8 (Snow Leopard). Using Wireless Utility and NIC Driver I have a Newer Technologies nMaxPower with RA chips. I downloaded the drivers from here: http://www.newertech.com/downloads/maxpower_usb_n.dmg


    Hope this helps people. Let me know if it worked for you.

    Cheers, Andrew.

  • andrew_in_au Level 1 Level 1

    That did it for me, thanks so much, Andrew!


    FWIW, Mac Pro 4,1 running OSX 10.8.