13 Replies Latest reply: Nov 25, 2012 10:31 AM by Miz Rebel
Smiller4128 Level 1 (0 points)
So whenever I try to watch a movie/episode on netflix this is what happens...it takes 3-5 minutes after pushing "play" for the content to load or do whatever (I thought it was supposed to be instant?) then after 2 seconds it quits playing and returns me to the screen where it says to push "Play" again....this happens over and over. And if by some miracle I can get it to play for more than 2 seconds, it will only play about 5 minutes and then do the same thing by quitting and returning me to the menu where it says to push "play". Now I know this isn't my connection because it says I have excellent signal strength and my Xbox 360 will play Netflix with no issues at all....is this the Apple TV itself? Cause if it is I'm going to return it and just get a Roku XDS. I LOVE apple products but this is making things very impossible and frustrating...i just wanna watch my netflix!

13" Macbook Pro, Mac OS X (10.6.4)
  • Smiller4128 Level 1 (0 points)
    Can anyone at all please provide me with some help?
  • Dup B Level 1 (0 points)
    I'm having a very similar problem although it's not with all the Netflix titles -- only selective titles. It's very frustrating, I haven't found a clear answer yet from Apple or Netflix.

    You can take a look at this thread: http://discussions.apple.com/thread.jspa?threadID=2597992&tstart=0. In it there's a suggestion of changing your DNS settings to Google DNS -- it didn't work for me but it might for you. I've tried everything else from resetting and restarting to no avail.

    I'm bumping up my DSL speed tomorrow and I'm hoping that might solve the problem but if it doesn't I think I'll seriously consider trading for a Roku.
  • Dup B Level 1 (0 points)
    Update: My DSL's speed was bumped up today (it's still pretty challenged at about 2.5mps) but it did solve my problem with streaming certain titles. All the titles that were giving me problems at my previous speed now play without any problems, pausing or hiccups. It seems like if most of the titles were playing at the previous broadband speed than all of them should have, but this wasn't the case. I don't know if that's because the way Netflix coded some of the titles it causes a conflict with ATV2's firmware or what. But I'm glad it's working.

    My next issue is getting the HD Movie Trailers to begin playing before the entire file is loaded...
  • Gaugevox Level 1 (0 points)
    I too have had a world of issues with Netflix streaming on the new ATV2. You may want to try playing around with whatever you're trying to watch. I've had some marginal success.I have found that some titles work and others don't. Others can be "tricked" into working.

    For instance:

    Watching episodes of 30 Rock, will not cooperate at all. Plays the first couple seconds, then quits.

    Watching episodes of Futurama will work if you fast forward 30 seconds into the show.

    I watched a movie or two without issues.

    I am using the slowest high speed internet available, but I have no problems streaming Netflix to Macbook pro, iPad, iPhone 4, desktop PC, why is a device that is specifically designed to stream content having such a problem?
  • Steffenu Level 1 (15 points)
    I am having similar issues with Netflix. It's not all titles. I think this issue is caused by netflix and not Apple or my connection speed. I did a speed test on my system and came to 10 MB using Wireless N, plus I was able to stream a full 1080p HD movie from Apple without even the smallest hickup.

    So, I think it's Netflix. maybe their network is overwhelmed with too many new accounts caused by the new ATV2.

    But all in all, I love the new ATV2. Hopefully Apple will talk to Netflix so they can igure out what's going on.

    Just giving my 5 cents.
  • BradGarbus Level 1 (5 points)
    I have the same issue.
    I have 20+ mbs cable internet, high speed network (gigabit) and can stream movies without any hesitation from my iTunes account from my PC using home sharing, but when I use Netflix with my Apple TV 2nd Gen it is hit or mostly miss. Very frustrating.

    It will start the movie, play about 1 minutes then hesitate for a minute, then again play another minute and then hesitate...

    I originally had it hooked up wireless (N), but then connected it via wire with the same results.

    I got rid of cable TV and replaced it with the Apple TV 2nd Gen. So far I am NOT impressed with the Netflix side of things.

    The strange part is I can watch Netflix just fine on my iPad, iTouch, or any of my computers!

    Any suggestions would be very welcomed!

    It has started being called "crapple-tv" in my household...

    I am going to probably call support AGAIN to see if maybe I get someone that has a clue...
  • Markus Wernig Level 1 (20 points)
    Please do call Apple tech support and send them feedback/bug reports through http://www.apple.com/feedback/appletv.html

    Let them know that they have to start taking their "hobby" (the Apple TV) seriously.

    Netflix streaming has gotten a lot worse since the latest iOS update, IMHO. The spinning waiting ball is a constant companion to any Netflix streaming attempt. I also get constant freezes, out of sync audio - all that with a super fast internet connection (26+ MB/s down). Likee everyone else I have ZERO problems streaming Netflix via the iPhone or the Netflix website on my MacBook Pro.

    It clearly is an Apple TV issue. And it's unacceptable. I traded in my Roku for the Apple TV. And while navigation and menus are way better on the Apple TV, Netflix streaming is a nightmare. The Roku was steaming Netflix without any problems.

    Please, Apple! Don't tell us this can't be fixed. It's working fine everywhere else.......
  • gannoneye Level 1 (0 points)
    Just chiming in to express that I'm another dissatisfied customer. The atv2 started out working fine. There were hiccups in the first minute of anything I downloaded, but then it caught up and streamed fine. That was something I could deal with. Now, however, MOST episodes will not download at all. Of the ones that do, most of them hiccup every thirty seconds. Unwatchable. The remaining 5% of titles, movies, tv, hd or otherwise, work fine. They just may not be what I want to watch at all. I have reset my router several times and that fixes the problem for about 30 minutes. I will be able to download almost anything quickly and it plays fluidly. But after that episode, if it doesn't kick me out of the episode mid-way, I'm back to square one. Netflix streams fine on my macbook, soooo....what does that tell you?

    Lots of finger pointing going on between apple and netflix. No solution. And I'm a hundred bucks in the hole, really a little more if you count my netflix monthly subscription which is pretty much worthless at this point. I guess I need to pick another hobby.
  • Thomas Hilimire Level 1 (5 points)
    Use Google’s Public DNS Server To Fix Apple TV 2 Streaming Problems

    1. Start your Apple TV 2 and navigate to Settings => General => Network and click on Configure TCP/IP.

    2. Select “Manually” next to Configure IP.

    3. Click “Done” on the IP Address screen and do the same for both the Subnet Mask and Router Address screens.

    4. Configure the DNS Address screen with the following IP address: and click “Done.”

    You should now be able to stream Netflix on your Apple TV 2.


    What we did here (in network admin speak) was to set the Apple TV 2 to use a static IP address. Instead of using OpenDNS or the ISP’s DNS servers, which would be “handed out” by DHCP, we specified that the Apple TV 2 should use Google’s Public DNS server ( which fixed our Netflix streaming problem on the Apple TV 2. On a business network you would never configure a static IP address within a dynamic range, but in a home this shouldn’t create a problem. I would also like to point out that this fix should also be tried even if you are not using OpenDNS because some ISP’s DNS servers might not be as reliable as they should be.

    Update: March 2nd, 2011

    I just setup an Apple TV 2 for a friend who uses Time Warner Cable Road Runner for his ISP. Netflix streaming didn’t work properly right out of the box and my friend did not have his router configured to use OpenDNS. Setting the Apple TV 2 DNS address to immediately fixed the problem with Netflix streaming!
  • tatnip63 Level 1 (0 points)
    I have been having sporadic performance issues with Netflix and iTunes HD streaming using 802.11n. Funny thing happened when I was playing around with my Airport Extreme radio settings. I changed the setting to 802.11a - g; and my brand new iMac i7 started using the 802.11a (it uses 5 GHz frequency like 802.11n) protocol as did my Apple TV (2). The other devices in my home - iPhones, PCs, etc. connected at the 802.11g protocol. Major improvement in performance of Apple TV for Netflix. I have not tried renting a movie on iTunes since I made that change, but I plan to to that next. I can't explain why "a" vs. "n" works much better in this case, but it did. I'll post again after a longer test drive to make sure it isn't some short term anomalie. It would be nice to know why the major difference with the much older protocol.
  • Pudgipuk Level 1 (10 points)

    I have finally "solved" an annoying problem.  When I watch Netflix, I get very frequent buffering time outs or disconnects.  I have tried everything from rebooting the ATV, Airport etreme, Comcast modem..........etc.  Sometimes it has temporarily fixed the problem. By temporarily I mean for a few min utes.  While looking for solution, I have phisically moved the ATV away from the Sharp TV, Tivo Box, Panasonic DVD and ..............BINGO it worked.  The fix was a sort of blind leading blind concept, but I have reproduced the condition over and over again and proved that when the ATV is close to other components there is some sort of EMI (Electro magnetic interference)present. That caused the Netflix streaming problems.


    So now I have a solution, but I have to look at two ugly wires connected to my ATV (AC and HDMI), which is about 6 feet away from my other components.  Hope this helps.

  • BenFinklea Level 1 (15 points)

    Many people have been having a streaming problem with the Apple TV - especially with Netflix. In fact, it's often the most popular topic on this forum. After having the same problem off and on for two years, I finally figured out the following solution. It uses Google's public DNS service instead of your ISPs DNS.


    1. Navigate to Settings >> General >> Network and select Configure TCP/IP.


    2. Select “Manually” next to Configure IP.


    3. Dont change the IP address or the Subnet Mask and Router Address. Just click "Done".


    4. Set the DNS Address screen with the following: and click “Done.”


    You should now be able to stream more smoothly on your Apple TV.


    This problem is probably caused by a bad streaming server somewhere on Netflix's CDN (Content Delivery Network). The DNS points your Apple TV based on location. By using Google's DNS, you get a different streaming server. That is, of course, a wild guess and is not verifiable by me. But, it makes sense so I'm going with that.



    If this works for you, please buy a cup of coffee for a complete stranger or some other selfless, random act of kindness.

  • Miz Rebel Level 1 (10 points)

    OHHHH!  Ohhhh!  It worked!!!  Thank you!  I'm going to go buy someone a cup of coffee.