Previous 1 2 Next 20 Replies Latest reply: Aug 21, 2012 11:59 AM by elscorcho42
Joachim Frey Level 1 (75 points)
Hi,
I have subscribed to a calendar within my family.
Now, I want to turn off the alarms just for this calendar on my iphone.
How can this be done?

Thanks
JO

iMac, Mac OS X (10.6.4)
  • Joachim Frey Level 1 (75 points)
    Anybody ?
  • Pierre G. Bernard Level 1 (5 points)
    With the new MobileMe calendar, you can use iCal on your Mac to subscribe to calendars. When you set the subscription's location to be your MobileMe account, it propagates to the iPhone.

    iCal gives you the option to strip alarms, attachments and to-dos from subscribed calendars.

    Unfortunately, my iPhone does not honor that option. It keeps ringing alarms for my wife's calendars. I believe this is a bug.

    I chatted with MobileMe support about this. The support person seemed surprised to hear that my wife's alarms make it through to my iPhone. Unfortunately, they were unable to help.

    Pierre
  • Edward NC Level 1 (105 points)
    Same problem here. My wife syncs with my Google calendar so that she can see my ludicrous timetable and add the odd event. Unfortunately, she also gets all of my alarms - of which there are many. Ideally, she wants to be able to switch off all alarms for my calendar. I can't find any way of doing this.

    Come on Apple...surely there are couples all over the world who share calendars and have the same problem?
  • bug00 Level 1 (45 points)
    Same problem here. Just wanted to add my voice to yours. Very frustrating bug.

    I have the alarms turned off/ignored for this particular subscribed calendar within iCal on my Mac. So, I don't see them on the computer. MobileMe just doesn't seem to share that setting with the iPhone, as the iPhone displays alarms for this calendar constantly.
  • Level 6 (11,040 points)
    Another vote here.....my wife needs to know my appointments but doesn't need the alarms....PLEASE can we be given the facility to switch off alarms by calendar.
  • Joachim Frey Level 1 (75 points)
    Still no solution around the corner so far.
  • Greg Welch Level 1 (95 points)
    Same problem. I don't know whether it's a bug or intended (hard to believe, but "remove alarms" on the mac could mean just on the mac...).

    Anyway, only solution I've found (which I think works) is:

    1. Subscribe to the calendars on my Mac in iCal specifying "On My Mac" as the Location of the calendar (not MobileMe), and

    2. Subscribe manually on my iOS devices (iPhone and iPad), which gives an option to disable alarms.

    You do 2 through Settings -> Mail, Contacts, Calendars -> Add Account... -> Other -> Add Subscribed Calendar, and then entering all the info, and turning on the option to ignore alarms.

    Not ideal, but I think it works.
  • audiohollywood Level 1 (0 points)
    Thanks for your post Greg. I did try this and it worked like a charm. I'd like to add that you will need to go into Settings>Mail, Contacts, Calendars to switch off calendars and then turn it back on again for the changes to take effect. For some reason the iPhone doesn't reflect changes to the calendars in the display list until this action is done.
  • Stacy Brownrigg Level 1 (45 points)
    Ditto. Fix it apple
  • Rozak Level 1 (5 points)
    Just to add another voice to say 'fix it please' - such a great thing to be able to share calendars and this problem makes it almost unusable (if I get another appointment popping up saying 'facial' I'll scream)
  • Mike Lovelady Level 1 (0 points)
    Yes, another voice asking PLEASE FIX!
  • dppellegrini Level 1 (0 points)

    Same thing - don't need to have the alarms from my wife and kids' calendars on my iPhone.

    No other better advice out there? Greg's approach seems cumbersome and I don't want to alter 5 calendars...

  • jen587 Level 1 (0 points)

    Same problem here...Just adding my voice in hopes someone at Apple will listen.

  • elscorcho42 Level 1 (0 points)

    I'm sure iCloud will fix everything.

Previous 1 2 Next