7 Replies Latest reply: Nov 4, 2010 12:07 PM by The guy who posted this
RoxasXIII Level 1 Level 1 (0 points)
I have tried to update multiple apps on my ipod touch, but every time it goes to start downloading it just stay on "waiting." No matter how long it is on the app still just stays on waiting. I restarted my device, but I do not believe that the app actually updated correctly, and it does not show up anymore in my available updates. How do I get the updates to stop stalling on waiting forever?

Windows 7
  • 1. Re: App updates stuck on "waiting"
    N Pokorny Level 1 Level 1 (110 points)
    Some apps take a VERY long time to download, and many times, if you let your screen go to sleep, the iPod may disconnect from wifi and not finish downloading. In your case, you need to connect to your computer and have iTunes finish the updating process.
  • 2. Re: App updates stuck on "waiting"
    RoxasXIII Level 1 Level 1 (0 points)
    No, that is not the case. These are apps that I have updated before. There is no reason for the update to stay on waiting for 5 or more minutes. Installing is what takes the longest and I'm not talking about that. I click "update", put in my password, then the app just goes to waiting. It is just sitting there on my device doing nothing. This is a new problem I have found that many other users are also experiencing. I am not letting my device disconnect, these apps are not downloading, they are just freaking WAITING!
  • 3. Re: App updates stuck on "waiting"
    N Pokorny Level 1 Level 1 (110 points)
    Alright, if it's stuck on waiting and it's not doing anything, plug it in to iTunes and it should finish the updating for you. I have done it before when the same thing seemed to be happening while I was at a friends house, so I just went home and plugged it in and iTunes finished it for me.
  • 4. Re: App updates stuck on "waiting"
    jenny55972002 Level 1 Level 1 (0 points)
    I'm having the same problem and it's been on waiting for almost two days including plugging it in to the computer to let it finish, and it does the same thing i really hope some does something about this I am really not liking this.... please apple do something about this...
  • 5. Re: App updates stuck on "waiting"
    masands Level 1 Level 1 (5 points)
    I also got this problem but you don't need a computer or iTunes to fix it. Just go to settings and log out of your account or do it from the app store. The downloads cancel automatically. Sign-in again and this time it should download.
  • 6. Re: App updates stuck on "waiting"
    Phil Kim Level 1 Level 1 (15 points)
    Try restarting your iPod. iOS 4.x has a bug that erroneousness reports download as still in progress, when in fact it may have completed already.
  • 7. Re: App updates stuck on "waiting"
    The guy who posted this Level 1 Level 1 (0 points)
    Ok... So I hard reset and powered down ... No luck... Then I went to the app store and updated all... The first app to update was the one that was stuck.... Prob solved here..