Previous 1 2 Next 24 Replies Latest reply: Oct 21, 2010 6:05 AM by Senne Guns
Senne Guns Level 1 Level 1 (5 points)
Hi all,

since updating to Mainstage 2.0 (I'm currently on 2.1.1), my knobs from my Novation Remote Midi Controller - which used to control the volumes of the different channels in Mainstage - started to behave curiously: if I turn them very gently clockwise, the volume increases (as it should do), from the moment I start turning them a little faster they immediately jump to full scale (which is strange) and if I turn them counterclockwise in any way (to decrease the volume), they also immediately jump to full scale volume (which is even more strange)...

In Mainstage, when I "learn" a controller, the type is (according to Mainstage) "Relative (Sign Magnitude)". I tried experimenting with other types, but so far no luck.

I never changed anything internally in my MidiController and once again, in Mainstage 1 this used to work properly, so I'm really puzzled here as to what could be the problem.

Any ideas?

Thanks a lot!

MacBook, Mac OS X (10.6.4)
  • Senne Guns Level 1 Level 1 (5 points)
    Edit: just experimented a bit more and the problem seems even stranger: in the "layout" view, when I've just learned the controller and twist and turn it, it seems to behave properly (clockwise/counterclockwise turning of the hardware knob gives the same result on screen). It's only when I switch to "edit" view (where you map the controllers) that it suddenly behaves completely wrong (as described above).

    Any clues? My mapping parameters seem normal (range min: minus infinity, range max: +6db, not inverted, graph is diagonal)...
  • dingdangdawg Level 2 Level 2 (455 points)
    Any differences when you change the Preferences>General>Parameter Values>Respond to Hardware Moves .... (set to Jump, Pickup, or Relative setting, depending on what you want to happen)?
  • Senne Guns Level 1 Level 1 (5 points)
    Hi,

    thanks for your suggestion but unfortunately that doesn't help... It's really strange: in layout mode I can twist and turn my knob perfectly, in edit mode I can only twist my knob clockwise (increase a value). When I try to decrease (turn counterclockwise), the software-knob immediately jumps to maximum value...
    When I increase, I can read of the screen a midi value of 65 (or a little more if I turn the knob faster), decrease is midi value 63 (or a little less)... Does it have anything to do with value 63 being the "middle" value (between 0 and 127)?
  • dingdangdawg Level 2 Level 2 (455 points)
    That's insane. Just for troubleshooting purposes, try creating a fresh, blank Concert, create a single channel strip, and assign the control(s) and map them, just to see if they do the same thing. Shooting in the dark....
  • Senne Guns Level 1 Level 1 (5 points)
    I agree, it's insane

    I already tried that (creating a blank patch and assigning controllers from scratch: I get the same thing)... I even created a new template in my MIDI controller... No change.
    I'm really stuck here; can't figure out why a controller behaves normally in one mode (layout) and goes completely crazy in another mode (edit)...

    Any other ideas?
  • dingdangdawg Level 2 Level 2 (455 points)
    I'm stumped; it makes no sense to me. The wacky thing is that the Novation works OK in one mode and not the other. I use a Nocturn, and it works as expected. The only thing I can think of is some sort of corruption in a preferences file, or some other outlier. If you are at the end of your rope and have some time, you could always save your Concerts, instruments, samples, etc, then trash all your MainStage files, and reinstall.

    Do you have another controller you could try to see if it works correctly in Perform mode? Also, what does the same controller do when using it with another application such as Logic; does it behave normally (I'm guessing it would, given that it works correctly in Layout mode). Again, I'm grasping at straws, cause I'm stuck too.
  • Senne Guns Level 1 Level 1 (5 points)
    Well, maybe together we can sort it out Thanks already for your help!

    Tried the two things you suggested: assigned a Novation relative knob controller in Logic Pro, worked like a charm, no problems.
    I happen to have a Behringer BCR2000 (of which I never thought I would use it again , learned a relative-knob controller in Mainstage, turned it clockwise, everything ok, turned it counterclockwise... and surprise surprise, it also jumped immediately to maximum value... ONLY in edit mode, it works fine in layout mode.
    Also: I don't have the problem with absolute knob controllers, not with the Novation nor with the Behringer controller. But I don't want an absolute knob controller, I want a relative controller to adjust volume in real time without the software volume jumping to an abslute value...

    Anyway, what we know now is that the problem is definitely NOT the Novation Controller, but something very strange inside Mainstage... Leaves us with the question: what?
  • gilapuki Level 3 Level 3 (530 points)
    CurlsOnKeys wrote:
    Also: I don't have the problem with absolute knob controllers, not with the Novation nor with the Behringer controller. But I don't want an absolute knob controller, I want a relative controller to adjust volume in real time without the software volume jumping to an abslute value...


    This is not a solution to your problem, but a work around that may get you out of trouble.

    Leave the knobs as absolute & go to Preferences>General>Parameter Values>Respond to hardware move. Set that to 'Pickup'.

    Now the knobs should work the way you want them to.
  • Senne Guns Level 1 Level 1 (5 points)
    Hi,

    thanks also for your help! In theory that should work indeed and I tried it but Mainstage still behaves stranges. Upon some patch changes the software volume knob doesn't "pick up" unless I twist and turn my hardware knob several times back and forward untill (it seems) one specific MIDI value "wakes up" the software knob and from that moment I'm able to control the volume... But of course, in a live situation that's not what you'd want...

    Seems to me reinstalling Mainstage is the best option, no?
    The thing is: I've got 2 Mainstage-apps in my Applications (one called "Mainstage 2.0.1" and one simply called Mainstage (and that is the 2.1.1 version; same goes for Logic by the way). What do I do? Trash them both? Or is there some kind of uninstaller on the Logic installation disk? Any pref/system files I have to manually remove?

    Thanks already for all your kind support.
    S
  • dingdangdawg Level 2 Level 2 (455 points)
    Apple keeps your older 2.0.1 version of MS when you install 2.1.1.

    To get rid of ALL of your MainStage program files (but not documents, Concerts)
    - back up your Concert files (User>username>Music>Mainstage) just in case
    - download free AppZapper utility online and install
    - drag MS 2.0.1 onto AppZapper (it deletes application and all associated program files)
    - do the same for 2.1.1
    - reinstall MS
    - create a single simple Concert first to test the Novation, before trying older Concerts

    Its interesting to me that things worked fine in 1.X, which leads me to believe there may be something broken in communication between 2.X MS and your specific controller model. I am guessing you have done online searches and checked the Novation forums? Still, desperate times call for desperate measures, so the complete deinstall, reinstall won't hurt.
  • Senne Guns Level 1 Level 1 (5 points)
    Hi,

    ok, thanks, I'll try that tomorrow. Yeah, looked around on the internet, couldn't find anything about possible Novation/Mainstage conflict, but don't know if that's the case, since the Behringer BCR2000 gave the same strange results, remember... So I'm hoping it has something to do with Mainstage and that reinstalling helps...
    I'll tell you tomorrow
  • GilbertLiddell Level 1 Level 1 (10 points)
    Is this resolved? I'm experiencing the same volume issue with my Edirol PCR-800 and mainstage.
  • Senne Guns Level 1 Level 1 (5 points)
    Hi all,

    time for an update. I reinstalled Mainstage as you suggested and BEFORE updating to 2.1.1, I tried a new concert, created a software knob, learned it to my Novation Midi Keyboard and... it behaved normally! However, when assigning the relative hardware controller in layout mode, Mainstage kept "seeing" it as an absolute controller. I had to set the type to "Relative (sign magnitude)" myself before it worked correctly but once I'd done that, I could twist and turn my hardware knob clockwise and counterclockwise in layout AND edit mode and Mainstage followed without a problem.

    Then I updated Mainstage to 2.1.1. I noticed that, when learning the controller in layout mode, Mainstage now "sees" it correctly (as a relative controller) BUT! ... switching to edit mode caused the same problem as originally adressed in this topic: turning the knob counterclockwise in this mode resulted in an immediate jump to full scale 6 dB...

    So still not fully solved, but maybe we're getting a little closer? It clearly has something to do with the update tot 2.1.1. I re-opend my original concert in which I had the problem in Mainstage 2.0.0 and the knobs behave ok, so it would be a (temporary) solution to keep working in 2.0.0 (hoping that their aren't too many other bugs in this first version

    Any other ideas or solutions are always welcome!

    Message was edited by: CurlsOnKeys
  • dingdangdawg Level 2 Level 2 (455 points)
    That's good data. So which version worked OK, and which version "broke" your Novation response? Did it break with V 2.0.1, 2.1, or 2.1.1?

    If it broke with 2.1.X (after 2.0.X): its notable that 2.1 was the first version that added 64-bit mode. Try launching 2.1.1 in 64 and 32 bit mode and compare notes. Did anything change?

    Steps to switch bit modes: 1) Quit MainStage if it is running.
    2) Navigate to the MainStage application in the Applications folder.
    3) Choose Get Info from the Finder File menu.
    4) Disable or Enable the option to "Open in 32-bit mode" to switch modes.
    5) Restart and test.

    Beyond that, I would speculate that something broke in one of the MS updates (since your hardware/driver did not change); that, I would report it to Apple.
Previous 1 2 Next