Previous 1 2 Next 21 Replies Latest reply: Oct 12, 2010 1:55 PM by cornelius
PatrixUSA Level 1 Level 1 (0 points)
I have two folders that I am unable to trash. Have tried all key combination and terminal options that I know of to empty. Unable to post an image of the errors that I am getting when attempting to empty via Secure Empty Trash and Terminal commands I will type out the error messages.

When using Secure Empty Trash: "The operation cannot be completed because a required item is in use." Also, "The operation cannot be completed because the item {folder name} is in use."

When using Terminal commands, using "sudo rm -ri /" I enter my password and it asks for confirmation and the resulting message is "Directory not empty"

ANY help would be greatly appreciated. Thanks.

MAC Dual 1.8 GHz PowerPC G5, Mac OS X (10.3.x)
  • Niel Level 10 Level 10 (265,405 points)
    Run a disk repair utility on that drive.

    (54181)
  • PatrixUSA Level 1 Level 1 (0 points)
    Thank you Niel - Have both verified and repaired permissions on the disk. Also, I've tried both trash it and onyx programs to empty, no success. What disk repair utility are you referring to?
  • Texas Mac Man Level 8 Level 8 (46,535 points)
    If you have the problem where you can’t empty the Trash or eject a disk because something is preventing you? Usually the reason is because some application has a file open, and thus you can’t get rid of the disk or trash the file. Then use What’s Keeping Me! What’s Keeping Me (10.4) will identify the application that is preventing you from accomplishing your task. You can then use What's Keeping Me to quit, relaunch, or kill the problem application so you can get on with your business. http://www.hamsoftengineering.com/products/wkm/wkm.html

    Sometimes it happens that the Finder just doesn't want to empty the trash anymore and says "The operation cannot be completed because the item "" is in use.". That's a good warning if it is true, but sometimes you want to get rid of an application and this warning appears even though the only thing running is the Finder. Usually after a restart you can delete it. But that is very time consuming and even then, it is sometimes still stuck not wanting to be deleted. There is a risky command that can be used in the Terminal that will empty the trash no matter what. Risky because a simple error in the syntax could erase a lot of stuff that you want to keep.

    There is a way of forcing the Finder to empty the trash no matter what! It is done in the freeware customization and maintenance application OnyX (download @ http://www.titanium.free.fr/pgs/english/apps.html ). Once you loaded OnyX and entered your administrator password, choose "Cleaning" in the top bar. Click on the "Trash" tab. You can now choose whether you want to "Delete" or to "Securely Delete" (by overwriting) and click Execute. That's it, it will force the Finder to empty the trash even if the files are in use!

    Many times, depressing the Option key while emptying Trash will empty problem files. Another method – start by depressing the mouse over the Trash icon. Then empty trash from the pop-up menu. The files should be emptied.

    Also look at these links.

    You can't empty the Trash or move a file to the Trash in Mac OS X
    http://docs.info.apple.com/article.html?artnum=106272

    Solving Trash Problems
    http://www.thexlab.com/faqs/trash.html

    How To Fix Stubborn Trash and Why it Won't Delete
    http://www.osxfaq.com/Tutorials/LearningCenter/HowTo/Trash/index.ws

    Download Trash It! v3.6.1 from:
    http://www.nonamescriptware.com/?page_id=5

    Download DropNuke from:
    http://www.versiontracker.com/dyn/moreinfo/macosx/12664

     Cheers, Tom

  • cornelius Level 6 Level 6 (17,825 points)
    "The operation cannot be completed because a required item is in use."

    Have you tried completely shutting down the computer, then restarting and emptying Trash?

    Also, check out Dr. Smoke's FAQ Solving Trash Problems.

    cornelius
  • PatrixUSA Level 1 Level 1 (0 points)
    Thanks for the replies.

    Texas Mac, yeah, I've tried the xlab solutions and onyx too, no go, onyx gives an error and the xlab terminal solutions all come back with 'directory not empty'.

    cornelius, the computer has been restarted, rebooted, shutdown, etc. many times now, still unable to get rid of these folders.

    Note, I can empty all other items from the trash no problem, just these two folders give me the errors listed in my original post. At my wits ends, may just leave them there.? They don't seem to be causing any other issues, besides not being able to empty them out of the trash.

    Texas Mac, I'll try some of the other links in your post and see what happens, thanks all.

    PatrixUSA
  • Niel Level 10 Level 10 (265,405 points)
    The Repair Disk command of the Disk Utility, not Repair Permissions. You may need to boot from a Mac OS X install disk or third-party software such as DiskWarrior.

    (54191)
  • PatrixUSA Level 1 Level 1 (0 points)
    thanks Niel - the 'Repair Disk' button is greyed out when i select my internal drive (which is where i would need the repairs, no?) but able to be selected when i select my external data drives.
  • Niel Level 10 Level 10 (265,405 points)
    As I said above, you may need to reboot from the install disk. If you don't have that, restart with the Shift key held down and then normally.

    (54192)
  • PatrixUSA Level 1 Level 1 (0 points)
    niel, rebooted holding shift key down - machine started then rebooted on its own - logged in normally upon this reboot and Repair Disk is still grayed out, unclickable.

    What should have happened upon rebooting with shift key held down? thanks.
  • PatrixUSA Level 1 Level 1 (0 points)
    i can't seem to get the system to boot into safe mode. When i press and hold the shift key after tone i see the apple with spinning wheel, release the shift key and the system then reboots. I get no indication that the system has booted into safe mode, hmmm....
  • cornelius Level 6 Level 6 (17,825 points)
    Hold down the Shift key immediately after startup chime and keep holding until the gray apple appears, then release. It takes a while to boot, so be patient. Once booted it should say Safe Boot or something to that effect.

    cornelius
  • PatrixUSA Level 1 Level 1 (0 points)
    Yeah, that's the sequence i'm using and the only thing it accomplishes is a restart - system restarts seconds after i release the shift key then proceeds to boot normally - i do hate it when issues begat issues...

    I've also tried holding the shift key down before the chime, on the chime, way after... etc, etc, all to the same result.

    PatrixUSA
  • cornelius Level 6 Level 6 (17,825 points)
    Try this:
    • Shut down the computer.
    • Locate the following keys: Command, Option, P, and R. You will need to hold these keys down simultaneously later.
    • Turn on the computer.
    • Press and hold the Command + Option + P + R keys immediately after the startup chime.
    • Hold keys down until you hear the startup chime for the third time.
    • Release the keys and immediately hold down Shift key to start up in Safe Mode. _Hold Shift down *until the gray apple appears*, then release_.
    • Log in and empty Trash.
    • Restart normally and log in.

    cornelius
  • PatrixUSA Level 1 Level 1 (0 points)
    Thanks cornelius - I had zapped the PRAM and NVRAM prior but went ahead and followed your protocol again. Upon hearing the third chime, I held the shift key until the gray apple appeared, then released - the system gets to the spinning "gears" for about 2 seconds then restarts normally - no sign of safe mode - so, same result. Why wouldn't I be able to start in safe mode?

    The owner is telling me since the system was purchased pre-configured thru AVID that he does not have the OS start up disk - hmmm...
Previous 1 2 Next