Previous 1 2 3 Next 767 Replies Latest reply: Apr 4, 2016 8:54 PM by carliito5
TWalkerPolk Level 1 Level 1
I wanted to create this topic to ask if others are running into the same issues I am with streaming rented HD movies. I go to play the rented HD movie and am transferred to a screen that says "Loading...." for about a minute or two. Then, that message is replaced with one that says "Ready to play in [xxx] minutes"...with horribly long times listed (my movie was rented last night, and as of this evening, it shows "Ready to play in 232 minutes").

This seems like a MAJOR flaw with the Apple TV. I have no problem viewing YouTube, HD Netflix movies, HD trailers, etc. I have even been able to watch an HD TV show rental within about 5 mins of selecting it. Seems like there may be a major flaw in the streaming process for HD Movie rentals over the Apple TV.

If you haven't tested this yet (or if you have no issues), please post what is happening with your HD movie rentals.


Note: I have rebooted everything, used my Airport Express with the ethernet cord directly into the Apple TV, over wiFi, adjusted the distance between my router and the Apple TV. Nothing has worked.

Dell Laptop m1330, Windows 7
  • Steven Binder1 Level 1 Level 1
    Yes. I'm having same problem. Have not found work-around.
  • Lisa Heilman Level 1 Level 1
    i'm having the same problem with both HD and standard def movies. At one point, the HD movie was going to take over 3,000 minutes to load. The AppleStore says they will replace my Apple TV with another, but now I'm not certain that the problem will be fixed. I'm using a Comcast connection which Comcast says is high speed.
  • rikithemonk Level 1 Level 1
    I purchased two apple tv's. One for me, and another for my parents. They are on High speed DSL and a speed test is showing 3 download speed. Im on Cable High speed with 8 download verified with Speakeasy speed test. I'm seeing the same download delays on both units. Both networks are simple set ups using Apple Airports, and im getting full bars on the Apple TV signal meters.

    Im seeing some shows downloading fine, while others have massive delays. For instance WKRP episode one started almost instantly, while the new Wolfman movie was 130 minutes delay. To further test my network, while the Wolfman delayed, I opened netflix on the apple TV and ran several movies without issue.

    This tells me the problem is on Apples end. Its my bet that they didn't expect this number of people to jump on so quickly.
  • Sirstever Level 1 Level 1
    I am having same problem. Went to watch a movie last night with the wife, rented it and then it said loading ready to view in 78 minutes. It was on wireless at the time, thought this might be the problem so I spent 10 minutes re-running all my cables to plug it in via ethernet, it did not work. Still said 78 minutes, was bummed but we thought maybe you just need to "pre-rent" right? So, come back today to watch it (Apple TV has hibernated) and go to watch, it says 78 minutes again. I think the problem is it needs to buffer the movie but once it does that it losses the buffered stream after so long or after hibernation. So, the only potential work around doesn't work either. Some one has to do something because this literally negates the ENTIRE point of the Apple TV. With this much wait time, I could just rent the movie from playstation store or use Netflix. In fact, that is what we ended up doing, watching a "free" Netflix movie after paying $5.00 to Apple to rent a movie. Now my 30 days are counting down and I can only watch the movie when I have 80 minutes to sit around and wait BEFORE I even want to watch the movie. *** Apple! Someone please tell me what I am doing wrong and how I am just being stupid so that I can get this to work right and actually start enjoying this $100 (what is for now completely useless, albeit nicely designed black box).
  • sjmitchell Level 1 Level 1
    Me too. First night we got the Apple TV installed I shelled out $4 for a movie rental. The movie started okay, but then about an hour into it it got stuck, said "Ready to play in 48 minutes." Then it just never got unstuck. Eventually had to disappoint the kids and give up.

    Since then I've tried a few free TV show rentals with various incarnations of the same problem. Seems like streaming of HD rentals is seriously broken--at least for me. I'm sticking to Netflix streaming until there's some news from Apple that this is fixed.

    Search Google for "Apple TV ready to play in minutes" and you'll find lots and lots of people are experiencing this problem. Also lots of people reporting this problem on Twitter. I don't know why the gadget blogs haven't picked up on this yet--Apple news is really hot, and a new product launch with problems is particularly juicy news.
  • dgalvan123 Level 1 Level 1
    I experience this problem with the rental shows, but also with the HD trailers and with the higher quality video podcasts and youtube videos. I am convinced it is because of my slow internet speeds. i pay for "up to 3 Mbps", but typically get between 1.5 and 2.5 downstream.

    Based on the file-size-to-show-duration ratio of iTunes shows (example: a 720p HD tv show rental on itunes downloads at 1.44 GB for a 44 minute show), I estimate that you need a 4.4 Mbps or higher actual bandwidth to get real-time streaming that starts soon after you order it. (Just divide the first number, 1.44 GB, by the second, 44 minutes, to find that it takes about 4.4 Mbps to watch that show. Your actual download speed has to be higher than the bit rate of the movie file itself: that way the movie will download faster than the movie can play, and you will never catch up to the stream and hence it should start playing immediately. Since my bandwidth is ~1.5 Mbps, I have to wait for the ATV2 to buffer a significant portion of the show if I am to watch it without catching up to the stream.

    That said, several people are posting here that they are experiencing the problem even though they confirm they have streaming speeds of over 5 Mbps. Don't have an explanation for that, but the fact that my problem is not limited to the iTunes rentals but also makes me wait for the other videos on apple tv implies that bumping up my bandwidth should help. I'm getting "up to 10 Mbps" service installed in a week. I'll let you know if that makes a difference for me.
  • Robeartoe Level 1 Level 1
    This is incredible. I am also a victim in the false advertising of renting movies on demand. Has anyone verified that the charge was actually made on the credit card even though the movie never streamed?
    Has anyone heard back from apple? What are we to do?
  • thelanj Level 1 Level 1
    Same problem. Amazon VOD, Netflix, Xbox Live HD streams all start instantly. Just plugged in my new apple tv and tried to rent robin hood. 71 minute wait, 10 minutes later said it was ready, hit play, 10 minutes later it hadn't even buffered enough to start playing. Apple FAIL

    The roku is looking better and better
  • Markse Level 1 Level 1
    I have the same issues. Apple TV2 will not recognise my computer from sleep and it's impossible to watch a rental movie. Started to watch a film, went back to view the remainder in the evening and was told I had to wait 537 minutes! My Apple TV1 works absolutely fine. Not impressed.
  • jpr76 Level 1 Level 1
    I am beginning to think that my issue is a network problem.

    Both times I have rented an HD film from ATV2 it was Sat and Sun night (peak demand). Both films were ready to play pretty quickly and started normally. After a pause of the film for 2 mins, when resuming play their playback stalled and I was given wait times (sometimes ridiculous such as 130 odd mins, sometimes 20-30 mins). Either way, waiting for the duration the film announced it was ready to play again but upon playing it stalled again and re-entered the cycle! In both instances the films were not fully cached at the time. I seem to have no problem with fully cached material.

    My broadband (Virgin Media Cable in the UK) claims up to 10mbps. After running a speedtest last night (during all the problems), I was only getting 2.3mbps download.

    Today (off peak time) I am getting 10mbps! Unsurprisingly, no problems with the ATV stream from itunes!

    I wonder whether the issues we are facing are actually because our ISPs are not producing the 'goods' at peak times!?
  • benoitgl2000 Level 1 Level 1
    I just read all the posts in that thread. I don't experience that at all. Streaming rentals is blazing fast. OP said that sometimes it worked within about 5 minutes...5 min is TOO long.

    Did any of you tried to rent in iTunes on your computer instead to see if the issue is from the Apple TV or not ? Maybe your ISP deliberately slows down the connection from Apple servers...
  • Living In A Box Level 1 Level 1
    Yup, I'm with Virgin Media in London, UK and I'm having exactly the same problem with the same 10 meg pipe. At peak times my streaming to ATV2 is squeezed heavily and causes the "loading" problems discussed here but on say Tuesday afternoon, I have no problems at all. I would definitely say my issues with streaming are directly attributable to supply/demand issues at peak times with my ISP. Guess I may have to go to 20 meg which is seriously boring!
  • jpr76 Level 1 Level 1
    Living in a Box - I spoke to Virgin today and despite giving them comparative speed tests they claimed all was well with my system and accused my home setup as being faulty!!

    I have bitten the bullet and gone for an upgrade to 20mbps to try and solve the problem......I am only getting 2.4mbps at peak times on the 10mbps package.

    Incidentally the Virgin media operator didn't seem to know the difference between MBps and Mbps - so he was accusing my imac of being too slow by a factor of 10!!
  • slughand Level 1 Level 1
    I am beginning to think this entire problem has more to do with Apple's servers than our network connections. I have been trying to watch Robin Hood since the day I got my ATV2 2 each time it tells me I have these lengthy load times before I can view it. Two days ago I went to play again and again it was going to take 90-100 minutes before it was ready to play, this was the third or fourth time I had starting loading this movie. Anyway I let it set and later it showed it was ready to play, unfortunately it was too late in the evening to begin it. Last evening I finally had time to watch and when I pressed play it came up and said it would be ready to play in 30 minutes blowing my chances again to watch it. I hit menu and then play again and this time it said it was ready to play immediately and when I pressed play it went to authorize and then played. The funny part was for all the load time it didn't show any data buffered except a small portion of the bar which continually loaded as the movie played the entire time. This tells me that the "Loading" and "Ready in ## minutes" are not valid messages showing buffering but something to do with the response of Apples streaming iTunes servers. It's funny that with all the chatter of problems on this Discussion site that Apple has been entirely silent and unresponsive to our issues. Love it when it works but until it's fixed I don't think I'll be renting anymore movies from iTunes, I'll just use what works on it instantly as it should.
Previous 1 2 3 Next