1 Reply Latest reply: Oct 10, 2010 5:57 AM by greg sahli
andrepeternell Level 1 (0 points)

a friend oh mine has a very old (pre 2004) HP Laserjet 4050, which is still going strong, but has no USB port, just parallel and Ethernet with TCP/IP and IPX/SPX (yeah).

He connected it until now on Win XP + Vista using an USB to parallel adapter cable, and it worked.

However, this does not work any more with his newly acquired Mac Book pro and SL (10.6.4). The printer will be recognized at setup and the apropriate driver (HP Laserjet 4050) will be automatically selected. But then printing (1 page Word text, 1 page Adobe Reader) will not work.
On the Mac, it will say "sending data", but there will be no indication of that on the printer, and the sending will not end after 30 minutes.

I tried to configure the printer via Ethernet/TCP/IP over a switch, with nearly the same results. But I am not sure I configured everything needed, may be I averlooked someting more special. I am familiar with configuring home networks including servers, routers, Wifi access points, printers etc.

Does anyone have any idea? Is there any special configuration trick? Do I have to use the Gutenprint driver?

This message will be posted also in HP forums.

Thank you,


MBP 15" 2008, Mac OS X (10.6.4)