10 Replies Latest reply: Nov 29, 2010 11:28 PM by Katrina S.
fostythesnowman Level 1 Level 1 (0 points)
I have two computers in my home and i am trying to share files between the two. but when i try to use home sharing it doesn't work. home sharing is on and it has the look for shared libraries checked and everything but the home sharing icon on the left side bar isn't visible. help!

Windows 7
  • Jolly Giant Level 7 Level 7 (25,440 points)
    the following is for iTunes 9 but, except the colors, applies to iTunes 10 too:


    what you want to see in iTunes is this (view from my MBP's iTunes seeing the library on my Mini)

    iTunes new

    if you then click on the house icon, it will change to this iTunes new and the shared library will load. at that point, two buttons will appear in the lower right corner of the iTunes window, being settings and import

    GrowlHelperApp

    now you should be able to import any content from any shared library by selecting the content and clicking on import.

    if the icon looks like this Apple - Support - Discussions - Home Sharing ..., home sharing has not been set up correctly.

    in order for home sharing to work

    (a) iTunes on all machines must be authorized for the same iTunes store account
    (b) all machines must be on the same network
    (c) all machines must have access to the internet.

    if none of the above makes a difference, try turning home sharing off on all computers, then turning it back on.

    these reads will be useful: one and two.

    JGG

  • fostythesnowman Level 1 Level 1 (0 points)
    by on the same network, can one computer be ethernet and the other wifi if they use the same network?
  • Jolly Giant Level 7 Level 7 (25,440 points)
    fostythesnowman wrote:
    can one computer be ethernet and the other wifi if they use the same network?


    sure, no problem.

    JGG

  • nor10 Level 1 Level 1 (0 points)
    I am having the same issue. I can access my laptop (Win7) home share from my iMac but I can't access my iMac homeshare from my laptop. On my laptop. As soon as i start home share, the home share icon disappears but I am still able to access from my iMac.

    I am on the sames networks, same itunes accounts, etc.

    Is this a windows 7 issue with iTunes?
  • fostythesnowman Level 1 Level 1 (0 points)
    Yes actuallly i hooked up both computers on the same network and there is still no icon for home sharing. i reset home sharing, changed the network, and now there should be no problem, but STILL NO ICON!
  • Pommieken Level 1 Level 1 (0 points)
    Add me to the list of very unhappy iTunes users. Exactly the same problem, but as yet, no solution from Apple. My AppleTV sits there redundant until this bug is fixed.

    I have tried EVERY 'fix' listed on this site and otrhers and absoutely none of them are fixing this issue. We need iTunes 10.0.2 to include this bug fix ASAP!
  • _BBS_ Level 1 Level 1 (0 points)
    Have the same problem with home sharing but mines laptop to desktop. I have also got Apple TV (2 Gen) and this is working fine with the Laptop.
  • fostythesnowman Level 1 Level 1 (0 points)
    and now apple has just stopped answering. they need a patch to fix this. i have tried everything previously stated now, changing networks, restarting computers, turning home sharing off and back on again... it just isn't working.
  • Sudsieb Level 1 Level 1 (0 points)
    I used to have the icon on the left hand side, now it is not there and I can't get it back on. Everything is updated, I have been through all the troubleshooting through apple and still nothing. The other 2 computers in the house can see each other, but not mine and I can't see anyone. FRUSTRATING!!!
  • Katrina S. Level 7 Level 7 (24,090 points)
    This is a user board, BTW - apple was never answering anything in this thread.



    +by on the same network, can one computer be ethernet and the other wifi if they use the same network?+


    This might be your problem. It has to use the same subnet. Go to itunes menu > help > run diagnostics. Run the network diagnostics on your wireless machine. Midway down will be something similar to this



    Adapter Name: {2AF1D78A-EE6B-4AC1-B1C8-DE25CDC80E0B}
    Description: Atheros AR9285 *Wireless Network Adapter*
    IP Address: 192.168.1.102
    Subnet Mask: 255.255.255.0




    Now run it on the wired ethernet PC. Is it on the same subnet? FOr example,
    Adapter Name: {8595CC34-384C-48A5-A944-5B7183E4EB3F}
    Description: Marvell Yukon 88E8059 Family PCI-E Gigabit *Ethernet Controller*
    IP Address: 192.168.1.105
    Subnet Mask: 255.255.255.0

    Message was edited by: Katrina S.