Skip navigation

Apple TV not showing on my Itunes?

83986 Views 60 Replies Latest reply: Mar 28, 2014 9:19 PM by gopifromca RSS
  • SwissMiss37 Calculating status...
    Currently Being Moderated
    Nov 2, 2010 1:05 AM (in response to louilepke)
    surely Apple will realize the error and fix the issue w/ itunes 10, right??? HELLO.... APPLE???? Hello...????
    Windows XP
  • SwissMiss37 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 5, 2010 4:58 AM (in response to SwissMiss37)
    Hello all - curious to know if anyone has any forward progress on this one? Sadly, I have not...
    Windows XP
  • louilepke Calculating status...
    Currently Being Moderated
    Nov 5, 2010 11:13 AM (in response to louilepke)
    There is a guy on a another discussion string that claims he has the solution to the the sync problem and posted the following, not sure if it's the same issue we are all having, but until someone else try it and let me know i am not going back to Itunes 10.1. Somebody should try it that's still on Itunes 10 and let me know:

    +Have two 40GB AppleTV's that stopped syncing at the same time.+
    +Restarted - would not sync.+
    +Did factory restore - would not sync.+
    +Then deleted 'iPod Photo Cache' folder, which is automatically created by AppleTV and is located in the photo folder that is being sync'd, and voila, all problems solved.+

    +So if you sync photos and your AppleTV suddenly stops syncing, your 'iPod Photo Cache' folder may be to blame.+
    Gateway, Windows Vista
  • ghynson Calculating status...
    Currently Being Moderated
    Nov 5, 2010 10:30 PM (in response to Tuxs1)
    Problem solved today, itwas quite simple actually. You need to make sure all of your equipment is actually on the network using an ip address. My Airport Extreme was in bridge mode it should have been assigning individual ip addresses to the ATV, laptop etc... Once this was corrected my ATV showed up in ITUNES with a quick restart of ITUNES.
    MacBook, Mac OS X (10.6.4)
  • flowerfeeder7412 Level 1 Level 1 (35 points)
    Currently Being Moderated
    Nov 7, 2010 6:33 AM (in response to ghynson)
    Any official word on this yet? I'm having this problem too. Tried everything. Nothing works.

    I've had this Apple TV since DAY 1 and no issues until now.
    iPod 30GB Video, Other OS
  • louilepke Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 7, 2010 5:51 PM (in response to ghynson)
    Don't understand what you are saying. What do you mean that "all the equipment you are using should be on the network using an IP address." Can you provide more detailed explanation? i think we all would appreciate it.
    Gateway, Windows Vista
  • Jeronimo_in_Perth Calculating status...
    Currently Being Moderated
    Nov 10, 2010 6:51 AM (in response to louilepke)
    I was struggling with this a while ago. Ready to chuck my AppleTV in the bin. I just couldn't get it to appear in itunes, even after I went back to itunes 9. Weird thing was, I could use my AppleTV to get onto youtube through my TV, so it was on my network. Then the coin dropped. I have set up my airport with a main network plus a bunch of "guest" networks. Turned out my AppleTV was on my guest network and my iMac was on my main network. No wonder AppleTV didn't appear in itunes. Doh! So went back to my AppleTV, choose the main network, and hey presto! It's there in itunes. Not sure if this helps, but I was very relieved...

    Still a bit scared to upgrade to itunes 10 though...
    iMac 2.93 Ghz, Mac OS X (10.6.4)
  • olinyon Calculating status...
    Currently Being Moderated
    Nov 15, 2010 3:13 PM (in response to Tuxs1)
    Hi,

    1 more person having the same problem since itunes 10 before was working fine. I've tried to reset, re-install redownload, check firewal, l reinstall completely itunes 10 nothing to do the appletv is not showing it is about 3 or 4 days I'm loosing my time
    Mac OS X (10.6.5)
  • louilepke Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 17, 2010 6:51 AM (in response to olinyon)
    Did you try just going back to Itunes 9 until the fix the issue, maybe on Itunes 11? Has anyone asked at an Apple Store?
    Gateway, Windows Vista
  • Fend_der Calculating status...
    Currently Being Moderated
    Nov 17, 2010 7:00 AM (in response to Chenks)
    I am uncertain why the 2nd generation does not appear in iTunes. I have just recently bought it, and assumed, based upon sites on internet, that is did, and would allow for various capabilities via iTunes.
    I take it that I was wrong on all counts, and am not stuck with a streaming device that can only play my iTunes library, when I have my mac turned on with iTunes open.
    Not really what I expected.
    MacBook Pro 13, Mac OS X (10.6.5)
  • louilepke Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 28, 2010 12:29 PM (in response to Fend_der)
    So I have been following this thread for months to see if there was a resolution to the syncing issues with Itunes 10, and I just got some free time to research more. I use A PC with Windows Vista, so I am not sure if this is the same for Mac users. I stumbled on another thread where the user said he disabled his firewall, then went into Apple TV's settings,then computers, then add Itunes library. write down the code and then reopen Itunes and then Apple TV should appear in the devices at the left of the screen. After months of not being able to sync this worked for me!! I had to go into my network and internet sharing center. It seems Apple didn't allow Itunes 10 the ability to accept info from the old ATV since the new one only streams to the ATV. At least that's my guess.
    Hope this helps!! It's got to be a similar issue with Macs as well.
    Gateway, Windows Vista
  • Man About Town Calculating status...
    Currently Being Moderated
    Jan 5, 2011 2:53 PM (in response to louilepke)
    This randomly worked for me too!

    I was about to throw my ATV off my balcony, then turned and clicked add computer on the ATV, left the 5 digits up on screen, turned back to my ITunes and BOOM! There it was.

    SUCH a pain in the *** though! Now it has to completely sync back up!
    Macbook Pro, 2.53 GHz Intel Core 2 Duo, 4 GB ram, Mac OS X (10.6.5)
  • oph1066 Calculating status...
    Currently Being Moderated
    Jun 5, 2011 4:27 AM (in response to Tuxs1)

    This is so rubbish it's obvious that apple have broken it with itunes 10. and just don't give a **** my ATV gen1 worked find then suddently stopped after upgrade.  So now the kids can't watch films on laptop and even if the re-registering via 5 digit code etc workds I will have to resync everything not great when it's on wi-fi so hours or possibly days.  Thanks a bunch.

  • concon2 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 11, 2011 10:15 AM (in response to Tuxs1)

    I had the same problem. I went to "reset settings" on ATV, then "restore factory settings". It took

    a while to download everything, but when it was done, "devices" once again appeared in Itunes, and

    now all of my songs are back on ATV. Problem solved, at least for now. I hope this helps someone.

  • Delme Greening Calculating status...
    Currently Being Moderated
    Dec 23, 2011 2:56 AM (in response to Tuxs1)

    If it's any help, I also HAD the same problem and have now resolved it.

     

    I have ATV 1 and Airport Extreme (old version) so don't have the latest features of a guest network and a private one however this sparked my interest.

    My iMac uses WiFi to connect to the network - and so did my ATV originally.  I plugged the network lead in recently when I noticed the ATV went missing from the DEVICES list in iTunes.  I switched off the ATV and restarted (same with iTunes and restarting the iMac) to no avail.  Then I remembered that there was also a firmward update a while back for the AirPort Extreme (which I dutifully installed).  I removed the network lead, restarted ATV and iTunes and hey presto! My ATV appeared in DEVICES in iTunes.

     

    I can't help but think that the latest Airport Extreme firmware update (for older models - pre Time Capsule) is somehow keeping my wired and wireless network seperate.  As soon as I plug in the cable again, it's gone from devices.  Remove the cable and connect via WiFi - It's back.

     

    Maybe a new firmware update for Airport is needed?

     

    Hope this helps!

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.