Previous 1 2 3 4 5 Next 60 Replies Latest reply: Mar 28, 2014 9:19 PM by gopifromca Go to original post
  • Che! Level 1 (5 points)

    watchfull wrote:


    Thank you, Great idea !!!  Can I do that on the MacBook too...???



    No, as far as I know there are no Apps that allow control  of the AppleTV from the Mac, but you may want to search the Mac store. The quickesy thing you can try is to replace the battery in your AppleRemote.

  • watchfull Level 1 (0 points)

    The first thing I did was to replace the battery, we checked it first and it was good !!! The ATV response to the remote , untill It get to play the contents, then it stop responding.

    The Apple Tech. told me to connect the ATV to the Mac via cables, he said use Min to USB, he was wrong, there is no Mini socket on either ...and USB to USB did not work.    Now I will try wity HDMI and with your suggestion of using iPad - before I take it in...

    Thanks for ypour help,


  • Che! Level 1 (5 points)

    One question I forgot to ask is how did you have your ATV connected? Streaming or Sync?

    If Streaming then you will not be able to play content if the ATV has lost its Pairing with you computer/iTunes.


    In any case you will need to pair the ATV and computer again, but I don't understand why you can't get to the Settings menu which is the right-most menu on the ATV. Then select Computers as mentioned earlier.


    On your AppleTV (Connected to the TV)

    1. On the Apple TV, using the AppleTV remote, select Settings menu and then Computers.
    2. Highlight Add iTunes Library and click ok to continue.
    3. The Apple TV (1st generation) generates a unique passcode. Make a note of the passcode.



    Also, check to see if you have the most up to date ATV software.


    To update your Apple TV to the current software version:

    1. Select Settings > General using your Apple Remote.
    2. Click Update Software. At this time your Apple TV checks to see if an update is available and a download message should appear if an update is available.
    3. Click Download and Install to start the download process (or Download Now on an Apple TV 1st generation with Apple TV software 1.x).

      Important: Do not disconnect your Apple TV during the update process. An Apple TV (1st generation) may flash an amber light; this is expected behavior.
    4. On an Apple TV (1st generation) with software version 1.x: When the update has finished downloading, an Update Now message should appear. To start the update process, click Update Now.


  • woosten Level 1 (0 points)

    just dandy, but the Apple TV is not in the devices list neither is it available on the preferences menu to even select to ask it to be available...

    reloaded iTunes, did all the in and out power cycling on all the pieces of the system...was working then suddenly phut it was gone.

    windows 7 64 bit, intel quad core


  • Che! Level 1 (5 points)

    First off you should ignore the computer since you need to initiate the request from the AppleTV, with the AppleTV connected to your TV. Therefore put away your computer and bring out your AppleTV Remote!


    On your AppleTV (Connected to the TV)

    1. On the Apple TV, using the AppleTV remote, select Settings menu and then Computers.
    2. Highlight Add iTunes Library and click ok to continue.
    3. The Apple TV (1st generation) generates a unique passcode. Make a note of the passcode.

    Once you've completed these steps, bring up iTunes on your computer and goto devices.


    Also make sure that both the AppleTV and the computer are on the same Wifi network. Check your router status menus for list of connected devices.

  • Alix Leigh Level 2 (150 points)

    What Che (  has described is in fact the correct method when first setting up an AppleTV.


    You can find MORE info about this AND sharing a computer (for streaming purposes only) in the Apple Doc:


    Apple TV (1st generation): Differences between syncing and streaming" )


    HOWEVER, the problem I'm seeing defined here is when things have already been set up, then suddenly no longer work. Should this be the case, If you check under "Computers" in the "Settings" menu you will most likely see the name of your iTunes library Greyed out. (see below **)


    SHARING a temporary solution)

    You CAN set your computer to Share by following instructions in the same doc under the heading:

    "How to connect to a shared computer"

    HOWEVER, this will not allow you to sync info.


    **A (not ideal but effective solution)

    If ATV 1 had been working but suddenly 'disappeared" from iTunes sidebar


    The following solution will almost surely work to regain your ability to Sync:

    1. QUIT iTunes
    2. Select "Computers" from "Settings" Menu.
    3. Select your "greyed out" iTunes library.
    4. This will bring up a window named "Disconnect from iTunes"
    5. You're now given the choice to Cancel, or disconnect. WITH THE WARNING that if you disconnect any  content synced with iTunes, will be erased. (in fact it will be removed from your ATV but not your computer)
    6. Assuming ALL of your media IS on your computer, Go ahead and disconnect.
    7. Follow instructions in the Apple doc above about setting up your ATV as a paired computer.
    8. After you ATV gen1 reappears in the sidebar. Reset all your desired syncing preferences,
    9. Begin syncing.


    All will be fine again, (at least till the next time this occurs.) I've had to do this twice this year.


    I've read alternate solutions on this board, one involved changing the name of your iTunes Library etc... you may wish to try this first (if it applies)



    What I'd like to know: What causes this problem...  I'm suspecting iTunes updates, or any iTunes database issues or crashes. Or maybe too many visitors connecting to your other Apple devices (ATV 2 for example) or heck the weather in Guatemala...



    PS: everyone here should be contacting Apple Feedback at: (unfortunately there's no current link for ATV ANY GEN)  so that perhaps they will come up with a better workaround. Since it's possible they are no longer officially supporting this product, you may also wish to make it clear that problems like this, might make you think twice befor purchasing other Apple devices.

  • MachinesTitan Level 1 (0 points)

    My Apple TV (Gen One) was connected to my iTunes for syncing once. It lasted about two weeks completely fine. Then earlier yesterday I went to sync a new movie to it and it wasn't showing up under my Device list in iTunes. My iPhone and iPad were though. So I have done the following:


    • Restarted my computer and did a soft reset on the Apple TV.
    • Restarted my wireless router.
    • Disconnected all devices from the router and reconnected them.
    • Disconnected the power from my router and Apple TV for a minute each.
    • Factory restored the Apple TV.
    • Did a complete uninstall of iTunes and then reinstalled iTunes.
    • Added iTunes to my Windows Defender exemption list, just in case.
    • Added every port used by ATV to the open list in Windows Firewall.


    Nothing has worked, it still will not show up in my iTunes Devices list at all.  The ATV can connect to the internet (same network) to download trailers and access YouTube, but it will not setup and show in iTunes for STREAMING or SYNCING.  I've tried to just set it up as a Shared Library, and that doesn't work either.


    Any thoughts would be great, this is really frustrating...

  • siamless Level 1 (0 points)

    Add me to the list.

    ATV 1st gen is not visible in iTunes anymore (just updated to 10.6.3) which did not have any effect.

    I remember times where everthing was working fine (using the SAME SETUP) BEFORE I upgraded both OSX (SL to Lion) and iTunes.

    If not forced by Apple one should never "upgrade" before reading posts - like f.e. this one!

  • siamless Level 1 (0 points)

    The article you mention ( has been last modified on 5. May 2010 . at this point everything was working fine with ATV1!

  • Eatspud Level 1 (0 points)

    There are no fewer than 682,000 posts on "apple tv not recognized in itunes" in a Google Search.  This has been an ongoing problem with Apple TV devices since their inception.  Apple does not care.  Apple gives bad support.  There is no reliable solution, except to use some other device (WDTV, cheaper and more versatile).  However, Apple TV Gen1 has one unique advantage that NO ONE else has . . . the floating picture screensaver.  To my knowlege, there is no device capable of displaying more effectively thousands (Yup, that's what I got) of photos on an HDTV with music playing during a party.  So, now that I stupidly "up"graded to itunes 10.whatever, it doesn't work.  Steps taken:


    1. Connected by ethernet

    2. Accesses the web and Apple Store (plays movie trailers) no problem

    3. Turned off firewall

    4. Turned off router security

    5. Reinstalled iTunes

    6. Factory Reset/diagnostics on AppleTV, unplugged and replugged

    7. Rebooted numerous times

    8. Restarted with all services and startups disabled except for Bonjour, Apple, iPod and iTunes services and programs


    Aaaaaand none of it helps.  Why not?  Because of buggy malware distributed by Apple.  It's why, despite Windows getting progressively worse since XP, I refuse to switch to Apple products.  So far there's not been a Windows problem I can't fix with enough looking on the web.  But when 682,000 posts suggest a problem that has not been addressed since it was first sold 5 years ago, well . . . why would anyone want an Apple product?

  • Manuel P. Level 1 (0 points)

    My fix was the same as Man About Town.


    Using Itunes 10.6.3.


    I connected the ATV Gen 1 and Imac together via Ethernet (not through router). Luckily I have both devices in the same room.


    Nothing came up until I brought up the 5 digits on the ATV and then Itunes recognized it. Synced everything, unplugged the cable putting the ATV back on wireless and everything looks fine for now.

  • Manuel P. Level 1 (0 points)

    Posting additional info to the above because I can't edit post and I want to be precise.


    Once you connect the Imac and ATV make sure you go into the Apple TV and connect it to ethernet in the internet options.

  • BaDmIsTeR Level 1 (0 points)

    Hello everybody, this will get me a heart attack.


    I have a ATV first Gen for some reason the control won't work, so I tried using the Apple APP with my iPhone and iPad no luck, I try using Ethernet cable but iTunes won't see it, I want to know if there is any way I can configure the ATV with my computer and ethernet, I can't pair anything, it's been some time know i've been trying everything I find on the web, please help me out.

  • Alix Leigh Level 2 (150 points)


    Assuming that you mean you can't control with a remote:

    The main reason this would happen is that somehow, you've (or the ghosts of xmas past) have paired a remote (ie your ATV thinks it's paired with another remote. Yes, somewhat ironic...


    The simplest (and likely only way to resolve is to first UNPAIR - choose any remote to do so...


    Here's an excerpt from Apples take on how to do so  from:

    "Pairing and unpairing the Apple Remote"

    To unpair your Apple TV from a remote

    You can use any Apple Remote to unpair Apple TV from a remote. Note: If you lose the Apple Remote that you paired with Apple TV, a replacement remote will not work until you unpair Apple TV from the lost remote.

    Press and hold the Menu and Previous/Rewind buttons on a white Apple Remote for 6 seconds, or the Menu and Left buttons on an aluminum Apple Remote for 6 seconds.

    You can also use these steps:

    1. Choose Settings > General > Remotes from the Apple TV main menu.
    2. Choose Unpair Apple Remote.

  • BaDmIsTeR Level 1 (0 points)

    thanks for the help, I have already try that and change the batteries and all, Let's say the only access is the ethernet cable which is hooked up to a modem hub where my computer and iphone are also connected, computer also uses an ethernet cable, is there anyway I can configure my atv, i try connecting a keyboard nothing happens