Previous 1 2 Next 20 Replies Latest reply: Jan 25, 2015 6:49 PM by just1203
mftoronto Level 1 Level 1 (0 points)
Every time I rent a movie from iTunes and watch on my Apple TV, the movie stops about 6-10 times. I am returned to the setup page where, after a couple of clicks on the remote I have the movie restarted.

Does anyone know how to fix this? Is it a common problem?

iMac, Mac OS X (10.6.4), Apple TV2
  • jpr76 Level 1 Level 1 (0 points)
    mftoronto - there are a number of threads running (see topic list) with respect to poor itunes streaming performance. We are not sure yet whether these are network issues or Apple server problems.

    What speed are you getting from your broadband supplier? I recommend using or something similar to measure what you are actually getting when you experience the streaming problems.
  • Ivanello Level 1 Level 1 (0 points)
    I have the same problem, it usually plays the first 3/4 of the movie fine, then stops and backs out to the description screen, where i can immediately press play and it starts right up again. Happens every 5 minutes from then on until the movie finishes. Highly irritating.

    I fiddled with my router settings to no effect, and my wireless signal strength seems ok.
    I wouldnt mind if it paused to buffer, its being kicked out to the menu that bugs me.

    My ps3 sitting right next to it streams netflix with no issues...
  • cmwild31 Level 1 Level 1 (0 points)
    I am actually getting quite frustrated with this, i play a movie or a series and after 20mins it stops and i have to fast-forward back to where it stopped. my connection is 8.2mps uninterrupted my settings seem to be ok, any thoughts or ideas ?
  • handsoffmatt Level 1 Level 1 (0 points)
    I have the same issue with my brand new Apple TV. I even tried letting the movie download completely over the course of a few hours, but still when I went to play it back, the movie keeps stopping and returning to the info screen. VERY annoying!!!
  • photorob2 Level 1 Level 1 (0 points)
    I returned the first box which did this and have 2 new boxes which do not do this.
  • vazandrew Level 6 Level 6 (17,220 points)
    I haven't done any movies but I have noticed this problem with podcasts. They wouldn't be on apple servers though, netflix and youtube work fine so i'm confused.
  • prof54 Level 1 Level 1 (0 points)
    To reiterate the discussions in this thread, I have the same problem with both Netflix and iTunes Movies.
    Netflix stops about 2x in an hour and a half movie. Need to go back to movies to "restart" where stopped. iTunes behaves very similarly, but more often. My setup is "g" wifi encrypted. I have tried wired ethernet, but my wiring for ethernet is via a power line interface to the router. It seems I have much difficulty streaming thru this type of wiring interface. Any ideas?
  • Ivanello Level 1 Level 1 (0 points)
    On the assumption that the issue is caused by poor wireless connection, I tried one of the power-line networking things instead, which so far seems to have fixed the problem.
  • vazandrew Level 6 Level 6 (17,220 points)
    Ok so I watched a movie on Netflix last night, it played flawlessly. I also have a g router. What is your connection speed out of curiosity.

    Message was edited by: vazandrew
  • Ivanello Level 1 Level 1 (0 points)
    To confirm, switching from wireless to wired connection (via power-line networking) completely fixed this problem for me.
  • sooosally Level 1 Level 1 (0 points)
    I have a similar problem. So far the only time this has happened has been when I was trying to watch something from my shared library. Mostly with movies although it has happened a couple of times with a TV episode from my library. So far watching anything directly from the internet (Netflix, audio podcasts) has not done this. I don't think it's about my router or my speed. First of all, that would be a problem for anything I'm streaming I think and so far it's only been things from my library. Secondly, I hooked up a laptop to another TV in the house and streamed one of the movies there just going through iTunes sharing without a problem. It's really feeling like an AppleTV problem. Any suggestions from the Apple group???
  • Gary Meyers Level 1 Level 1 (50 points)
    Am having the same issues but only with HD content. Ready to go back to my Apple TV 1st gen. at least the movie was downloaded to a hard drive. This new streaming *****!
  • Adam101 Level 1 Level 1 (0 points)
    Having the same problem. I think its a hardware issue. Helpline has suggested that it's a router problem but I don't think so. They suggested I try hard wiring it but I don't want to run cables across the house or pay to have someone put a ethernet point in my living room. I also have a ATV 1 wireless and it never misses a beat. All the other wireless devices in my house run fine.

    They also suggested I do a factory reset which I did. The first attempt failed and I had to do another one. This is what makes me think its a hardware issue because the first software download would not install.

    My ADSL2 speed is 13-16MBps so speed is not the problem.
    The status bar at the bottom of the screen is showing that the movie is fully loaded when this happens and has full signal strenght so it's not buffering just dropping back to the play menu.

    Very annoying considering how well my old ATV works.
    Called them back about this issue and still waiting for a reply
  • prof54 Level 1 Level 1 (0 points)
    I had posted on Oct 31st. I went to a new linksys powerline interface from wireless. Problem is gone.
    What i can only guess for now is that when wireless is interrupted, Apple TV does not recover. Obviously needs to be corrected. But, the powerline interface to my router works great for netflix and iTunes Movies in HD.
Previous 1 2 Next