11 Replies Latest reply: Dec 10, 2012 9:30 AM by DavidFromFocusriteNovation
aaronkg1 Level 1 (0 points)
When I connect my focusrite saffire to my i7 imac 27" via the firewire 800 port, the device does not show up on the computer, however it does light up indicating it is being powered off the firewire. When I click on "about this mac<more info<firewire", all I see is this " Maximum Speed: Up to 800 Mb/sec", I have checked and my "AppleFWAudio" file is up to date. The Focusrite uses Firewire 400 but I use an adaptor which converts it to 800, I have tried different adapters and cables from a number of companies which were suggested by Focusrite themselves and none of them worked.
Any ideas on what the problem could be?

Imac 27" i7 2.8ghz, Mac OS X (10.6.4), Firewire 800
  • den.thed Level 7 (26,007 points)
    Hello arronkg1

    Welcome to Apple Support Communities

    Have you checked around @ > http://www.focusrite.com/answerbase/en/article.php?id=1045

    Dennis
  • aaronkg1 Level 1 (0 points)
    Yes I have been on there, the problem is that the Saffire utilises the apple core audio driver so I cannot get it to connect as it does not show up when I plug it in.
  • AmpliDude Level 1 (0 points)
    I'm using StudioKonnekt 48 connected via firewire 400 to 800. Once connected and turned on the interface, everything looks fine and I also can use the interface as well as its control panel. But the problem is how I can disconnect firewire? After connecting firewire it doesn't show up anything on desktop! So just turning off the interface could damage the device. Is there any way to make firewire show up on desktop so that I can eject it???
  • frvr Level 1 (0 points)
    have you found an answer? i'm having the same problems with my focusrite saffire pro 24 dsp.
  • backpagefirst Level 1 (0 points)
    would be great to have a solution for this!

    anyone found a way around it ?
  • ScareMe Level 1 (0 points)

    Did you ever figure out why the firewire port powered the saffire pro 24, yet didn't act as if it were a device?  Mine is doing the same thing and there is no support line for this company in the US.  Please help if possible.

  • gregae Level 1 (0 points)

    It appears that I've joined the ranks of folks with iMac/Saffire issues.  My new Imac (OS 10.6.7) can see the Saffire (Pro 24 DSP) in the System Profiler, but it does not show up in the Sound Control Panel. I'm currently working with Focusrite Tech Support on this via email, but so far no happiness. 

     

    Has anyone gotten theirs to work?

  • chris catalano Level 2 (280 points)

    I too was having problems connecting my Focusrite Saffire to my new iMac 27" i7.  It would light up and click several times, but it would never be in a ready state w/ both LINE indicators being green.  The Saffire Control software would say the the Saffire DSP didn't load and to unplug it and re-plug and wait for the lights to turn green, but that never happened.  I called Sweetwater (where I bought the unit) and they didn't seem to know of any prevailing issues, BUT the tech did suggest to reboot the iMac in 32 bit mode (hold down the '3' and '2' keys during startup).  I did that and replugged the Saffire but it exhibited the same problem.  I unplugged it and left it for like 3 minutes then reattached the firewire cable and it mounted.  I opened up the Sound preferences and was able to select it and get sound out of it.  I then opened DP and ran a quick test and it worked as well.  The next test was to reboot into 64 bit mode.  I did that while the Saffire was still connected and it actually stayed mounted and connected upon reboot.  I have my System Sound output running through it right now and its still working.  I haven't tried DP yet, but will do that later.  I'm not going to reboot again until I hear back from Focusrite.  I sent in a help request last night. 


    Hope this helps someone.

  • SUCKA FREE Level 1 (0 points)

    ?

  • chris catalano Level 2 (280 points)

    I got a note that Sucka Free had responded to this thread, but your post is just a '?'. In any event, since I posted something here a while back and never followed up, here is what I found:  I did have a conversation with Focusrite a while back.  The conclusion was that the iMac when running in 64 bit mode cannot supply enough bus power on the firewire bus to adequately power the Saffire.  So they had me plug in the power supply and it worked fine after that. 

  • DavidFromFocusriteNovation Level 1 (100 points)

    Hi all,

     

    If you're experiencing issues with your Saffire, please contact our tech support team, where we can help each person in detail: http://www.focusrite.com/answerbase/en/contact.php

     

    If you'd rather speak to us by phone, we can be reached at (310) 322-5500.

     

    Best regards,

     

    David Tichauer // Focusrite Technical Support