Previous 1 2 Next 18 Replies Latest reply: Oct 23, 2010 3:51 PM by AnnieD333
AnnieD333 Level 1 (0 points)
When I try to login to a site, I get this message:

Too many redirects occurred trying to open “XXX”. This might occur if you open a page that is redirected to open another page which then is redirected to open the original page.

I have cleared cache, history, cookies, and reset Safari. I also tried using FireFox, but I get a similar message. Nothing has worked. Help!

I am using Snow Leopard 10.6.4.

macbook, Mac OS X (10.6.4), 2008
  • thomas_r. Level 7 (30,640 points)
    Sounds like an error with that site. Have you contacted the site admins?
  • AnnieD333 Level 1 (0 points)
    I have contacted the site and they said it was a network problem, but the others on my network can get there just fine.
  • The hatter Level 9 (60,925 points)
    Change your modems primary and secondary domain name servers to OpenDNS, Google, or even NortonDNS. has instructions and you can find the others easily enough from Google.

    This is actually common lately.
  • AnnieD333 Level 1 (0 points) didn't work. Any other thoughts or suggestions?
  • WZZZ Level 6 (12,795 points)
    Did you try OpenDNS?

    Put these numbers in Network>TCP/IP>DNS Servers, then click on "Apply"

    Then go here to see if it is working.
  • The hatter Level 9 (60,925 points)
    It? what is "it?"

    Google, Norton, logging into your modem and making the change?

    Those OpenDNS IPs should.
  • AnnieD333 Level 1 (0 points)
    Sorry...changing the settings with OpenDNS did not fix the problem.
  • AnnieD333 Level 1 (0 points)
    By the way, it only happens on my computer and on different networks. Other people are able to get to the sites with no problem on the same network.
  • WZZZ Level 6 (12,795 points)
    Did you go to the Welcome page I linked to make sure it's working?

    By the way, it only happens on my computer and on different networks. Other people are able to get to the sites with no problem on the same network.

    I don't quite understand what you are saying here, "different networks" "same network." Can you explain with some more details, please?

    Message was edited by: WZZZ
  • The hatter Level 9 (60,925 points)
    I recommended the modem (or your router/switch) so it would apply on any computer going out to the internet through that gateway.

    As for your computer, and making changes in just your Network account preferences, and why it does not work, perhaps the DNS cache has to be cleared, maybe restart or even reboot the modem or other equipment.

    To flush dns cache - from terminal:

    *sudo dscacheutil -flushcache*

    Most DNS clients cache the results of name resolution requests. This means that the DNS clients will temporarily store the website names that you have been visiting lately. This process speeds up name resolution if multiple lookups are done to the same address, such as is common when browsing the web.

  • AnnieD333 Level 1 (0 points)
    Yes, the welcome page says that it is working. I have a network at home and a network at work, with multiple computers in each location. The other computers at home and at work can get to the website with no problem at all.
  • The hatter Level 9 (60,925 points)
    From MacIntouch on DNS Security:

    Topher Kessler published an article on MacFixit recently (4 December 2009) explaining DNS and announcing Google's new public DNS service at and

    But you should probably warn your readers about the following. If you have "connections" that could shed some light on this, an informative comment might be a good idea.

    There's a BIG increase in "chatter" between my computer and somewhere "out there" whenever I switch to the (admittedly fast) Google DNS servers.

    I use the excellent DNS Performance Test utility to establish which of several DNS servers are responding most promptly to inquiries.

    BUT after switching experimentally to Google's DNS, I noticed a small "bundle" of activity spikes occurring once per second, easily seen on Net Monitor, which I keep on the desktop. None of this occurs with other DNS servers I have tried. Switch to Google and there's all this "chatter." Switch back, and it's gone.

    I don't know what is going on. Maybe this is merely an insignificant error on Google's part (polling interval too short?). But what business does Google have interacting with my computer one a second-by-second basis for any reason? I thought DNS was accomplished on an on-demand, ad-hoc basis. We know that successful DNS performance doesn't rely on this kind of "attention" activity, as other servers that respond nearly as fast (~100ms) don't do this.

    I am staying with my other choices for now until I hear an explanation or that this is fixed. I hope you can find out something and publish it.

    DNS poisoning:

    DNS vulnerability: Apple fixed a flaw in the Mac OS X Libresolv DNS software that could have allowed attackers to trick victims into visiting malicious Web sites using what's known as a cache poisoning attack [...] Mac OS X client is now doing the required address port randomization that was added in ISC's bug fix. This is needed to make a cache poisoning attack much more difficult to pull off.

    The New York Times tech columnist David Pogue publishes a glowing review of OpenDNS, writing that it's "one of the last great freebies of the Web" which will make "your Web life better." He recommends all readers start using OpenDNS.
  • AnnieD333 Level 1 (0 points)
    Thanks! I did all of these things (router/switch and clearing cache through terminal). I still get the same message. I was able to get through last week, though, so I just cannot understand the problem.
  • WZZZ Level 6 (12,795 points)
    I see you tried a different browser. Since this is specific to only one computer, just a guess, but can you try removing/clearing and then restoring all your Network settings?
Previous 1 2 Next