1 2 3 Previous Next 151 Replies Latest reply: Nov 8, 2013 7:17 AM by StephenM
e.f. Level 1 Level 1 (0 points)
I have 10.6.4 Snow Leopard Server running on a Mac Mini and am having intermittent problems with various iPhones logging into CalDAV calendars. The iPhones are a 3G running iOS 3.1.3 and a 3GS running iOS 4.1.

iCal server works perfectly, with Push, on desktop clients.

The iPhones do work occasionally. Push is still not possible (AFAIK) but 15 minute fetch interval is acceptable for now (when is push coming to iPhones btw?). However, a few times per week, sometimes as many as 5 times in a single day, the iPhone will report "Password Incorrect." This happens on its on, presumably after one of the fetch intervals. Re-entering the password usually works, and is stored correctly for hours or days, but eventually it happens again. Sometimes password is accepted after re-entry but sync will silently stop working, which is even worse than the error popping up.

Each iPhone has 3 CalDAV accounts, one of which is a delegate, one of which is shared by all. The password issue happens with all of them, but far more often with the shared account. The password incorrect prompt does NOT always happen with all of them at once, sometimes just one of the accounts will throw the login error and the others will work for a while.

On the server, iCal has Authentication set to "any method", port 8008 and SSL on, Port 8443

The iPhones connect to CalDAV with SSL on port 8443 using "server" set to server.companyname.com

I have deleted the Calendar accounts on the phones repeatedly, hardware reset the phones, deleted all data and set up accounts again. This fixes the problem for a few days but then it comes back.

I don't see much in the iCal server logs, but I might not know what to look for. What should I look for or try next?

Thanks for any help.

Mac Mini 2Ghz Intel Core 2 Duo, 4GB RAM, Mac OS X (10.6.4)
  • 1. Re: Recurring CalDAV login issues with iPhones and SLS (10.6 Server)
    e.f. Level 1 Level 1 (0 points)
    I should add that I just tried completely erasing and restoring factory OS to the iPhone 3G (3.1.3) and setting up everything fresh, and after first CalDAV account setup I get an "unable to verify certificate" error, but if I dismiss using Accept button, it still verifies account successfully and sync works. This might be because I only have a self-signed SSL certificate, but thought I'd mention it.
  • 2. Re: Recurring CalDAV login issues with iPhones and SLS (10.6 Server)
    e.f. Level 1 Level 1 (0 points)
    Also, I have noticed in the iCal server log that when a login error happens on a phone, the username does not show up in the log. For example, 2 of the usernames (used on the same phone) are "tina" and "jane". The password is entered correctly for both. An error is returned only for "jane". In the log, after IP there is a dash "-" and then username and then in brackets the timestamp, "- tina" shows up correctly but another dash is displayed where username jane should be "- -". So perhaps the username is sometimes not being transmitted correctly by the iPhone?


    166.137.136.102 - tina [13/Oct/2010:16:27:27 -0400] "PROPFIND /calendars/_uids_/8DD801B2-E109-4CC6-82F1-4D95645FCE50/ HTTP/1.1" 207 19507 "-" "DAVKit/5.0 (765); iCalendar/5.0 (79); iPhone/4.1 8B117" i=8444 t=286.7 or=1

    166.137.136.102 - - [13/Oct/2010:16:27:30 -0400] "PROPFIND /calendars/_uids_/267D7B76-AD0D-49C5-96C3-7370EBA415AA/ HTTP/1.1" 401 141 "-" "DAVKit/5.0 (765); iCalendar/5.0 (79); iPhone/4.1 8B117" i=8444 t=9.0 or=1


    And one last detail from the error logs - I'm getting this error every 30 seconds or so:

    2010-10-13 16:37:10-0400 [-] [mailgateway] 2010-10-13 16:37:10-0400 [Uninitialized] [twistedcaldav.mail.IMAP4DownloadFactory#error] IMAP factory connection failed

    What is that about? (Maybe I should start a separate thread for that, but I thought it could be related to this issue.)
  • 3. Re: Recurring CalDAV login issues with iPhones and SLS (10.6 Server)
    e.f. Level 1 Level 1 (0 points)
    This is embarrassing how much I am replying to my own thread! Just wanted to add I turned off Email Invitations and the mailgateway error went away (I thought that could work without server running Mail but I'll figure that out another time). So forget that for now.
  • 4. Re: Recurring CalDAV login issues with iPhones and SLS (10.6 Server)
    apullen Level 1 Level 1 (0 points)
    I too am getting these pop-ups, to the point where on-the-fence iPhone users are beginning to regret their use of either the phone or our server. Our issue is identical to e.f.'s.

    I've called apple three times, and they haven't had any idea what is happening, and there isn't any seemingly pertinent info in the iCal logs or the OD logs. This is also the first I've been able to find anyone else with the same issue. Any ideas would be greatly helpful.

    In our situation, we have 2 original iPhones, 4 3GSs, and 3 iPhone 4s, all with various iOSs. All phones are experiencing the pop-ups. We all share a common calendar, set up as a dummy user, then we have individual calendars, and a couple of wiki calendars that are shared between some users. In other words, our deployment is nearly identical to the OP's.
  • 5. Re: Recurring CalDAV login issues with iPhones and SLS (10.6 Server)
    Tim Harris Level 4 Level 4 (1,460 points)
    that mail gateway entry is not related to your problem. Apart from that I cannot offer any advice apart from saying loosing passwords seems to be a common iphone issue.
  • 6. Re: Recurring CalDAV login issues with iPhones and SLS (10.6 Server)
    e.f. Level 1 Level 1 (0 points)
    thanks for reply. i'm glad i'm not the only one. i would love to hear what Apple Server support says about this. i can't call them without an expensive service plan. if anyone has any other experiences or solutions, i'd love to hear about it.
  • 7. Re: Recurring CalDAV login issues with iPhones and SLS (10.6 Server)
    Xalio Level 1 Level 1 (0 points)
    Exactly the same issues!
    I'm looking for a solution, my users don't want to use their calendar on my server because of that f* password problem!

    I thought it was because I have an unsigned certificate, any idea?
  • 8. Re: Recurring CalDAV login issues with iPhones and SLS (10.6 Server)
    e.f. Level 1 Level 1 (0 points)
    what's the best way to get a signed certificate to test?
  • 9. Re: Recurring CalDAV login issues with iPhones and SLS (10.6 Server)
    Xalio Level 1 Level 1 (0 points)
    Verisign, i think it's free for 15 or 30 days trial...
  • 10. Re: Recurring CalDAV login issues with iPhones and SLS (10.6 Server)
    apullen Level 1 Level 1 (0 points)
    Tim Harris- the iPhone forgetting passwords must be different. The message will pop up seemingly when the phone is first starting to connect to the CalDAV calendar. There are two options: enter your password and hit ok or just hit cancel. They both produce the same result of your iPhone connecting with the CalDAV service. It is like it hits a snag when first trying to connect, often when the phone wakes from sleep, but occasionally when in the middle of use. By the way, this seems to happen under all connectivity profiles, 3G or wifi.

    e.f.- Our server had a valid signed certificate and we have connected via SSL and non SSL. I don't believe that the phone has Kerberos capabilities so I believe it connects only via digest. Although I don't yet fully understand Kerberos, so I might be way off.
  • 11. Re: Recurring CalDAV login issues with iPhones and SLS (10.6 Server)
    e.f. Level 1 Level 1 (0 points)
    That's interesting that caldav login still works if you hit Cancel instead of re-entering password. Can you see in verbose log exactly what happens?

    Also I'm curious, can someone explain the "- -" to me in logs? I'm not that familiar with log/unix syntax.
  • 12. Re: Recurring CalDAV login issues with iPhones and SLS (10.6 Server)
    Tim Harris Level 4 Level 4 (1,460 points)
    I'm not sure this is a 'server' issue or 'iphone' issue. The fact that the problem goes away when you down grade, sort of suggests iphone related.

    i assume you are in a fixed IP address and your ISP is hosting the DNS records for you?
  • 13. Re: Recurring CalDAV login issues with iPhones and SLS (10.6 Server)
    deeky1981 Level 1 Level 1 (0 points)
    Same issues. I don't use the SSL. From time to time the phone will work great, syncs to Snow Leopard server through the iCAL with CALDEV. My desktops sync nicely, both the Macbook and my Windows Desktop using thunderbird.

    It seems when I notice my iphone 4 stops syncing calendar will be preceded by a request for a CALdav password to my Mac Mini Server sitting at home. I can cancel, all seems fine. But I believe that is where the breakdown occurs and the phone simply stops syncing and fetching.

    I find that a phone restart gets things going again for me.

    I'll have to play with this some more as I haven't realized it was a problem until I just started looking around and found this thread. I'll keep my eyes on this here to see if anybody gets anywhere with it.
  • 14. Re: Recurring CalDAV login issues with iPhones and SLS (10.6 Server)
    e.f. Level 1 Level 1 (0 points)
    How many of you find that syncing works again after the login error, and how many find that phone needs to be restarted (or some other intervention)?
1 2 3 Previous Next