Previous 1 7 8 9 10 11 Next 151 Replies Latest reply: Nov 8, 2013 7:17 AM by StephenM Go to original post
  • fabianschaefer Level 1 Level 1 (0 points)

    I just got the authentication dialog with my iPad 1 3G with iOS 5 Beta. It seems that the problem not has been fixed in the iOS yet or that the Server itself cause this Problem. I'll do some tests with Lion Server to find out if it has been fixed in 10.7 and report the result.

  • Afro Garach Level 1 Level 1 (0 points)

    I don't have the authentication dialog any more!

    Problem solved for me. This is the solution:

     

    "I tried what Adrian had suggested.

     

    I edited the /etc/caldavd/caldavd.plist

     

    Setting Basic to true and Digest to false.

     

    <key>Basic</key>

         <dict>

              <key>Enabled</key>

              <true/>

         </dict>

    <key>Digest</key>

         <dict>

              <key>Algorithm</key>

              <string>md5</string>

              <key>Enabled</key>

              <false/>

              <key>Qop</key>

              <string></string>

         </dict>

     

    Then I restarted the iCal Server and have tested it with multiple iPhone & iPad (running 4.3.3) using an SSL connection.

    I have not gotten an authentication dialog in days. *yippee*

     

    Hope it keeps on working and it also works for you guys as well."

     

     

    +


     

    "I may have found a solution and recognized the problem. Like most of us I'm running Snow Leopard Server and have iCal Server running using SSL connections. My certificate is self-signed, like I imagine most of our's are. Recently I remembered seeing some post, somewhere, on installing certificates on the iPhone. On a hunch, I installed the certificate I use for my FQDN for web services on my iPhone. It's been about 2 days now and I haven't seen a single authentication dialog and calendars are working.

     

    To install a certificate on your iOS device you need to email it to yourself as an attachment. Click on the attachment and it will as if you want to install. It installs as "Not Trusted" and I don't see any method to make it trusted. You will see the certificate as a Profile under Settings > General > Profiles.

     

    To get at the certificate.cer file, I dragged it out of Keychain Access on my desktop and then emailed it to myself.

     

    I don't know if this is a real solution, but so far it's working here. I hope more people will be able to demonstrate whether it's effective or not."

     

     

    After apply the mod at the caldavd.plist and install the certificate in 10 iphones everything now goes fine. Thanks for the help!

  • Adrian Nier Level 1 Level 1 (0 points)

    My personal opinion about self-signed certificates is that they shouldn’t be used outside of a test installation. If you do so in a production environment you’re either doing too much work or neglect protecting your users by desensitizing them to security alerts that should be taken seriously.

     

    On the other hand the whole system is broken anyway, so why bother right?

  • jpawelchak Level 1 Level 1 (0 points)

    I have not edited caldav plist and am sorry to report that the problem still exists running iOS 5 on my iPhone 4 and iPad.  Apple seems to be ignoring the fact that this issue exists.  I have reported it as a bug on the Developer Report a Bug site.  The Issue ID is: 9651468

     

    I can also confirm that the reported issue is not related to self-signed certificates and I have a wildcard cert issued by Verisign.  On the topic of self-signed certificates... If you are using them in a production environment you are doing a your company and/or clients a great disservice not to mention your standing as an "IT Professional". I refuse to present self-signed certs even as an option to my clients and haven't received a single complaint about the expense from any of them. Spring for the $600 or so a year and purchase the real deal. :-)

     

    Message was edited by: jpawelchak

  • Adrian Nier Level 1 Level 1 (0 points)

    For smaller installations, where only the iCal and/or Address Book service is exposed to the Internet, a domain-validated non-wildcard certificate should be sufficient. Those are much more affordable.

  • jpawelchak Level 1 Level 1 (0 points)

    Absolutely agree! My point was not to be using self-signed certs. I just typically purchase wildcard because the installations I support have typically required one and the one time I did purchase a non-wildcard I ended up needing one down the road. :-(

  • josephcorbett Level 1 Level 1 (0 points)

    Well this is exciting! Looks like we are finally getting an official fix for this bug with the release of 10.6.8! The error on rare occasions would occur with cardDAV as well so who knows if they really squashed it. I've already updated and plan to remove my changes to the plist file just to double check that the bug is really gone. Hopefully Lion Server will be earth shattering so I can forget about this year long pain in the butt feature, we'll just have to wait and see.

     

    Calendar Services

    - Improves reliability of processing international character encodings.

    - Improves authentication support for iOS devices.

  • Adrian Nier Level 1 Level 1 (0 points)

    It’s been a week of testing two separate installations of Mac OS X Server 10.6.8 and there wasn’t a single authentication dialog for the CalDAV service. It seems that the update actually fixed the issue and I closed the bug report. http://openradar.appspot.com/radar?id=669401

  • MustardParty Level 1 Level 1 (15 points)

    Just want to add for the record here: the latest server update seems to have squished this recuring login issue.  It has plauged me for months and months, but so far it's been a whole week and so far so good.

  • stc23 Level 1 Level 1 (0 points)

    The issue occurs only 3 times since the latest SL Server Update. Bevor: 3 times every day.

  • thelizardo Level 1 Level 1 (0 points)

    So I am suddenly getting this repeated request for the CalDav for my yahoo account about 15 times already today. No recent updates.  What could be happening?

     

    Thanks

  • bildur1 Level 1 Level 1 (0 points)

    I started getting the same request for CalDav password. There were no updates, no recent changes to the apps or settings. The only thing I had done was access "my verizon" to view my bill.

     

     

    I had been reading through this thread and on the frst page I read someone had suggested tapping the home button twice which opens a small screen showing all open programs on the phone. I was suprised to see that I had about 20 apps going. I chose to close all programs manually by holding down on one of the apps. This caused all open programs to shake and display the red dash in the upper corner. I closed all programs and then I rebooted the iphone.

     

    I have had no issues with the CalDav error since then. I think it solved the issue.

  • FEFWmsbrg Level 1 Level 1 (0 points)

    My wife has this problem all the time and she was not savvy enough to know what caused it so she simply cancelled it and accepted that it would return periodically .   I laughed but It does work without a fix. Some one in Apple needs to resolve it for folks like my wife. It can't be that hard to resolve given all I read already from the masses of users screaming instructions and problem details. I say -use the cancel button and move on. It will get fixed when someone says that they are concealing their contract to buy because of it..

  • josephcorbett Level 1 Level 1 (0 points)

    Hey Guys,

       You're probably posting in the wrong thread, this was an issue with password prompts popping up on the iPhone when the phone was setup to work with Snow Leopard Server calendar services. The issue here was eventually fixed by Apple with a patch to SLS. I reccomend you hunt down a more relavant thread if you want to get some answers. Best of luck!

  • dancetoday07 Level 1 Level 1 (5 points)

    You say that this issue was fixed by Apple, but it just started for me about a week ago.  I was trying to sync calendars with an app called Intuition that is a sort of To Do list organizer.  It was supposed to Sync with my iPhone, Mac and iPad calendars by going through Google Calendars.  It had me log into Google.  Immediately the error messages started.  They go away after repeatedly touching either Cancel or OK. They seem to work equally. But like other people have said, they pop up 15-20 times a day, usually when I first log in to the phone (security code) or when I change apps.  This is what it says. 

     

    Password Incorrect

    Enter the password for the CalDAV

    account "Lucy's Calendar"