1 2 3 4 5 Previous Next 151 Replies Latest reply: Nov 8, 2013 7:17 AM by StephenM Go to original post
  • 30. Re: Recurring CalDAV login issues with iPhones and SLS (10.6 Server)
    swithed2mac Level 1 Level 1 (0 points)
    Same here. iPhone iOS 4.2 (and earlier) keeps prompting for password. Happens a couple times a day. Initially I thought that high CPU utilization on the server was the problem, but turned out it wasn't. Tried restarting the iCal services and/or restarting the iPhone. After these actions the pop-up seems to be gone for a while.

    Also no problems with other clients. iPhone is the only one suffering from this. Highly annoying.
  • 31. Re: Recurring CalDAV login issues with iPhones and SLS (10.6 Server)
    deeky1981 Level 1 Level 1 (0 points)
    Two weeks ago I went ahead and submitted some type of report to Apple about this just to make it official. I have heard nothing.

    Sometimes I can go for a day or two and not have the problem, sometimes I have the problem three times a day. I wish I could develop a "this is what happens to cause this and reproduce it."

    Overall - it works pretty well. If I had to deploy this is many users as a company - I would be embarrassed to make my users deal with this. As a home server user, it's just me.
  • 32. Re: Recurring CalDAV login issues with iPhones and SLS (10.6 Server)
    e.f. Level 1 Level 1 (0 points)
    i can also report an update to 4.2.1 did not resolve the problem. i submitted a bug report to apple a few weeks ago and i got an email asking me to attach a device log from the phone. so that's promising that someone is paying attention. that means the more people submit a bug report, the faster something will be done about it. so do it. http://bugreport.apple.com

    as a template, here is what i entered:

    Problem ID: 8659967

    Summary: iPhones and iPads running iOS 4 repeatedly see CalDAV authentication error despite correct login credentials. iCal Server running on 10.6.5 server. Problem occurs on both wifi and 3G. Re-entering password works for a few hours, then fails again.

    Steps to Reproduce: Sync calendars on any phone with iOS 4. iOS 3 phones also experience the problem, but less frequently.

    Expected Results: Correct login should never have to be re-entered

    Actual Results: "password incorrect". sync stops with no further error messages.

    Notes: many others posting on Apple Discussions have experienced the same issue. iPhone demonstrated same issue after iOS 4.2 update. Log from iPCU attached.

    RESPONSE FROM APPLE:

    Engineering has requested the following information in order to further investigate this issue:

    Could you please attach your device log to the bug report. Device logs can be retrieved via the Organizer in Xcode. Or, from the iPhone/iPad Configuration Utility:

    1. Download and install iPCU from http://www.apple.com/support/iphone/enterprise/
    2. Launch iPCU, then connect device with USB cable
    3. Click the Console tab in iPCU
    4. Reproduce the problem
    5. Click the “Save as” button to save the log to a text file.
    6. Attach the text file to the bug report
  • 33. Re: Recurring CalDAV login issues with iPhones and SLS (10.6 Server)
    swithed2mac Level 1 Level 1 (0 points)
    Going through the steps you provided. Will post the console log to the Bug Reporter. Thanks
  • 34. Re: Recurring CalDAV login issues with iPhones and SLS (10.6 Server)
    swithed2mac Level 1 Level 1 (0 points)
    My bugreport regarding this annoying feature is: 8699817
  • 35. Re: Recurring CalDAV login issues with iPhones and SLS (10.6 Server)
    thatwilson Level 1 Level 1 (0 points)
    Hi All,

    Same here with the symptoms. iPad pre 4.2.1 never asked for a password, while iPhone 4 on 4.1 did. iOS 4 onwards seems to be th problem.

    One question for all involved (may seem random) do you have the "encrypt all packets (requires SSL or kerboros)" enabled in the Open Directory policies binding page of server admin?
  • 36. Re: Recurring CalDAV login issues with iPhones and SLS (10.6 Server)
    swithed2mac Level 1 Level 1 (0 points)
    My current workaround is to tap the home button twice. This shows the open/running programs. Hold the Calendar app for a couple of seconds (things start to jiggle) and close the Calendar app. Press home to stop the jiggling. Open the app again and it runs fine (until it crashes again)

    Message was edited by: swithed2mac
  • 37. Re: Recurring CalDAV login issues with iPhones and SLS (10.6 Server)
    chafer Level 1 Level 1 (0 points)
    Ditto to the problems described in this thread.
  • 38. Re: Recurring CalDAV login issues with iPhones and SLS (10.6 Server)
    Mike JM Level 1 Level 1 (0 points)
    Probably no need to pile on at this point, but just want to say: ditto that ditto. We're experiencing this bug also, and it's making our entire company's userbase question the wisdom of using iPhones and iCal Server. Really a major, gigantic problem.
  • 39. Re: Recurring CalDAV login issues with iPhones and SLS (10.6 Server)
    Frando Level 1 Level 1 (145 points)
    The same issue. SLS 10.6.5 and iOS4.2.1. Always asks for CalDAV and CardDAV passwords. Reset device twice, no changes. v SSL enabled on OD.
  • 40. Re: Recurring CalDAV login issues with iPhones and SLS (10.6 Server)
    Todd Fleisher Level 1 Level 1 (5 points)
    Problem ID: 8715764

    Summary:
    iPhone repeatedly prompts for CalDAV authentication error despite correct login credentials. When this happens the iCal in question is not in sync with the server. OSX Server version is currently 10.5.8 (though the issue affected previous 10.5.x releases as well). Testing also shows this occurs with OSX Servers running all version of 10.6.x up to the current release of 10.6.5. iPhones running multiple versions of iPhoneOS/iOS from 3.x to 4.x are affected - all the way up to the current release of 4.2.1

    Steps to Reproduce:
    Setup a CalDAV iCal on an iPhone to sync to an OSX Server running the iCal service. I can't say what triggers the problem to occur as the timing seems to be randomly distributed across many events: unlocking the phone after idle time, reboot, normal device operation (non-idle device), etc. But at some point, you will be prompted for incorrect username/password for your CalDAV account on the iPhone.

    Expected Results:
    The iPhone CalDAV account should remember the correct credentials and not become "disassociated" from the OSX Server repeatedly - prompting the user to re-input the username/password to the account.

    Actual Results:
    The iPhone CalDAV account repeatedly prompts the user to re-input the username/password to the account. When this happens, the iPhone CalDAV account becomes "disassociated" from the OSX server in that it is no longer in sync - updates to the OSX Server iCal on other devices aren't seen by the iPhone & updates on the iPhone aren't sync'd to the OSX Server iCal.

    Regression:
    n/a

    Notes:
    See this discussion thread for numerous users experiencing this problem: http://discussions.apple.com/thread.jspa?messageID=12687136#12687136
  • 41. Re: Recurring CalDAV login issues with iPhones and SLS (10.6 Server)
    swithed2mac Level 1 Level 1 (0 points)
    Looks like it's a known 'feature'. I got the following reply on my bug report:

    +This is a follow up to Bug ID# 8699817. After further investigation it has been determined that this is a known issue, which is currently being investigated by engineering. This issue has been filed in our bug database under the original Bug ID# 8434401. The original bug number being used to track this duplicate issue can be found in the State column, in this format: Duplicate/OrigBug#.+

    +Thank you for submitting this bug report. We truly appreciate your assistance in helping us discover and isolate bugs.+

    +Best Regards,+

    +Patrick Collins+
    +Apple Developer Connection+
    +Worldwide Developer Relations+
  • 42. Re: Recurring CalDAV login issues with iPhones and SLS (10.6 Server)
    josephcorbett Level 1 Level 1 (0 points)
    Christmas has come early! I want to start by saying how good it feels to finally discover a group of people that are experiencing this issue. I've been suffering from this problem for more than two months now and have felt very alone. I've questions my abilities as a novice admin at every turn until I think I've figured it out and then the problem comes back and totally crushes my morale. Overall this problem makes me look like an ***** because I'm supposed to make everything "just work" and I just can't stamp this one out.

    Anyway all the symptoms you have described are in line with what I have seen, in fact the recent release of IOS 4.2.1 seems to have made it worse. Prior to this release I believe I could just hit cancel on the password prompt and everything would be fine, but now I'm seeing that it just disables fetch altogether.

    *Failed Solutions...*

    - Changing the time zone
    - Disabling Time Machine
    - Upgrading Users to Admin
    - Disabling SSL
    - Drinking heavily

    *Treating the Symptom...*

    I don't have a cure for this issue, but I do have what I think is something that keeps it from happening frequently. Approximately EVERY 24hrs I run Disk Utility and Repair the permission on my server Main HD. It SEEMS to me that this reduces the frequency of this error popping up. I have to admit thought this could just be a placebo effect because I REALLY want something to work.

    *Moving Forward...*

    Hopefully we'll see a solution in the near future. I'd also like to see if this issue happens on other platforms like a blackberry or a Nokia 96. If i get around to trying this out I'll hit you guys back.

    <Edited by Host>
  • 43. Re: Recurring CalDAV login issues with iPhones and SLS (10.6 Server)
    josephcorbett Level 1 Level 1 (0 points)
    This forum straight up moderated me. So sad...
  • 44. Re: Recurring CalDAV login issues with iPhones and SLS (10.6 Server)
    e.f. Level 1 Level 1 (0 points)
    Hear, hear!

    What got "moderated"?
1 2 3 4 5 Previous Next