Skip navigation

Apple TV 2 has big problems homesharing - fixes?  firmware update needed!

125864 Views 283 Replies Latest reply: Dec 25, 2013 10:27 AM by jamesn00 RSS Branched to a new discussion.
  • ThoricCLA Calculating status...

    When I said 10.5.1, I meant 10.6.1 (ie, the latest version available yesterday 1st April 2012)

  • manpowre Calculating status...

    I have the same problem with ATV3 and latest Itunes which I downloaded today. Itunes 10.6.1.7.

    I also have latest version of firmware update for ATV3.

     

    I have a more complex network in house, with socket cable. but I took a looooong cable between HW switch in living room and PC and turned on home sharing, nothing in between the two devices than a cable and a hardware switch. still the same.

     

    I turned off windows firewall, restarted, same problem.

     

    I disabled vmware devices (yes I have vmware installed on my windows 7 machine.) as vmware shares IP adress with the vmware device. same problem.

     

    I will try to uninstall vmware now, as the network device theoretically can interfere even disabled, but just a theory. dont think that changes anything though.

     

    ATV1 worked just fine in my house for years. even playing movies from itunes. once I got ATV3, it didnt work..

     

    I will try to put my ATV1 in and see what happens with same setup.

     

    This seems like software bug for sure.

  • Floyd O\\\'Neil Calculating status...

    Did you read my reply to you earlier.  It is this version of iTunes causing the problem, I am certain!

  • manpowre Level 1 Level 1 (5 points)

    I agree that there might have something to do with the software.

    I have uninstalled any software on my windows 7 64 bit that has multicast functionality as service. one of these is the splashtop application which can remote a pc from ipad. apple sells the splashtop app in appstore for ipad. and a service is needed on windows. same problem after uninstall and reboot. however, I do see better performance. I now managed to play 15-20 minutes into a movie before I drop out.

     

    Since there is a drop out, I suspect this to be related to multicast drop out. yes, fix in bonjour/itunes has to come. but I am curious if I have any other multicast systems on local network.

     

    I installed the bonjour browser for windows.. guess what ?

    I have a denon airplay capable device, and a DM800 device which broadcasts multicast.

     

    So now I will try to turn off DM800, and disable denon from network.. and see what happens since bonjour detects these devices.

     

    Ill give an update after I disable these and try to play a new movie and see how long it lasts.

     

    (earlier, I did let these two devices stay on the HW switch, so they still broadcasted on the local network..

  • manpowre Level 1 Level 1 (5 points)

    well, that was a quick test, stopped streaming very quickly after I dropped the network connection for DM800 and Denon airplay enabled reciever...

     

    still, interupted and loosing connection from ATV3 to Itunes.. through home sharing..

     

    I did check the bonjour browser, and the bonjour software still had the DM800 registered and also the airplay denon reciever registered . Then I restarted bonjour service (I have the latest one), and now testing agian..

  • manpowre Level 1 Level 1 (5 points)

    restarted machine, as the ATV3 locked, and now I dont get to load video even.. weird..

     

    well, I have uninstalled:

    Vmware

    Splashtop


    Stopped bonjour service and started it again after stopped other local multicast devices as DM800 and Denon reciever.

     

    Restarted after I tried to take away devices that has multicast, and now bonjour browser only shows atv and itunes registered. nothing else, still problem persists.

     

    This has nothing to do with wireless communication as ATV and main machine are both cabled. I tried to connect direct connection between the two with a HW switch (no sw on the switch) and still same problem.

     

    I cant see anything than that this has something to do with Bonjour sw disrupting multicast stream or something.. something disrupts the connection betwenn ATV3 and itunes latest version from yesterday.

     

    I really hope Apple can look into this fast, as the ATV3 is now only a fancy good looking device in the living room.. I cant even use it..

  • manpowre Level 1 Level 1 (5 points)

    well,

     

    I disconnected main PC, moved the clip to my work laptop, with same version of itunes. both 64 bit windows 7.

    Then connected my AppleTV3 to the laptop, and streamed the clip off there just fine.

     

    the weird thing is that the laptop is on wireless, same network. no physical changes, just to another PC.

     

    so there doesnt seem to be an external multicast device that is interrupting the stream atleast. neither a service on the PC, as the PC that has the problems with itunes has been on all the time.

     

    So, this is why Apple has a hard time to track it down.. it is not reproducable in the lab most probably.

  • beegeeuk Calculating status...

    I have had this problem before with a previous version of iTunes. After updating to V10.5 the problem disappeared only to resurface in the latest version 10.6.1.

     

    It's got to be a problem with iTunes!!

     

    I am now using my PS3 to stream movies/videos with absolutely no issues and will continue to do so until Apple can assure me that the problem with ATV2/iTunes has been addressed and fixed!!!

     

    As others have said - my ATV2 is now an expensive paperweight!!!

  • Wendell_WoW Calculating status...

    I have a slightly different issue with the ATV2 and iTunes.  When I initially power up the ATV, everything is just fine, finds my library with no issues.  Selecting a movie works fine, and it downloads fast (using a TRENDNet power line network adapter since the wireless was sketchy). 

    However, once I'm done watching the first movie, any subsequent movie I select and try to watch will take forever to download.  Sat watching the whirly wait/loading indicator for over 15 minutes.  The first movie I watched took maybe 5 seconds to load enough to start playing automatically.  Even if I restart the ATV, it still bogs down and won't load in any reasonable time.  The following day it will work flawlessly, but again only for the first movie I watch.  Second one will once again not load.  Tried going back to the wireless, didn't help.  The same movie (while creeping on the ATV) loaded up and started playing just fine on my iPad.  Memory caching issue?

  • Charmiepoo Calculating status...

    I've had this happening since the latest Apple TV update. It never happened before that.  Homesharing just drops out at random intervals. The only way I can get it back is to close out iTunes and then start it back up.  Very annoying. I've tried all sorts of "fixes" suggested in these threads, to no avail. I have no problems watching Netflix movies or viewing my Photo ztream or Flickr account, etc., it's only with homesharing. I do not sync any of my devices wirelessly. Another new bug since the new update is that if I try to use shuffle mode when listening to my music, about third or fourth song will quit about halway through and it advances to the next song. At first I thought the shuffle thing was an iTunes Match problem, but then discovered it also happens in Homesharing.

  • TheRightSider Level 1 Level 1 (0 points)

    I have the ATV 3. It is wired to the switch/router that also acts as an internet modem. The router is given by the internet provider that runs VLANs on it so I can't get it replaced.

     

    Anyway the ATV3 just drops home sharing after 5 min. I need to restart itunes from my computer for another 5 mins.

     

    I have done all I can read from the threads here. Open ports in window firewall, updated all software and firmware, reinstall itunes, reset ATV 3, tick off IPv6 in adaptor, choose non 128 bit SSL in advanced adaptor settings and more.

     

    Still have 5 min of home sharing uptime on ATV3, every time. This needs to be fixed.

     

    I am a windows user. I had wanted to swtich to Apple as I think it is about time I get something that is easier to use. I like a mac ecology of the ATV, iphone and macbooks. But my first foray by getting ATV3 has not been good so far. I shouldn't need to go to this level of user troubleshooting and Apple expecting me to self help with others like me.

     

    When I have a trouble with a win7 update, I sent an email to MS and they had someone email me daily to troubleshoot till it gets done. With Apple I have no such options. Only a line to call which they don't tell me when is their office hours, just that it is outside their office hours and call later. Incredulous. How can I be calling when I am in the office and ATV3 is back home?

     

    I hope soon there is an update that can do the trick. But right now. Apple is not very much better than MS in user experience. It is better in areas, but worse off in others by my experience now.

     

    What I need now is a new Apple.

  • Illini2011 Calculating status...

    I am also having this problem.  I turned off wifi syncing on my 2 iphones and ipad (previous suggestion from above) and that allowed me to get further along in the movies but it still kicks me out randomly.  My wifi connection is solid and 5 bars so I assume that Apple needs to fix it on their end.  I have an Apple TV 2 but all those people who purchased Apple TV 3 are going to be ****** and think the product is not good if they don't fix it soon.  I use it mostly for kid's movies and my wife is starting to get pretty frustrated with it always shutting off.  I never had a problem before the last update please fix Apple.

  • manpowre Level 1 Level 1 (5 points)

    I reallly dont understand why Apple doesnt comment on these problems.

     

    We are now going into Easter holiday time without a working appleTV to stream the purchased content that relys inside Itunes on the PC or Mac.

     

    Atleast give us a timeframe, will be fixed within next patch or something.. its all dead quiet for a really annoying problem that basically makes it almost impossible to watch a tv series or a movie without restarting itunes 3-5 times.

  • manpowre Level 1 Level 1 (5 points)

    I read in another thread that the itunes.xml file might contain some data from old version of itunes which doesnt make home sharing happy.

     

    so, anyone tried to delete the xml file, and reimport everything ?

     

    I can try this tonight.. I guess that explaines why some ppl, and myself got it working from a laptop, which has a clean library when I installed the new version..

     

    My library is a few years old now, so the xml file, so there might be something that kicks out home sharing within the xml data file.

  • tillathenun Calculating status...

    For the past two days mine has been absolutely fine.

     

    Here's what I did – Lord knows whether it made a difference:

     

    • I unplugged the ATV and left it for ages unplugged

    • On starting it up everything looked strange (I only had the Computers and Settings icons - nothing else like Rentals)

    • I restarted the ATV

    • The Internet was also restarted – surely that's not anything to do with it?

     

    Oh, and the iMac from which the content is playing now has a fixed IP address instead of DHCP. Surely that's not it?!...

     

    Anyway, so far (touch/knock on wood), no trouble.

1 ... 4 5 6 7 8 ... 19 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (4)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.