Previous 1 2 3 Next 283 Replies Latest reply: Dec 25, 2013 10:27 AM by jamesn00 Branched to a new discussion.
draper3000 Level 1 Level 1
After 5 days of having ATV2, (which is lovely when its working) I'm still having problems narrowed down to Homeshare access from ATV2 to my macbook running the latest itunes.

I've just moved house and got a new broadband router and provider the same day as the ATV2, so it has taken a while to make sure it was not the router (BT home Hub 2), the connection, or my macbook itself.

Macbook - (Running Snow Leopard) Internet working fine with router and broadband, (have removed all network settings, removed passwords in keychain and repaired permissions, restarted and re-entered network info - just incase).

Router - works fine all day, with macbook and dell laptop, Have tried restarting a lot just incase

Apple TV 2 - works fine with broadband and router, and I can browse the online selection of videos, youtube etc fine.

Homeshare - When I connect ATV2 using homeshare to my macbooks itunes account, it works for a maximum of 2 minutes then loses connection. And my macbook which still shows full wifi signal can no longer get the internet, and forgets the wifi password and says its wrong when I re-enter it. Only fix is to restart router and delete network settings on macbook and re-enter them.

So is this homeshare technology screwing up, Apple TV 2 screwing up, or my router jumping in after a couple of minutes and saying NO!.

Is anyone else experiencing exactly the same as me?

Its a shame that the only thing I've found left to try (after searching alot of forums) is when turning on 'Homeshare in Itunes' don't press the 'DONE' button. Will give that a try tonight.

MacBook 2008 model, Mac OS X (10.6.4), In the UK
  • Cleverclou Level 1 Level 1
    Hi all,

    I experienced almost the same. I try to connect my library from Itunes now since 3 days and it will not work.

    The latest I found out is, that my other PC (Win XP) has no problems to connect via homesharing with ATV2. As soon as I put my homesharing to "on" the ATV2 finds the library. Also the connection between my Win7 and my Win XP PC works fine with homesharing. But the big question is, why the connection between my Win7 PC and ATV2 is not working?????
    I tried all explained in support section including uninstalling and reinstalling iTunes. I switched my firewalls of, opened designated ports in the router, used the same Apple IDs, used static IP addresses, rebooted all devices and last but not least I've sent a ping request to the ATV. Also this was successful. No packages lost in inbound and even outbound.

    So Apple, now it's your turn!!!! I think, that there must be a bug in the Win7 version of iTunes.

    By the way: I experienced the same issue of complete lost of WIFI as draper3000 explained before. That happens sometimes when I try to setup the homesharing with my iPhone4 Remote App. The only solution then is a complete reboot of the router...

    Clecerclou from Germany
  • draper3000 Level 1 Level 1
    Will try out of interest to see how well it works with my wifes Dell laptop running Windows Vista.

    As well as trying the not pressing 'DONE' button in itunes after turning on Homeshare.

    Any one else had any success?
  • Cleverclou Level 1 Level 1
    Oh I forgot to say: The thing with the DONE button did not work for me.

    Tomorrow or on weekend I will try another laptop to make shure that the problem is not caused by the router.
  • draper3000 Level 1 Level 1
    Thanks for the reply.

    Ok, got home and finally after cooking, bathing and putting our 9 month old daughter to bed I got to play around with the Apple TV 2 problem.

    I'm pleased to say the 'not' pressing the 'DONE' button seems to be working, it is keeping the Homeshare connection live, and has done for the past 2 hours. Far better than my previous 2 minute record.

    The connection was however very very very very very slow (like 30 seconds to load one video thumbnail), and made the internet very slow on my laptop and on the apple tv. But after now changing my BT home Hub wireless channel to 7, it seems to be working a lot better. If it drops again I will try the other available channels. Worth noting that as soon as homeshare is going the apple tv must start emitting another frequency that was screwing with my router. I've also left my laptop with a static IP, (again may change back if needs be).

    This is by no means the end of the problem as having to open itunes and not press 'DONE' doesn't seem very cool and I'm sure Steve Jobs will be quite annoyed that his lovely new Apple tv is a little bit crap.

    We shall see if it is still working tomorrow morning, I'll leave it all on and see if it stays connected all night.

    Unfortunately my wife is now watching normal crappy TV and will have to wait for her to go to bed to test the connection a bit more thoroughly....Avater in 720P over homeshare is waiting!!! and has been for 5 days!!!
  • draper3000 Level 1 Level 1
    Ok, so 10 minutes into Avatar and the connection has gone again. My laptop forgotten password for wifi again. Have to reset router, and retype password.

    So the fix of not pressing 'Done' worked for probably 3 hours in total.

    Will try again and have just change wireless channel to number '1'.
  • YW84NE1 Level 1 Level 1
    Have any of you tried going to the General Settings and doing a Restore? If not give it a try. I had some issues and after I did a restore everything has been smooth sailing. If that doesnt work, call 1-800-APL-CARE. You're call will be covered under your 90 day free phone support
  • draper3000 Level 1 Level 1
    Thanks for reply. I did try that early on as people said that doing restore seemed to install new firmware even though none is supposed to be available. Didn't work then, but may give it another go.
  • draper3000 Level 1 Level 1

    Spent ages on phone to Apple support they are sending a replacement. Mainly to fix the screen going green now and again which is a known issue.

    Also have tried AppleTV2 at my work and it stays connected fine.

    So the problem falls back to my stupid BT Home Hub 2.
  • SecrtSqurl Level 1 Level 1
    It has to be a problem with Home Sharing. Once set up everything works fine. If I browse in music, I can do almost anything in there with no problems. If I leave music and go to movies, it will still work until I try to leave. When I leave the home sharing shuts down in Itunes even though it is still showing as connected. (in advanced tab there is a menu item that says "turn off home sharing") If I click that, to disconnect, and then re-connect, the apple tv sees the library again, and will work fine until I try to "leave" the movie section again.

    Both of my 1st gen Atv"s still work without a problem.
  • draper3000 Level 1 Level 1
    problem solving continues...

    Ok so my apple tv at home works fine with an old gateway router but the internet connection is alot slower. And my apple tv works fine with my works wifi, both of which are non 802.11n .

    So the current thinking is perhaps my laptop has issues with 802.11n when home sharing.

    The BT Home hub two that I'm having problems with supports 802.11n as should my laptop.

    So is it an airport extreme card problem in my laptop?

    Do I buy a whole new 802.11n router? (really the new home hub 2.0 should be fine).

    Do I buy a new 802.11n USB stick for my laptop? in the hope that my airport card is dodgy, or at least the firmware is?

    My airport extreme card is a (0x14E4, 0x88).
  • paulkellighan Level 1 Level 1
    my apple tv wouldnt see my itunes libary until i turned off wifi security '
    works great but now any one can bump of my wifi tried hiding wifi name lost itunes lib again turned it of bingo fine derivin me nuts will try only allow certain mac address in
  • Petesmith07 Level 1 Level 1
    Did you look at your energy settings? My mbp settings had the hard drive sleeping when possible. I also adjusted my sleep settings and don't have problems. If you close the MacBook it goes to sleep.
  • draper3000 Level 1 Level 1
    Ok have solved the problem my end.

    Found lots of people saying the version of airport extreme in my. MacBook even though it is supposed to be 802.11n happy it has lots of issues with n.

    So I bought a 9.99 USB wifi stick which works with n. Turn off airport extreme and use this USB stick instead and connection works fine and as yet has not dropped at all.

    MacBook is about 3.5 years old. Shame apple didn't keep updating drivers for this particular model.0

    Still get the hdmi handshake inverted colours problem, but apple are supposed to be working on a fix for that.
  • Denis Evans Level 1 Level 1
    I have cured the problem. I have just turn my Apple TV2 off and everything started to work again!
Previous 1 2 3 Next