Previous 1 2 Next 25 Replies Latest reply: Oct 7, 2014 2:30 AM by curly41 Go to original post
  • JWCole1982 Level 1 Level 1 (0 points)

    I have this exact problem on my 2010 MB Pro with ML. I haven't found a solution, yet. If I resize the window, it will work for a while, but will end up reverting to the truncated window after a period of time.

  • Tim Fall Level 1 Level 1 (65 points)

    In case anyone is still having this issue, the window positions are saved in the mail preferences plist, so you can manually edit them. In general there are also window position saving applications, that can do this for other things as well.

  • Larry McJunkin Level 1 Level 1 (30 points)

    Tim, you can edit the plist all you want but each new message window you open is going to always be slightly right and down from it's last position.  Probably one of the biggest annoyances in Apple Mail since its inception.  I wouldn't look for Apple to do anything about it...they haven't so far.

  • Tim Fall Level 1 Level 1 (65 points)

    Larry McJunkin wrote:

     

    Tim, you can edit the plist all you want but each new message window you open is going to always be slightly right and down from it's last position.  Probably one of the biggest annoyances in Apple Mail since its inception.  I wouldn't look for Apple to do anything about it...they haven't so far.

    They likely haven't "done anything about it" because it seems like a bug, not normal behavior. It would be a good idea to find out what's causing that issue.

  • Larry McJunkin Level 1 Level 1 (30 points)

    As sad as it is, I think this is the expected behavior.  I personally hate it and it's one of the biggest reasons I only use Apple Mail for a "non-critical" email account I have. 

  • Tim Fall Level 1 Level 1 (65 points)

    That should be the expected behavior when opening multiple windows ontop of one another (so they stack slightly). It should not be the behavior when only opening (and closing) a single window.

  • Larry McJunkin Level 1 Level 1 (30 points)

    Couldn't agree more.  However, I have tried for six or seven years to find a fix for this and it just doesn't exist.

  • JurisP Level 1 Level 1 (0 points)

    what seems to work (on OS 10.8), though not an entirely satisfactory fix, is when maximizing the mail screen w/ "green window button" (don't confuse with Full Screen). When Mail App is in maximized mode, the new mail message windows appear in same center position + the next new messages stack neatly in a row next to the first one.

     

    I understand that this is not the desired solution, but a better one for me, compared with the ever-flying new message windows.

  • Fred J21 Level 1 Level 1 (0 points)

    From a previous post:-

     

    Open Mail, then close the "viewer window" (so that you have no windows open at all). Next, select File>new message and a window opens. Position this window where you would like it to be. Close this window.

     

     

    Worked OK for me.

  • Kymbo The Violin Stuntman Level 1 Level 1 (10 points)

    i tried that Fred J21, didnt work. After doing your procedure, when you open a new window, the new window still opens in a lower position.

     

    anyone found a solution for this yet?

  • curly41 Level 1 Level 1 (0 points)

    My problem:

    Whenever I open a mail it's showing up on the left bottom side with a very small window size. I'm using OSX 10.8.5 MacBook Pro and the Thunderbolt monitor. My mail runs in the classic mode (hope my translations from the german text is identical with what you see in english).

     

    Seems that the following method does the trick:

     

    1) Uncheck in the Mail preferences/display  "Use classic mode" … you get the modern Mail-design

     

    2) Open a mail and reposition that window the way you want to get it in future as default

     

    3) Close that mail and re-open it … the new position should be used. Open another mail … same effect

     

    4) Start with cmd+N a new mail and send it to your own address

     

    5) Quit Mail

     

    6) Open Mail and put the checkmark back in the preferences  "Use classic mode"

     

    I suspect, that what actual triggers and preserves the new adjustment is the switch from one design to the other and back i.e. this might also work if you run Mail in the "modern mode" - in that case you should try the above approach but set the classic mode temporarily . I described all of my trials though I suspect, that step 3+4 may not be required.

    By the way - this has survived a re-start of my computer

Previous 1 2 Next