Previous 1 2 3 Next 38 Replies Latest reply: Nov 25, 2014 8:11 AM by jawshoouh Go to original post
  • RTVIII Level 1 Level 1 (0 points)
    Reporting same problem on iPad. HUGELY frustrating...what a ridiculous oversight, that they have not included a simple check box to alleviate this problem.
  • ArthurDent999 Level 1 Level 1 (5 points)
    +1 from me too...

    This is incredibly frustrating. I run my own small email server for me and my family with a self-signed SSL certificate. I have no possibility of getting a Verisign or similar certificate.

    This has been happening constantly since I upgraded to OS4.2 and has meant that I have missed being alerted to the arrival of an important email on more than one occasion.

    What I can't understand is the fact that I am given the option to "accept" the certificate (which I think is a perfectly appropriate security measure) but that having accepted it, it does not "remember" the fact that this is now a "trusted" certificate.

    Does anyone at Apple read this forum? Can anyone give an explanation as to the intended behaviour here and, most importantly, tell us how to fix it or tell us when it will be fixed by Apple?
  • RickyB. Level 1 Level 1 (35 points)
    Apple explains the situation here:

    http://support.apple.com/kb/TS3585?viewlocale=en_US

    I just hope they have another fix planned than simply recommending we "follow Microsoft's best practices for Forefront TMG and install the Root Certificate Authority (CA) certificate on the iOS 4.2 device."
  • chatboy Level 1 Level 1 (0 points)
    Hi all,

    I think there are serveral ways that we connect to the email server.

    Exchange is one - which the solution of adding port 443 may have worked.
    I am subscribing to a POP server.

    As such, there are 2 places where you define your Outgoing mail server. With these settings, it worked for me.

    Settings -> Mail, Contacts .. -> POP mail
    -> SMTP (and)
    -> Advanced

    In SMTP -> Primary server
    Use SSL - OFF (I know that this may not go down well with many of you
    but it works for me )
    Authentication: Password
    Port -25

    In Advanced ->
    Use SSL: ON
    Authentication: Password
    Server port: 995

    Good Luck!

    Message was edited by: chatboy
  • ChessMonger Level 1 Level 1 (0 points)
    My work email has a self signed certificate. I used to be able to get email through webmail w/o any problems. I just updated my iPhone4 an iPad to 4.2 update and this issue popped-up. This used to happen in the older versions of the iOS but when you accepted the certificate as safe just once, it just went away. Now, the "Accept" button (under Details) does not seem to have a lasting effect.
  • methos1973 Level 1 Level 1 (0 points)
    I have an iPhone 3G running iOS 4.2.1 and the cause of my message was that my phone was trying to connect to a guest network at my job. I went into Settings - Wi-Fi then under the Choose a Network... section I chose the guest network and punched the Forget this Network button. It seemed to stop the Verify Identity message from popping up when I try access my email on my phone. BTW I was having this issue while on a 3G connection and not on any Wi-Fi network.
  • DanT3HMan Level 1 Level 1 (0 points)
    Mine keeps saying:
    Safari cannot verify the identity of Facebook.com. Would u like to continue? Everytime and it is VERY annoying..how can I fix this so this message wont keep appearing??
  • 91RS Level 1 Level 1 (0 points)
    iPhone 4, upgraded to iOS 4.3 last night in the dream that it would be fixed but still having the same issue with email, driving me crazy and makes email on this thing a waste of time almost.
  • HugoPT Level 1 Level 1 (0 points)
    I had this problem with my work e-mail, Apple Support provides this article - TS3585, a bit unclear.
    My goal was to install the Root Certificate Authority (CA) certificate on the iOS 4.2 device.
    All I had to do was navigate with iPhone 3G Safari to a web page where I could download my corporative root certificate (crt file, the same I install in my home pc with internet explorer). You'll know you're good when you access the file and a configuration wizard page pops up for a new profile, I accepted and installed the certificate and now I'm good again!
  • Gtvdhaak Level 1 Level 1 (0 points)
    Hi, im using an iPad with3G (witch is disabled), and using at home my wifi network with key, and at work an other wifi with server certificate. Now the're is my problem, everytime i'm switching between home and work i get this server certificate error like "cannot identity servercertificate". When trying to acces the from the exchangeserver.
    After Tapping About 12 times i can go one, but it's driving me crazy. Who knows the solution?
  • Eswara Moorthi Thanaraj Level 1 Level 1 (0 points)

    This will happen when we attempt to access some public wi-fi (say X) at office and failed to establish connection and we might have forgotten about this attempt. Whenever our phone is brought into that X range, it will keep accessing internet with the help of X but fails eventually. Solution as on iOS5 : Settings->Wi-Fi->(Traverse thru all the wi-fi connections that your phone shows in the problematic location and enable) 'Forget about joining this network' for that X.

     

    Note : This option 'Forget about joining this network' will be displayed only for X which you've attempted to connect earlier. Other Wi-Fi will not display this option. Hope this helps !

  • Tim from Paramus Level 1 Level 1 (0 points)

    I am using an iTouch older version, without camera.

    When at work , we have a WIFI Guest (in addition to WLAN used for company e-mails). I have the id and password for the guest WIFI but whentrying to login I got the message:

    Cannot Verify Server Identity. WI-FI can't verify the identity of "1.1.1.1". Would you like to continue anyway? I have 3 option buttons: cancel, Details and Continue.

    When pressed Detail I got the message "Not Trusted".

    Does not matter which of the 3 options I have selected I can not check my personal e-mails (aol or gmail). I have Internet access after selecting Continue and entering the login ID and password.

    What else I can do? IT does not handle personal devices to access personal e-mails!

  • YaserAlbahrani Level 1 Level 1 (0 points)

    Hi ,

     

    I had this problem with my iPad earlier this day.

    I chacked my date and time .. It was advanced a little bit .. Re agest the date and everything works perfect now!

     

    Hope that was usefull

  • busyguy714 Level 1 Level 1 (0 points)

    This one drove me nuts.  My iPhone 4s was syncing fine and we upgraded to the new build. Then it stopped working.  My IT group spent days on our 2003 Small Business Server and couldn't figure it out.  I finally found someone who fix our problems within 30 minutes for a flat fee.  Not sure why I didn't find him sooner.  Here is their site:  iphone exchange setup experts . They truly saved me and our law firm many extra hours of frustration.

  • Kid_Menegh Level 1 Level 1 (0 points)

    Go to app store abd pick "SSL Detective".  Run and insert ie: "static.ak.facebook.com"  or "smtp.gmail.com" or "www.google.com" and send by email. Open email and install the certificates.

     

    works for me.