Announcement: Update to iOS 12

Enjoy a faster and more responsive experience as well as fun new features, like Memoji and Camera Effects.
Get iOS 12 > https://support.apple.com/ios/update

Looks like no one’s replied in a while. To start the conversation again, simply ask a new question.

Question:

Question: Cannot verify server Identity on Iphone 4 on 3G

Hi,

I have been using my Iphone 4 for almost 2 months now in my office where there is no Wi-Fi network. So, I use 3G network.
Recently, every time I start using my phone (irrespective of If I am using internet or not), I get this error message -
"Cannot Verify Server Identity
Wi-Fi can't verify the identy of "10.1.1.1" Would you like to conitue anyway?
The buttons are - Cancel / Details/ Continue."

Irrespective of the button I click, I am taken to a log-in screen. I have no idea which login id or password should I enter? Also, my 3G contiue to work. This error message does not affect my internet access. Moreover, when I am at home and using Wi-Fi, this error never crops up.

I never had this problem ever before. And Its turning out to be pretty irritating. Even if I click the Photos, this error crops up.

Can you let me know what can I do to get over with this error?

Iphone 4, iOS 4

Posted on

Reply

Page content loaded

Oct 28, 2010 11:38 AM in response to miliaxy In response to miliaxy

I believe you will see this message when there is a WiFi base station that is broadcasting it's SSID and is unencrypted. It appears to be that the iPhone is trying to verify a digital certificate, typically used by an SSL transaction. That's when I see it - at work when connecting to one of the WLAN broadcast points. It's sort of goofy though as there is no WEP/WPA/WPA2 encryption being used by the base station, so not sure why this message is being displayed.

Perhaps, this occurs because the iPhone is attempting a Web transaction (see the 'http://www.apple.com' that appears at the top of the window when this message is displayed). The iPhone will attempt to make a Web connection in order to prompt you for a userid / password if needed by the base station to access the Internet.

Same thing happens when you are at an airport or other public Wi-Fi provider. You just don't see the error message, but see a login screen typically instead.

So, I think the message is rather bogus, as I can normally login to my work WiFi after choosing continue.

Net Net : Someone added a WiFi base station in at your work and you are seeing this message because your iPhone is attempting to connect to the Internet through the new base station. You can choose to turn off the feature of automatically attaching to new WiFi networks in the General settings area.

Oct 28, 2010 11:38 AM

Reply Helpful

Nov 15, 2010 12:11 PM in response to Mark Thacker In response to Mark Thacker

This message has nothing to do with an unencrypted wireless connection. It has everything to do with a mail account trying to connect via a secured SSL connection. You get this message only while on wifi as the address of the server you are connecting to is in a private IP range. When you connect via 3g you do not normally have the ability to access these other private subnets without added routing information.

The underlying issue most likely is that the SSL certificate being used is self-signed and has not been issued by a trusted Certificate Authority (CA). You can simply accept the certificate and it will allow you to send/receive the email as normal. Some hosted email on custom domains also used self-signed certificates (trusted CA issued SSL certificates cost money and self-generated ones are free for the host).

Nov 15, 2010 12:11 PM

Reply Helpful

Nov 24, 2010 7:20 AM in response to Aaron Goldman In response to Aaron Goldman

There is no current workaround.

Turning off SSL is NOT a workaround, unfortunately. Doing so can be a security issue as you are now transmitting usernames & passwords in the clear.

I see you found the other thread, though. Good. 🙂

It is also important to note that this NOT specific to Microsoft Exchange - this issue is affecting anyone that has a self-signed certificate.

Nov 24, 2010 7:20 AM

Reply Helpful (1)

Dec 9, 2010 1:05 PM in response to miliaxy In response to miliaxy

+1, this is an annoying issue since the 4.2 release. This is almost as annoying as the itunes loss-less playback quibble. Hey Apple, you're turning into Microsoft.

My small ISP is not going to pay for the certificates, so this means I'm stuck with two extra annoying clicks (and waits) every time I send an email now? Why was this ok before but not now?! It should actually save the "accept certificate" option. If it must, ask me a "are you absolutely sure" question, but dont nanny me. I'm a big boy now.

Dec 9, 2010 1:05 PM

Reply Helpful
User profile for user: miliaxy

Question: Cannot verify server Identity on Iphone 4 on 3G