Previous 1 4 5 6 7 8 Next 116 Replies Latest reply: May 1, 2012 9:15 PM by jhwitt Go to original post
  • jonfromweymouth Level 1 Level 1

    So my latest news is this:


    If I plug the Apple TV into my Panasonic TV directly I must select Dolby Digital to On.

    If I plug the Apple TV into my Denon AV amp I must select Dolby Digital to Auto.


    Any other combination results in "This content cannot be displayed"

    Providing I select the right Dolby Digital option, all is good.

  • David Sharratt Level 1 Level 1

    Thanks Andrew,


    Appreciate your help.

    Tried switching to WEP - no joy unfortunately. All software up to date on AEBS, Base Station, ATV2 and machine. Cannot think what other variables there are.


    Disk sleep - turned off

    Machine sleep - turned off

    Firewall - explicitly set to accept iTunes

    Even tried Multicast rate low

    Switching channels for the 2.4GHz doesn't make any difference.


    Think this one is over to Apple.....despite the fact they do not acknowledge there is an issue


    Appreciate your help trying


  • scotty1553 Level 1 Level 1

    I successfully set up the home sharing and the music works after a long delay. The video does not work at all. How is this product such a piece of ****. I guess the solution isn't to fix it but instead create I cloud so we have to pay monthly. Thanks a lot Apple.

  • Poligeek Level 1 Level 1

    I fought the same problem for a week.  First I read and attempted the fixes that worked for others to no avail.  The I got on the phone with Apple, and they suggested some of the same fixes, but not as thorough as this forum.  In this process, I fully restored the ATV2 twice via iTunes, unplugged it untold number of times, changed the Dolby setting, changed the HDMI cable, changed the HDMI out setting, tried a different HDMI input on the TV, and generally banged my head against the wall.  Ran speed tests from my PC through ISP and was getting 7+ Mbps download speed.  Failed to mention I am using a wired ethernet connection to the ATV2, not a wireless, but in the testing I connected it to the wireless newtork instead to see if that helped but it did not.  After all this, still got the error loading content if I tried to watch a Netflix video, tried to send a video to Apple TV from my iPad2, or tried to watch a video (HD or SD) from already downloaded to my shared iTunes.


    So I went to the local Genius Bar, laid it all out, and without any additional discussion, they gave me another ATV2.  Brought it home, set it up. SAME PROBLEM.  Repeated all the steps above, no help.  Then I noticed the 10/100 5 port ethernet switch I had in the cabinet sending internet to a variety of devices, including the ATV2.  I disconnected the feed from the switch and plugged it directly into the ATV2, and without even unplugging/rebooting the ATV2 the problem went away.  Everything worked. Despite my speed from the ISP, the switch between the router and the ATV2 was slowing it down too much.  So why didn't the wireless work?Well the wireless access point I was using in the living room was feeding off the same switch.


    Hope this helps someone.

  • Cbbowers84 Level 1 Level 1

    Switching the audio setting to auto when connected to my receiver seems to have fixed the issue with my movies streaming from my iMac. It also fixed my issue with streaming Mad Men from Netflix. Very strange...doubt it's a permanent solution but worth doing if you're receiving the "an error occurred while loading this content" message and you're connected to a home audio receiver.

  • Adam van Gaalen Level 2 Level 2

    Me too! While being streamed from my MacMini running MacOS X Lion all play just fine on my 160GB AppleTV but some of them will not play on my AppleTV2.

  • Adam van Gaalen Level 2 Level 2

    I remember I had a similar situation long ago, with my 1st AppleTV...

    The solution then was: Make sure you have just one soundtrack...


    So, since neither switching dolby settings nor adding a chaptertrack, as suggested above, worked for me, I re-m4v'd the failing DVD, using HandBrake, while making sure that I was using 'AppleTV'-settings with just ONE audio-track enabled.


    Seems like that did it...

  • Jalad Level 1 Level 1

    Same issue as OP. It's odd though, I wasn't having this issue with ATV2 until today when I purchased a bunch of movies and tv shows. Prior to today, I had no issue streaming tv shows I had previously purchased. I didn't have any movies before today on my macbook to have attempted so I don't know if it would have worked.


    But like I said, it worked all last week and the week before when I had just purchased it. I thought it might be a busy wifi network but that doesn't seem to be the case as I'm the only one using the internet right now and i have no downloads or uploads going on except for this webpage.


    no fix yet?

  • GSpyder Level 1 Level 1

    I posted a fix on another like thread here :



    Hope that helps...


    Should be at the bottome of the page - Gspyder is my screen name and of which the fix is posted.

  • ray sharpe Level 2 Level 2

    Apple TV 4.4.4 fixes video playback error

  • Biscuits81 Level 1 Level 1



    No it doesn't. I have Just recieved this issue this morning. After weeks of renting and streaming from imac.

  • jhwitt Level 1 Level 1

    Thanks, GSpyder, that seemed to fix mine.

Previous 1 4 5 6 7 8 Next