Previous 1 2 3 4 5 6 Next 116 Replies Latest reply: May 1, 2012 9:15 PM by jhwitt Go to original post
  • stocknigma Level 1 Level 1 (0 points)
    One thing that I've notices is that the path of my itunes folder reverts back to its default path which is directly on my mac instead of my server. So, I generally will go into preferences, advanced settings to redirect my itunes file path back to the server on which my itunes is located. Hope this helps!
  • s'Mart Level 1 Level 1 (0 points)
    Yup, I'm also getting this error - content works fine on ATV1 but fail with the "An error occurrd loading this content" on both my ATV2's

    currently running v4.1.1 of the ATV2 OS

    Mart.
  • atv2user Level 1 Level 1 (0 points)
    Purchased an ATV2 last week. Watched a bunch of movies streamed from iTunes on my desktop. All of these movies contained a DD5.1 soundtrack that worked perfectly.

    Yesterday I went to play back one of these same files and it didn't work. Got the "An error occurred loading this content." error instead. Tried everything to fix it including rebooting the ATV AND doing a factory restore from iTunes. Still didn't work. If I disabled 5.1 audio the files would play fine, but obviously there was no surround sound.

    Out of curiosity I rented a movie from the ATV2 (one that had a 5.1 soundtrack). The rented movie started up and played perfectly (5.1 and all). So I stopped the movie and went back the the list of movies on my computer... and they all started working again (5.1 audio too).

    So to troubleshoot this a bit further I used the ATV2 for a bit to see if I could make the files stop working again... and I found a way to consistently reproduce this issue. So I'm going to post the steps to break playback of all files streamed from iTunes that have 5.1 audio in hopes that an Apple engineer might read this and eventually fix this problem.

    *Steps to reproduce this issue*
    1. Play an audio file from your iTunes library on the ATV2.
    2. While this file is playing navigate threw the ATV2 menu and play a video file from your iTunes library (one with DD5.1 sound).
    3. You should now see the infamous "An error occurred loading this content" error and all video playback of DD5.1 containing files from your iTunes library will be broken. Multiple reboots, factory restore, nothing will make it work correctly.
    4. Rent a movie on the ATV2 that contains 5.1 soundtrack and play it.
    5. After the movie has played for a minute or so stop playback.
    6. Go back to the videos shared via iTunes. They should play correctly now. And they will continue to play correctly unless you do step one and two again.

    So if you want to play video files on the ATV2 streamed from iTunes don't play music via iTunes. Or be prepared to rent a movie on the ATV every time you play music on the ATV to fix the issue.

    Hope this helps.
  • F1234K Level 1 Level 1 (5 points)
    Actually it seems to be simpler to break and fix than this:
    If you play something (anything) with a stereo only track then it gets broken for all things streamed via iTunes NOT bought from iTunes store with a DD track until you play something which was bought from the iTunes store with a DD track.

    So playing anything bought/rented from iTunes with a DD track will allow you to play your movies you ripped with Handbrake etc. until you either play something with a stereo only track, turn it off or let it go to sleep.

    I have a TV show I bought ages ago which has a DD track that I have to play EVERY time I start my ATV (from sleep as well!!!) before I can watch anything else that was NOT purchased from iTunes since practically all my content has a DD soundtrack.

    This is incredibly annoying to say the least. I am also quite surprised it hasn't been fixed yet as it seems to be a trivial fix and easily reproduceable.

    This has been happening on my ATV2 since I got it about 6 months ago and there have been updates since which have not addressed the problem, so either the Apple engineers don't know about this bug or don't care.
  • atv2user Level 1 Level 1 (0 points)
    I spent some more time trying to troubleshoot this and I found a fix that works for me.

    It seems that the ATV2 gets tripped up when trying to load a m4v file that has two enabled audio streams (one 2 channel AAC and one 5.1 channel AC3). Files from Apple, and also files directly exported from HandBrake, have the 5.1 channel stream set to disabled by default. The files that have the 5.1 stream disabled are the ones that when played 'fix' playback for other files.

    It seems that some encoding/tagging tools export files that have both streams enabled. Not sure which app is responsible for this because I've used a bunch of them.

    These files can easily be fixed using MP4Box (cli tool available for Mac, Linux, and Windows).

    MP4Box -lang eng -disable 3 "<filename>"

    This sets the default language for each track to English (useful for tracks that say "unknown language" in the ATV interface) and "disables" the AC3 track.
    MP4Box modifies the file in place so it is very fast. With a quick and dirty bash script I was able to fix every file in my movie library in less than 30 minutes.

    The ATV2 has no problem selecting and using the "disabled" AC3 track automatically. It actually expects it to be "disabled." I presume that was done for backwards compatibility for devices that don't support Dolby Digital.

    I can now play everything in my library (2 channel, 5.1, music, vides) without errors (i.e. it works just like the ATV1 did).
  • atv2user Level 1 Level 1 (0 points)
    Since I can't seem to edit a post here..

    *Be careful using the MP4Box method above!*
    (in fact, don't do it)

    I didn't notice it originally, *but it seems to corrupt the metadata in the file in a way that can't easily be fixed.*

    To fix the corrupted files I had to extract all of the streams and then create a new file. Then I had to scrape/add metadata to all of them again.

    Will see if I can find a better way...
  • jwdenmark Level 1 Level 1 (0 points)
    mwardy wrote:
    Hi again ive managed to sort this now I read somewhere else on here that someone thought it was to do with chapters and yes they are correct all of the films that would not play had no chapter markers.
    I have converted the films again this time splitting into chapters and merging back to one film and this now works. Hope this helps
    Mark


    Thanks for this suggestion. Seems the same situation with me. All of the videos that have problems playing do not have a chapter track.
  • Murray Reid Level 1 Level 1 (0 points)
    My situation that generates this error is entirely different. On first attempting to view a TV show with my ATV2 I get this error. I then go to iTunes select the show (has exclamation point beside it now), select "get info". It then comes up and gives me a "locate" window. I select the file and click OK. The exclamation point goes away (metadata remains intact). Go back to ATV2 and select it again and it now loads/plays.
    All my video content is stored on an external hard drive. The ATV2 connects via ethernet.
    I am suspecting that the ATV2 has too short a timer somewhere, such that the time it takes to get the media streaming off the hard drive (in my case) causes the timeout. Fixing it (the exclamation point) in iTunes causes file info to be cached by the OS, so the next ATV2 attempt goes faster and the timer doesn't trip.
  • Jon Walker Level 6 Level 6 (17,970 points)
    On first attempting to view a TV show with my ATV2 I get this error... All my video content is stored on an external hard drive.

    The usual cause for this problem is an attempt to load/view the content via an TV before the external drive is completely online. Once the error is generated, iTunes does not automatically clear the error nor will it attempt to actually re-read the file once the error is generated. By "re-locating" the file once the drive is up and running, you manually clear the error. The normal solution here is:
    1) if the error occurs immediately on start-up, turn on the external drive before turning on the computer, or
    2) If the error occurs after a period of idle time, wake up the drive (or turn off the drive sleep option) before accessing content via the TV device.

  • tijean Level 1 Level 1 (0 points)
    This was driving me nuts. I concluded that the problem was with the metadata endoding re chapters in some of my movie files. Specifically, the files did not have any chapter data for some reason. I used a program called SimpleMovieX to open the .m4v file in my iTunes library, inserted a couple of chapters in each of the malfunctioning files, saved them and now they open up just fine. Good luck!
  • sandler77 Level 1 Level 1 (70 points)
    I'm still seeing this problem as well, but only with files greater than 4.00 GB. These also are the same files that for some reason after the AppleTV iOS 4.2 update don't show the movie descriptions that are metatagged to do so. The files were all showing this metadata information before the last iTunes and AppleTV update, so I'm sure the bug is somewhere in one/both of the updates...
  • nikkivj Level 1 Level 1 (0 points)
    I just fixed my issue with the error. I was unable to view anything from my computer as well as had issues with Netflix. The fix seems to have fixed all the problems. I'm going to ask you move a file to your desktop so make sure you can still see your desktop as you are performing these steps.

    1) Close out of iTunes
    2) Go to the "Music" folder/directory directly under the username of the itunes library you are using to connect to your Apple TV
    3) Open --> iTunes Media
    4) Move the file "iTunes Music Library.xml" to your desktop (if this works, you can delete it later)
    5) Open iTunes and try to open a movie or something that were unable to view on your Apple TV before. Make sure you have Apple TV as the source output.

    You should be able to now play your files without the "An error occured loading this content" message. The file you moved from the "Music" directory to your desktop will recreate itself. Also, if you were having issues with Netflix, try viewing a Netflix move as well. For some reason, it fixed my Netflix issue as well. You can delete the file on your desktop.

    I thought about this based on an issue I experienced some time back when I needed to move my itunes library from one computer to another.

    Hope it works for you!
  • sandler77 Level 1 Level 1 (70 points)
    I tried this... No success. The issue now is showing up with files larger than 4GB in size. Also, these are the same files that cannot be metatagged within iTunes using the script that was the temporary fix for the "descriptions" issue that hundreds have described in another AppleTV thread. Somehow, iTunes and/or AppleTV are not jiving on certain files and have some sort of communication breakdown when it comes to iTunes libraries. It is not all files, but I am willing to bet that the files you had problems with before you reset the iTunes XML file were all under 4GB in size, so it seemed to correct itself. Again, the files under 4GB should work fine either way, but with more and more movies being released in HD (Blu-ray) and/or sold in HD via iTunes, the file sizes are getting larger and larger.

    What is so special (and not so Apple friendly) about the 4GB size?
  • sandler77 Level 1 Level 1 (70 points)
    So I thought I had a solution, but it was only temporary. As others described, I reset and restored everything:

    1. I erased my entire media library and reimported all movies back into iTunes.
    2. I reset and restored AppleTV via the unit and remote. Unfortunately, after reinstalling the original software, it seemed to download and install the latest software update (iOS 4.2 that has this and other continuing problems).
    3. I reset my router, just in case.

    Result: my videos that were showing this error message worked. I only tried a few that I knew were problematic, then watched a single movie in it's entirety. As soon as the film ended, I tried one of my previous concerned movies that showed this "an error occurred loading this content. Please try again later." message. As I expected, the issue(s) are back and everything is as it was before my resetting everything.

    I am also still having this issue as well with the metadata descriptions not showing up on the AppleTV without running a script to edit the files after importing into iTunes: http://discussions.apple.com/thread.jspa?threadID=2776725&start=0&tstart=0. I also have the screen flicker issue as described by hundreds of others as well...

    I will continue to send feedback to Apple and hope that Apple techs read these boards and consider them as leads to problems and future software fixes. Does anyone know if Apple ever responds to these discussions, or are we just hoping to figure out our own solutions to Apple's new "Hobby" that unfortunately got an iOS update full io bugs?

    Any help is appreciated and always welcomed.
  • sandler77 Level 1 Level 1 (70 points)
    I just got this tip from another thread of the same problem:

    System Preferences>Network>AirPort>Advanced>TCP/IP>Configure IPv6 = Off

    I tried this and somehow it seemed to work as of now, but I want to give things time to see what happens. A possible fix until Apple releases an iOS update? Maybe. Try this and see how it works for those having issues with ATV2 and the "An Error Occurred Loading This Content, Try Again Later" error...
Previous 1 2 3 4 5 6 Next